[Testing Update] 2020-07-10 - Kernels, Deepin, KDE Apps 20.04.3, Firefox 78.0.2

DITTO @pierrep56 which kernel. I'm thinking of trying the 5.8 and see what I get.

@philm
Updating via TTY I get:
error synchronizing all databases
Updating via zsh everything is o.K.
+++++++++(Kernels: 5.4 / 5.7 / 5.8 )++++++GNOME+++GDM+++
EDIT.: sollft /solved: is not fully correct
the service dhcpcd was disabled.
...
now:
dhcpcd 0 enabled and running
NetworkManager-dispatcher = enabled - not running
NetworkManager-wait-online = disabled - not running
NetworkManager = enabled - not running
...
TTY and/or zsh o.K.
...
EDIT: the correct solution!
...
Own goal shot: in settings / network connections
I unhooked the hook "available to other users"
With this, e.g. "root" can not use the net for TTY...
....
Eigentor geschossen: in Einstellungen / Netzwerkverbindungen
den Haken bei "anderen Benutzern zur Verfügung stellen"
weg gemacht - damit kann z.B. root nicht ins netz für TTY...
...
Und im Übrigen kann man statt "NetworkManager"
dhcpcd benutzen - das hat den Vorteil, dass nun alle user
auf das Netzwerk dürfen und den Nachteil:
Meldungen wie: enp0s04: DHCPv6 REPLY: who are you ?
auftreten: weil der Service dhcpcd für alle Interfaces, auch die die kein DHCP für IPv6 brauchen,
DHCP durchführt.
...
And besides, instead of "NetworkManager" you can use dhcpcd

  • this has the advantage that now all users are allowed on the network
    and the disadvantage:
    Messages like: enp0s04: DHCPv6 REPLY: who are you?
    occur: because the dhcpcd service for all interfaces,
    even those that do not need DHCP for IPv6, performs DHCP.

Oh, I am currently on 5.8. I didn't try on 5.7

OK switching to kernel 5.8 solved the flatpak issue, all is good now.

yes.. on my case it's with spotify flatpak I have a problem with kernel 5.7.8 too.. I did not try on 5.4

/usr/bin/flatpak run com.spotify.Client                                  
bwrap: Can't bind mount /oldroot/dev/tty on /newroot/dev/tty: Invalid argument
error: ldconfig failed, exit status 256

Try to enable "dhcpcd-service".....

thanks for the suggestion, sadly it doesn't help :confused:

But now, searching for dchp in journalctl i'm noticing

Jul 10 17:38:12 Manjaro-ZZ NetworkManager[1437]: [1594395492.3832] dhcp6 (enp10s0): activation: beginning transaction (timeout in 45 seconds)
Jul 10 17:38:12 Manjaro-ZZ NetworkManager[1437]: [1594395492.3833] device (enp10s0): failure to start DHCPv6: failed to start client: Die Adresse wird bereits verwendet

Jul 10 17:38:41 Manjaro-ZZ nm-dispatcher[1590]: Error releasing name org.freedesktop.nm_dispatcher: Timeout was reached
Jul 10 17:38:52 Manjaro-ZZ dbus-daemon[1436]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45064ms)

and

Jul 10 17:38:52 Manjaro-ZZ sddm-helper[1943]: pam_systemd(sddm-autologin:session): Failed to create session: Message recipient disconnected from message bus without replying

i'm not 100% sure those were also present in the past :thinking:

after those, there is this line repeatedly:

Jul 10 17:38:52 Manjaro-ZZ dhcpcd[1445]: enp10s0: DHCPv6 REPLY: who are you ?

then

Jul 10 17:38:53 Manjaro-ZZ startplasma-x11[2267]: "dbus-update-activation-environment" ("--systemd", "--all") exited with code 71
and
Jul 10 17:38:53 Manjaro-ZZ systemd-logind[2338]: New seat seat0.
Jul 10 17:38:53 Manjaro-ZZ systemd-logind[2338]: Failed to add user by file name 1000, ignoring: Invalid argument
Jul 10 17:38:53 Manjaro-ZZ systemd-logind[2338]: User enumeration failed: Invalid argument
Jul 10 17:38:53 Manjaro-ZZ systemd-logind[2338]: User of session 1 not known.
Jul 10 17:38:53 Manjaro-ZZ systemd-logind[2338]: Session enumeration failed: No such file or directory

and then a coredump of sddm.
That seems fishy and i didn't stumble upon the last time i checked :thinking:

edit: just checked by skimming through older journalctls - those lines were mostly present without dhcpd.service, too

After applying this update I changed kernel from 5.7 to 5.8 to remove the message in the kernel_log of buggy seq_file .next function m_next did not updated position index. However since changing the kernel the grub menu on boot shows two Manjaros instead of one, just like Bleuzen.

Flatpak issue resolved with updating to the 5.8 kernel, but now I have 3 sets of entries on the grub menu instead of 2, and in my case there are only to Manjaro installs on the system. On my roommate's system I updated the kernel first, rebooted, did the testing updates, and his system now shows the grub menu which it hadn't previously. His Grub is correct though Manjaro, Advanced Options, Windows 10.

Just updated to kernel 5.7.8-2 (without the lockdep-debug patch). Flatpaks still do not start. But the error message is a little different now:

~ >>> flatpak run com.microsoft.Teams                                                                                                
bwrap: Can't bind mount /oldroot/sys on /newroot/sys: Invalid argument

But the good thing is: The LVM errors are away! Yeah :))

Kernel 5.7.8-2 lets me into my desktop :arrow_right: yay! :purple_heart:
But I also see flatpaks say bwrap: Can't bind mount /oldroot/dev on /newroot/dev: Invalid argument and idle on start.

Kernel 5.7.8-3 is fine in my case

1 Like

5.7.8-3 working perfect :heart_eyes:

Yep! 5.7.8-3 seems to be one happy li'l kernel. :+1:

log spam is gone :wink:

something else I noticed: dmesg does not require sudo anymore.

@schinfo why that ?!? ...

I also have those double entries for Manjaro since installing this update.
For me, all boot, but they have different settings. The first 2 boot like always, the second ones don't show the boot splash and take longer to boot.

Edit: According to /boot/grub/grub.cfg, the first ones are generated by /etc/grub.d/10_linux while the second ones are generated by /etc/grub.d/30_os-prober
In the past, only 10_linux created Manjaro entries in grub.
Edit2: sudo update-grub fixed it.

2 Likes

Just install and switch to the 5.8 kernel.

I updated to 5.7.8-3 and most things seem to work again now. Flatpaks work. Boot works. I run update-grub after the kernel update and grub is hidden again. (LVM errors are still there, but hidden and everything works anyway, so I guess I can ignore it for now).
So yeah, it is getting in shape :slight_smile:

Now only bugs left on my side are plasma tray menu problems when programs autostarted and that plasma desktop sometimes doesn't start properly but display only a black background and ignores my mouse input. But this could also be a user config bug, not sure yet.

Another question, not exactly about this update, but why is the linux57 kernel package so huge? The manjaro linux57 package is currently 172 MB in size. The manjaro linux54 package is only 82 MB.
Also, the kernel 5.7 from arch is only 70 MB. Only 40 % of the size of Manjaros kernel in same version.

@philm Could you check this? Maybe some wrong compression settings?

1 Like

Forum kindly sponsored by