[Testing Update] 2020-07-11 - KDE-git, Firefox-beta, AMDVLK 2020.Q3-1, Fixes to Plasma 5.19.3

Hello community,

Another testing branch update with some interesting updates for you!


On the #pinephone we added scale-to-fit so firefox and other apps scale properly now! #stayhome, #staysafe, #stayhealthy

  • We updated some of our KDE-git packages
  • Firefox developer edition is now at 79.0b6
  • AMD kicks of Q3 with AMDVLK on 2020.Q3.1
  • Some additional fixes to Plasma 5.19.3
  • The usual upstream updates rebuilds/updates including python by Arch

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest preview of Manjaro Mikah 20.1! XFCE, KDE and Gnome


Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux44 4.4.230
  • linux49 4.9.230
  • linux414 4.14.188
  • linux419 4.19.132
  • linux54 5.4.51
  • linux56 5.6.19 [EOL]
  • linux57 5.7.8
  • linux58 5.8-rc4
  • linux54-rt 5.4.44_rt27
  • linux56-rt 5.6.17_rt9

Package Changes (Sat Jul 11 14:17:35 CEST 2020)

  • testing community x86_64: 199 new and 192 removed package(s)
  • testing core x86_64: 2 new and 2 removed package(s)
  • testing extra x86_64: 36 new and 31 removed package(s)
  • testing multilib x86_64: 2 new and 2 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-07-10           2020-07-11
-------------------------------------------------------------------------------
                    breeze-icons-git5.72.0.r1585.g6c726232-15.72.0.r1590.g860440c9-1
                        discover-git5.19.80.r7758.g6ae9cd69-15.19.80.r7759.gf1ef9577-1
             extra-cmake-modules-git5.72.0.r3168.g4ad3d16-15.72.0.r3174.gac7404e-1
                indicator-sysmonitor              0.8.1-5              0.8.3-2
                        khotkeys-git5.19.80.r2009.g52af3fd-15.19.80.r2010.g52f4f8d-1
                      knetattach-git5.19.80.r7732.gb621217ab-15.19.80.r7734.g069cffa86-1
                   kscreenlocker-git5.19.80.r787.g6079810-15.19.80.r788.g44cc85e-1
                       ksysguard-git5.19.80.r3312.g871975b3-15.19.80.r3313.g1e55f42a-1
                            kwin-git5.19.80.r18125.g72cd67cbf-15.19.80.r18126.g0c67eb983-1
                  plasma-desktop-git5.19.80.r7732.gb621217ab-15.19.80.r7734.g069cffa86-1
                plasma-framework-git5.72.0.r15478.g2ed274da7-15.72.0.r15479.g12dd2589f-1
          plasma-wayland-session-git5.19.80.r9188.g5f13bcabf-15.19.80.r9190.gd752a3ed7-1
                plasma-workspace-git5.19.80.r9188.g5f13bcabf-15.19.80.r9190.gd752a3ed7-1
            budgie-sysmonitor-applet                    -              0.8.3-2


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-07-10           2020-07-11
-------------------------------------------------------------------------------
                             amsynth             1.10.0-1             1.10.0-2
                             arduino           1:1.8.12-1           1:1.8.13-1
                    arduino-avr-core              1.8.2-1              1.8.2-2
                     arduino-builder              1.5.3-2              1.5.4-1
                        arduino-docs              1.6.6-6              1.6.6-7
                           aspell-pt           20161001-2           20190329-1
                             aws-cli            1.18.93-1            1.18.97-1
                           blueberry              1.3.8-1              1.3.9-1
                      chewing-editor              0.1.1-6              0.1.1-7
                             cockpit              222.1-1                223-1
                   cockpit-dashboard              222.1-1                223-1
                      cockpit-docker              222.1-1                223-1
                    cockpit-machines              222.1-1                223-1
                         cockpit-pcp              222.1-1                223-1
                                code             1.46.1-1             1.47.0-1
                    deepin-clipboard            5.0.0.4-1            5.0.0.4-2
               deepin-control-center           5.2.0.17-1           5.2.0.19-1
                      deepin-printer              0.6.3-1              0.6.3-2
                            deja-dup               40.6-3               42.0-1
                                dpkg             1.20.0-1             1.20.5-1
                 firefox-dark-reader             4.9.14-1             4.9.15-1
           firefox-developer-edition             79.0b5-1             79.0b6-1
  firefox-developer-edition-i18n-ach             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-af             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-an             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-ar             79.0b5-1             79.0b6-1
  firefox-developer-edition-i18n-ast             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-az             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-be             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-bg             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-bn             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-br             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-bs             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-ca             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-ca-valencia       79.0b5-1             79.0b6-1
  firefox-developer-edition-i18n-cak             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-cs             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-cy             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-da             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-de             79.0b5-1             79.0b6-1
  firefox-developer-edition-i18n-dsb             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-el             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-en-ca             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-en-gb             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-en-us             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-eo             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-es-ar             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-es-cl             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-es-es             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-es-mx             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-et             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-eu             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-fa             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-ff             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-fi             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-fr             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-fy-nl             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-ga-ie             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-gd             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-gl             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-gn             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-gu-in             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-he             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-hi-in             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-hr             79.0b5-1             79.0b6-1
  firefox-developer-edition-i18n-hsb             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-hu             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-hy-am             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-ia             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-id             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-is             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-it             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-ja             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-ka             79.0b5-1             79.0b6-1
  firefox-developer-edition-i18n-kab             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-kk             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-km             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-kn             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-ko             79.0b5-1             79.0b6-1
  firefox-developer-edition-i18n-lij             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-lt             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-lv             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-mk             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-mr             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-ms             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-my             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-nb-no             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-ne-np             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-nl             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-nn-no             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-oc             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-pa-in             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-pl             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-pt-br             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-pt-pt             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-rm             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-ro             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-ru             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-si             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-sk             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-sl             79.0b5-1             79.0b6-1
  firefox-developer-edition-i18n-son             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-sq             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-sr             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-sv-se             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-ta             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-te             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-th             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-tl             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-tr             79.0b5-1             79.0b6-1
  firefox-developer-edition-i18n-trs             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-uk             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-ur             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-uz             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-vi             79.0b5-1             79.0b6-1
   firefox-developer-edition-i18n-xh             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-zh-cn             79.0b5-1             79.0b6-1
firefox-developer-edition-i18n-zh-tw             79.0b5-1             79.0b6-1
              firefox-tree-style-tab              3.5.7-1              3.5.9-1
               firefox-ublock-origin            1.27.10-1             1.28.0-1
                               gammu             1.41.0-3             1.41.0-4
                                gnac            0.2.4.1-9           0.2.4.1-10
                         gnome-boxes             3.36.4-1             3.36.5-1
                 gnome-initial-setup             3.36.2-1             3.36.4-1
                      gnome-podcasts              0.4.7-1              0.4.8-1
                             gnucash               3.10-1                4.0-1
                        gnucash-docs               3.10-1                4.0-1
                             gpodder            3.10.15-1            3.10.16-1
                            gpsbabel              1.6.0-3              1.7.0-1
                                grpc             1.30.0-2             1.30.1-2
                            grpc-cli             1.30.0-2             1.30.1-2
                     intel-media-sdk             20.1.1-1             20.2.0-1
                           keepassxc              2.5.4-2              2.6.0-1
                              libmfx             20.1.1-1             20.2.0-1
                           libosinfo              1.7.1-1              1.8.0-1
                               monit             5.26.0-2             5.27.0-1
                              mumble              1.3.1-1              1.3.2-2
                              murmur              1.3.1-1              1.3.2-2
                    nextcloud-client              2.6.4-1              2.6.5-1
                             openbve            1.7.1.5-1            1.7.1.8-1
                    openimagedenoise              1.2.1-1              1.2.2-1
                            oprofile              1.3.0-1                    -
                             oscpack              1.1.0-1              1.1.0-2
                           osinfo-db           20200515-1           20200529-1
                     osinfo-db-tools              1.7.0-1              1.8.0-1
                               pbpst              1.4.1-2                    -
                           pdftricks              0.2.7-2              0.3.0-1
                          photoflare              1.6.4-2              1.6.5-1
                            php-grpc             1.30.0-2             1.30.1-2
                        python-boto3            1.14.16-1            1.14.20-1
                     python-botocore            1.17.16-1            1.17.20-1
                     python-coverage              4.5.4-3                5.2-1
                       python-dotenv             0.13.0-2             0.14.0-1
                          python-fxa              0.7.3-2              0.7.6-1
                        python-gammu               2.12-2                3.0-1
         python-google-auth-httplib2              0.0.3-5              0.0.4-1
                       python-grpcio             1.30.0-2             1.30.1-2
                     python-identify             1.4.21-1             1.4.22-1
                       python-owslib             0.19.2-1             0.20.0-1
              python-pytest-randomly              3.4.0-1              3.4.1-1
                 python-pytest-xdist             1.32.0-1             1.33.0-1
              python-requirementslib             1.5.11-1             1.5.12-1
                       python-snappy              0.5.4-1              0.5.4-2
                    python-stevedore              2.0.1-1              3.0.0-1
                    python2-coverage              4.5.4-3                5.2-1
                       python2-gammu               2.12-2                    -
                python2-pytest-xdist             1.32.0-1             1.33.0-1
                           qmapshack             1.14.1-2             1.15.0-1
                      rime-cantonese     0.0.0.20200709-1     0.0.0.20200710-1
                    rime-luna-pinyin     0.0.0.20200410-1     0.0.0.20200710-1
                            rssguard              3.6.2-1              3.6.3-1
                rssguard-nowebengine              3.6.2-1              3.6.3-1
                         simple-scan             3.36.3-1             3.36.4-1
      thunderbird-extension-enigmail              2.1.7-1              2.1.7-3
                               timew              1.3.0-1              1.3.0-2
         v2ray-domain-list-community     20200709144815-1     20200711063108-1
                               wammu               0.44-3                    -
                           xarchiver           0.5.4.14-2           0.5.4.15-1
                      xarchiver-gtk2           0.5.4.14-2           0.5.4.15-1
                             kubeone                    -        1.0.0beta.2-1
                          lifeograph                    -              1.6.1-2
                              minder                    -              1.9.0-1
                             pcbdraw                    -              0.4.0-2
                      python-authlib                    -             0.14.3-2
                  python-hstspreload                    -           2020.7.7-2
                        python-httpx                    -             0.13.3-4
                      python-pybars3                    -              0.9.7-3
                      python-pymeta3                    -              0.5.1-1
                         rednotebook                    -               2.19-2


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-07-10           2020-07-11
-------------------------------------------------------------------------------
                               gnupg             2.2.20-4             2.2.21-1
                            iana-etc           20200624-1           20200707-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-07-10           2020-07-11
-------------------------------------------------------------------------------
                gnome-control-center             3.36.4-2             3.36.4-3
                           bluedevil                    -         1:5.19.3-1.1
                           plasma-nm                    -           5.19.3-1.1
                        plasma-vault                    -           5.19.3-1.1
              plasma-wayland-session                    -           5.19.3-1.1
                    plasma-workspace                    -           5.19.3-1.1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-07-10           2020-07-11
-------------------------------------------------------------------------------
                              amdvlk          2020.Q2.6-1          2020.Q3.1-1
                           audacious              4.0.4-1              4.0.5-1
                   audacious-plugins              4.0.4-1              4.0.5-1
                              bigloo               4.3f-2               4.3h-1
                        gnome-clocks             3.36.2-1             3.36.2-2
                     grml-zsh-config             0.17.3-1             0.17.4-1
                          libxnvctrl            440.100-1             450.51-1
                                 php              7.4.8-1              7.4.8-2
                          php-apache              7.4.8-1              7.4.8-2
                             php-cgi              7.4.8-1              7.4.8-2
                           php-dblib              7.4.8-1              7.4.8-2
                           php-embed              7.4.8-1              7.4.8-2
                         php-enchant              7.4.8-1              7.4.8-2
                             php-fpm              7.4.8-1              7.4.8-2
                              php-gd              7.4.8-1              7.4.8-2
                            php-imap              7.4.8-1              7.4.8-2
                            php-intl              7.4.8-1              7.4.8-2
                            php-odbc              7.4.8-1              7.4.8-2
                           php-pgsql              7.4.8-1              7.4.8-2
                          php-phpdbg              7.4.8-1              7.4.8-2
                          php-pspell              7.4.8-1              7.4.8-2
                            php-snmp              7.4.8-1              7.4.8-2
                          php-sodium              7.4.8-1              7.4.8-2
                          php-sqlite              7.4.8-1              7.4.8-2
                            php-tidy              7.4.8-1              7.4.8-2
                             php-xsl              7.4.8-1              7.4.8-2
                         python-lxml              4.5.1-1              4.5.2-1
                    python-lxml-docs              4.5.1-1              4.5.2-1
                   python-setuptools           1:49.1.0-1           1:49.1.2-1
                        python2-lxml              4.5.1-1              4.5.2-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-07-10           2020-07-11
-------------------------------------------------------------------------------
                        lib32-amdvlk          2020.Q2.6-1          2020.Q3.1-1
                     lib32-libgcrypt              1.8.5-1              1.8.6-1

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

8 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

System takes a long time to boot

If you've got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here

I think I've some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

... and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Older issues

Thunderbird might throw an error of older version available.

Use $ thunderbird --allow-downgrade from a terminal to fix it.

HP Device Manager


Pamac stuck at "Preparing..."

Users have reported issues with the recent release candidate of Pamac 9.4.0 when initiating transactions, being stuck at "Preparing..." without being able to cancel the transaction and quit Pamac normally.

For now, it is recommended to use pacman to do package management until this issue is solved and Pamac become usable again. Please test out upcoming updates for Pamac to see if the issue becomes solved or not.

If you are stuck in "Preparing...", you will have to manually kill the pamac-managerprocess.

Reported on Gitlab:
https://gitlab.manjaro.org/applications/pamac/issues/757

Upgrading firewalld package to 0.8.1-2 requires manual intervention

Please read this announcement if you have file conflicts when trying to upgrade firewalld package to 0.8.1-2.

Firewalld requires manual intervention

khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.


Weird font glitches (see screenshots below).

If you have weird glitches like below...

Screenshots

Screenshot%20from%202020-01-16%2023-59-49
string3
strings%20mismatch
post%20transaction%20hooks

... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.


Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in

/usr/lib/python3.7/site-packages/

To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.


System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.


xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.


Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.


Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


gnome-shell-extension-desktop-icons

the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

@philm have to ask why more kernel updates. and why when I haven't had VirtualBox installed for will over a month why I still get offered the host kernel modules for VirtualBox?

Once you remove virtualbox package you can still have the virtualbox kernel host modules installed. Check if one or more of them got left behind.

1 Like

Removing virtualbox won't remove extramodules. So check as @bogdancovaciu explained already. And why you're not happy with kernel updates?

XFCE + BTRFS + linux57
No issues so far, only 7 Packages to update :slight_smile:
Will report if I found any.
Great job as always, take care and take care of each other :heart:

1 Like

@Agentx - I always feel like


when there are updates :smiley:

What? I don't care about the updates since yesterday in regards to flsatpaks was the exception not the rule. Got it fix pretty quickly which is normsally the case with Manjaro. Other distros not so much.

This topic has been cleaned up. Please try to stay on topic discussing the status of this release.

5 Likes

No drama in this post. Why? Everything is copacetic and working fine. XFCE and Mate in a VM.

1 Like

On Gnome, kernel 5.7.8-5. Updated and everything is working smoothly.

Cinnamon, kernel 5.7.8-5, everything works well. Thank you!

On Gnome, Wayland:
The standard (black) Authentication-Box sometimes shows a transparent rectangle
with black "bordering" lines on the right side, when I type my password.
...........................
SPY or not SPY?!

That's the question! :upside_down_face:

But: how do I find out... :nauseated_face:
Edit:
looks like this effect is caused by using:
Optimierungen / Fenster / Fokus beim Überfahren
(Optimizations / windows / focus when driving over) (<-committed by aunt Google translate)
..???
? May be a security-risk of the "Authentication-Box"?
(this square-box appears, when the last character of the PW is typed!!!)

I just noticed that urxvt fails to launch with the default config of the i3 edition with error

urxvt: unable to load base fontset, please specify a valid one using -fn, aborting.

The failing config is the first entry for URxvt.font: 9x15 in ~/.Xresources, which references font -misc-fixed-medium-r-normal--15-140-75-75-c-90-iso8859-1, which should be provided by xorg-fonts-misc package, I guess.

Workaround for now for urxvt is to use the xft: setting alone, like this:

URxvt.font:     xft:TerminessTTFNerdFontMono

for example.

Interestingly
xlsfonts | grep misc-fixed-medium
returns only

-misc-fixed-medium-r-semicondensed--0-0-75-75-c-0-iso8859-1
-misc-fixed-medium-r-semicondensed--12-110-75-75-c-60-iso8859-1
-misc-fixed-medium-r-semicondensed--12-110-75-75-c-60-iso8859-1
-misc-fixed-medium-r-semicondensed--13-100-100-100-c-60-iso8859-1
-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso8859-1
-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso8859-1
-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso8859-1
-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso8859-1

but /usr/share/fonts/misc/fonts.alias, owned by xorg-fonts-alias-misc lists:
9x15 -misc-fixed-medium-r-normal--15-140-75-75-c-90-iso8859-1
So that one seems to be unavailable...

update on the workaround:
installing xorg-mkfontscale and then running
xset +fp /usr/share/fonts/misc
fixes the availability of the needed fonts and makes the alias work again.

I have your Manjaroi3 in VM, testing, do not experience urxvt problem, I did not change anything, did not install/uninstall anything.

GNOME:
Gnome-shell extension "dash-to-panel" latest working Version is 38
(community: v37)
! config changed !
Pleez update CAREFULLY

Forum kindly sponsored by