[Testing Update] 2020-07-17 - Kernels, Firmware

Hello community,

Another testing branch update with some interesting updates for you!

More work went into our #Phosh edition for the #pinephone #stayhome, #staysafe, #stayhealthy

  • We updated some of our Kernels
  • Renewed our Firmware for the kernels
  • Worked on our ARM-tools

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest preview of Manjaro Mikah 20.1! XFCE, KDE and Gnome

Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux44 4.4.230
  • linux49 4.9.230
  • linux414 4.14.188
  • linux419 4.19.133
  • linux54 5.4.52
  • linux56 5.6.19 [EOL]
  • linux57 5.7.9
  • linux58 5.8-rc5
  • linux54-rt 5.4.44_rt27
  • linux56-rt 5.6.17_rt9

Package Changes (Wed Jul 15 22:32:50 CEST 2020)

  • testing community x86_64: 1 new and 0 removed package(s)
  • testing core x86_64: 8 new and 8 removed package(s)
  • testing extra x86_64: 55 new and 55 removed package(s)
:: Different overlay package(s) in repository community x86_64

                             PACKAGE           2020-07-15           2020-07-17
                            topgrade                    -              5.2.0-1

:: Different overlay package(s) in repository core x86_64

                             PACKAGE           2020-07-15           2020-07-17
                   amd-ucode 20200715.r1674.69c7f0b-1 20200716.r1675.1d1c80b-1
              linux-firmware 20200715.r1674.69c7f0b-1 20200716.r1675.1d1c80b-1
                            linux419           4.19.132-1           4.19.133-1
                    linux419-headers           4.19.132-1           4.19.133-1
                             linux54             5.4.51-1             5.4.52-1
                     linux54-headers             5.4.51-1             5.4.52-1
                             linux57              5.7.8-8              5.7.9-1
                     linux57-headers              5.7.8-8              5.7.9-1

:: Different overlay package(s) in repository extra x86_64

                             PACKAGE           2020-07-15           2020-07-17
                  linux419-acpi_call            1.1.0-122            1.1.0-123
                   linux419-bbswitch              0.8-122              0.8-123
                linux419-ndiswrapper              1.63-12              1.63-13
               linux419-nvidia-340xx           340.108-42           340.108-43
               linux419-nvidia-390xx           390.132-51           390.132-52
               linux419-nvidia-418xx           418.113-50           418.113-51
               linux419-nvidia-430xx            430.64-50            430.64-51
               linux419-nvidia-435xx            435.21-61            435.21-62
               linux419-nvidia-440xx            440.100-3            440.100-4
                   linux419-nvidiabl             0.88-121             0.88-122
                      linux419-r8168           8.048.03-8           8.048.03-9
                  linux419-rtl8723bu          20200405-18          20200405-19
                   linux419-tp_smapi              0.43-71              0.43-72
                linux419-vhba-module          20200106-36          20200106-37
   linux419-virtualbox-guest-modules             6.1.10-6             6.1.10-7
    linux419-virtualbox-host-modules             6.1.10-6             6.1.10-7
                        linux419-zfs             0.8.4-11             0.8.4-12
                   linux54-acpi_call             1.1.0-57             1.1.0-58
                    linux54-bbswitch               0.8-57               0.8-58
                 linux54-ndiswrapper              1.63-13              1.63-14
                linux54-nvidia-340xx           340.108-49           340.108-50
                linux54-nvidia-390xx           390.132-57           390.132-58
                linux54-nvidia-418xx           418.113-57           418.113-58
                linux54-nvidia-430xx            430.64-57            430.64-58
                linux54-nvidia-435xx            435.21-57            435.21-58
                linux54-nvidia-440xx            440.100-3            440.100-4
                    linux54-nvidiabl              0.88-57              0.88-58
                       linux54-r8168           8.048.03-9          8.048.03-10
                   linux54-rtl8723bu          20200405-21          20200405-22
                    linux54-tp_smapi              0.43-57              0.43-58
                 linux54-vhba-module          20200106-42          20200106-43
    linux54-virtualbox-guest-modules             6.1.10-7             6.1.10-8
     linux54-virtualbox-host-modules             6.1.10-7             6.1.10-8
                         linux54-zfs             0.8.4-12             0.8.4-13
                   linux57-acpi_call             1.1.0-14             1.1.0-15
                    linux57-bbswitch               0.8-14               0.8-15
                 linux57-ndiswrapper              1.63-14              1.63-15
                linux57-nvidia-340xx           340.108-14           340.108-15
                linux57-nvidia-390xx           390.132-14           390.132-15
                linux57-nvidia-418xx           418.113-14           418.113-15
                linux57-nvidia-430xx            430.64-14            430.64-15
                linux57-nvidia-435xx            435.21-14            435.21-15
                linux57-nvidia-440xx            440.100-5            440.100-6
                       linux57-r8168          8.048.03-14          8.048.03-15
                   linux57-rtl8723bu          20200405-14          20200405-15
                    linux57-tp_smapi              0.43-14              0.43-15
                 linux57-vhba-module          20200106-14          20200106-15
    linux57-virtualbox-guest-modules            6.1.10-10            6.1.10-11
     linux57-virtualbox-host-modules            6.1.10-10            6.1.10-11
                         linux57-zfs             0.8.4-14             0.8.4-15
                   manjaro-arm-tools              2.8.5-1              2.8.6-1
               manjaro-arm-tools-git  2.8.5.r5.gf6d846c-1  2.8.6.r3.ga4db587-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

System takes a long time to boot

If you've got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here

I think I've some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

... and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Older issues

Thunderbird might throw an error of older version available.

Use $ thunderbird --allow-downgrade from a terminal to fix it.

HP Device Manager

Pamac stuck at "Preparing..."

Users have reported issues with the recent release candidate of Pamac 9.4.0 when initiating transactions, being stuck at "Preparing..." without being able to cancel the transaction and quit Pamac normally.

For now, it is recommended to use pacman to do package management until this issue is solved and Pamac become usable again. Please test out upcoming updates for Pamac to see if the issue becomes solved or not.

If you are stuck in "Preparing...", you will have to manually kill the pamac-managerprocess.

Reported on Gitlab:

Upgrading firewalld package to 0.8.1-2 requires manual intervention

Please read this announcement if you have file conflicts when trying to upgrade firewalld package to 0.8.1-2.

Firewalld requires manual intervention

khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.

Weird font glitches (see screenshots below).

If you have weird glitches like below...



... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.

Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in


To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.

System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.

xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.

Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.

Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

1 Like

I've already rebuilt my DKMS modules 3 times this week because of so many updates to kernel 5.7.8.


==> Building image from preset: /etc/mkinitcpio.d/linux58.preset: 'default'
-> -k /boot/vmlinuz-5.8-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.8-x86_64.img
==> Starting build: 5.8.0-1-MANJARO
-> Running build hook: [base]
-> Running build hook: [udev]
-> Running build hook: [autodetect]
-> Running build hook: [modconf]
-> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: xhci_pci
-> Running build hook: [filesystems]
-> Running build hook: [keyboard]
-> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.8-x86_64.img
==> Image generation successful

Update from terminal KDE / Kernel 5.7 / Nvidia without issue,

Still have the NVENC issue [Testing Update] 2020-07-15 - Palemoon, Linux57 with Fsync/Futex, Vulkan-ICD, Deepin

No issues Kernel and Firmware Update went fine.

Kernel and firmware updated successfully without any issues.

Updated via TTY and everything good so far XFCE, Kernel 5.7, nouveau Thank you

Updated by pacman and so far so good. Plasma 5.19.3/kernel 5.7/nvidia 440.100

1 Like

is some time, maybe one month, after updating in tty and systemctl reboot it hangs for about two minutes before restarting

$ inxi -Fxzc0
System:    Host: computer-pc Kernel: 5.4.52-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           Desktop: KDE Plasma 5.19.3 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Precision M4800 v: 00 serial: <filter> 
           Mobo: Dell model: 0C3V2K v: A00 serial: <filter> BIOS: Dell v: A26 date: 06/13/2019 
Battery:   ID-1: BAT0 charge: 62.0 Wh condition: 84.1/99.9 Wh (84%) model: Sanyo DELL T4DTX45 
           status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i7-4810MQ bits: 64 type: MT MCP arch: Haswell rev: 3 
           L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44713 
           Speed: 1198 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 1197 2: 1198 3: 1197 4: 1198 5: 1199 
           6: 1199 7: 1196 8: 1200 
Graphics:  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Dell driver: i915 v: kernel 
           bus ID: 00:02.0 
           Device-2: NVIDIA GK106GLM [Quadro K2100M] driver: N/A bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.8 driver: intel tty: N/A 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2) v: 4.5 Mesa 20.1.3 
           direct render: Yes 
Audio:     Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio vendor: Dell 
           driver: snd_hda_intel v: kernel bus ID: 00:03.0 
           Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Dell driver: snd_hda_intel 
           v: kernel bus ID: 00:1b.0 
           Device-3: NVIDIA GK106 HDMI Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Sound Server: ALSA v: k5.4.52-1-MANJARO 
Network:   Device-1: Intel Ethernet I217-LM vendor: Dell driver: e1000e v: 3.2.6-k port: f080 
           bus ID: 00:19.0 
           IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
           Device-2: Intel Wireless 7260 driver: iwlwifi v: kernel port: f040 bus ID: 03:00.0 
           IF: wlp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 942.70 GiB used: 23.38 GiB (2.5%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 840 PRO Series size: 476.94 GiB 
           ID-2: /dev/sdb vendor: Samsung model: SSD 840 EVO 500GB mSATA size: 465.76 GiB 
Partition: ID-1: / size: 454.03 GiB used: 23.38 GiB (5.1%) fs: ext4 dev: /dev/sda1 
           ID-2: swap-1 size: 14.65 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 52.0 C mobo: 47.0 C sodimm: 38.0 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 227 Uptime: 3m Memory: 15.55 GiB used: 1.25 GiB (8.0%) Init: systemd Compilers: 
           gcc: 10.1.0 Shell: bash v: 5.0.18 inxi: 3.0.37
1 Like

3 systems updated. No issues.

1- XFCE - Kernel 5.7 - AMDGPU
2- XFCE - Kernel 5.4 - NVIDIA
3- XFCE - Kernel 5.7 - Intel UHD + AMDGPU

Yeah, sometimes I see a delay during reboot after Stopped User Manager or-something-like-that message.
Anybody else?

Not a big deal, in Gnome, notifications, which I use deactivated all, I mean settings -> notifications and disable all, one by one except for the software manager. After the update more than half were enabled and I had to disabled one by one again. In the list, the software doubled, now I have two (See the attach). Some programs like MKvToolniX lost the custom settings and were reset by the defaults.
Nothing more to report.

Looks like my room mate did have one issue come out of the 06152020 update, and that is his bluetooth will not recognize his bluetooth speakers. No biggy cause I had him switch to a set of standard speakewrs since the only thing he really needed bluetooth for were the speakers.

As for this update his system still updating and this one updated, rebooted and no issues I can see so far.

This round of updates fixed a missing battery icon on KDE with the prior update set.
All good now.

Do you log out of the graphical session before switching to TTY to update? The issue could be that it's having difficulty closing a process from the graphical session, then after about 90 seconds it sends a SIGKILL.

yes, I do

Does it give an error message, or do you have the splash screen enabled, which would block error messages?

Perhaps you could look at timers.

Does the stable branch kernel 5.7.0-3 have Fsync/Futex enabled already or this is atm only testing branch privilege?

Forum kindly sponsored by