[Testing Update] 2020-08-07 - Kernels, KDE-git, Browser, AMDVLK, Mesa, Haskell, Python

Hello community,

Another testing branch update with some interesting updates for you!

Soon available via Amazon ... #stayhome, #staysafe, #stayhealthy

  • Most of our Kernels got updated
  • Some Browsers got updated
  • Mesa is now at 20.1.5
  • Systemd is at 246
  • A new AMDVLK release
  • Usual Python and Haskell package updates and rebuilds

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest RC of Manjaro Mikah 20.1! XFCE, KDE and Gnome

Security Updates

Xorg-Server 1.20.8-4

Fixes CVE-2020-14347. No manual user intervention needed. Just update regularly.

Avoid leaking un-initalized memory to clients by zeroing the whole pixmap on initial allocation.
This vulnerability was discovered by: Jan-Niklas Sohn working with Trend Micro Zero Day Initiative

Grub 2.04-11.1

Fixes Boot-Hole issue.
You need to re-install grub on your system to complete the security fix: Bios-MBR, UEFI Systems

Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux44 4.4.232
  • linux49 4.9.232
  • linux414 4.14.193
  • linux419 4.19.138
  • linux54 5.4.57
  • linux57 5.7.14
  • linux58 5.8.0
  • linux54-rt 5.4.52_rt31
  • linux56-rt 5.6.17_rt9

Package Changes (Fri Aug 7 15:44:40 CEST 2020)

  • testing community x86_64: 1103 new and 1080 removed package(s)
  • testing core x86_64: 17 new and 17 removed package(s)
  • testing extra x86_64: 185 new and 179 removed package(s)
  • testing multilib x86_64: 21 new and 21 removed package(s)

A list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

System takes a long time to boot

If you've got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable org.cups.cupsd.service
systemctl enable org.cups.cupsd.socket

I think I've some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

... and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Older issues

Thunderbird might throw an error of older version available.

Use $ thunderbird --allow-downgrade from a terminal to fix it.

HP Device Manager

Pamac stuck at "Preparing..."

Users have reported issues with the recent release candidate of Pamac 9.4.0 when initiating transactions, being stuck at "Preparing..." without being able to cancel the transaction and quit Pamac normally.

For now, it is recommended to use pacman to do package management until this issue is solved and Pamac become usable again. Please test out upcoming updates for Pamac to see if the issue becomes solved or not.

If you are stuck in "Preparing...", you will have to manually kill the pamac-managerprocess.

Reported on Gitlab:

Upgrading firewalld package to 0.8.1-2 requires manual intervention

Please read this announcement if you have file conflicts when trying to upgrade firewalld package to 0.8.1-2.

Firewalld requires manual intervention

khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.

Weird font glitches (see screenshots below).

If you have weird glitches like below...



... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.

Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in


To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.

System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.

xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.

Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.

Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

1 Like

Upgraded successfully, ran the grub uefi procedure flawlessly.
Thanks Manjaro team.
Running kernel 5.8 with XFCE.

Pamac tray icon is still corrupted, unless it's delayed with sleep.
Like with previous Testing update, pipewire-media-session maxes out one of my CPU threads, if I unplug my USB microphone. Hopefully 0.3.9 lands here soon :smile:

Edit: Nothing out of the ordinary with kernel 5.8. Hopefully it'll include Fsync by Stable release. At least I didn't see the futex patch included in it.

After this update we need to re-install grub one more time to fix Boot-Hole issue?

Didn't see it got updated this time, compared to the previous Testing update. It's a notice for those who are updating their grub now.

no need if you already have installed the new grub in the earlier update

Tests with linux5.8.0 & linux 5.7.14
Xfce 4.14.2 + nvidia 44.100 ( cuba 10.2) + systemd246 + Steam ( opengl ) + youtube 1080p ( 15% to 25% max) OK
( check if possible diff power management powertop for intel )

Sorry but I don't understand:

  • apply the testing update and that's it


  • re-install grub 2.04-11.1


OK to be clear I did a fresh install the night before last so I'd have the updates from the 31st which would of been the last set of testing updates. So in my case no need to manually update grub? Thanks

depends on what u mean by "fresh install".

if you reinstalled manjaro from ISO even if its the RC and you updated to testing update on 07/31 (where the latest grub 2.04-11.1 was downloaded), you bootloader might be again old and require re-installing.

Some apps depending on rust OR rustup do not work any longer
since systemd 246. (for example "kate", but that concerns only KDE,
where there are no problems at time.) (Gnome-user...)
the installation of "rustup 1.22.1" in Community is incomplete.
Have to do after install (example) in terminal: "rustup default stable"
otherwise you get complains when using it...

I don't get any updates, Belgium repos. Maybe too soon?

Change to France repos and I got it

Getting this Not setting net/ipv4/conf/*
And have to reinstall OhMyZsh :woman_shrugging: Because manjaro-zsh-config gets an update
Other than this the update went fine.

I can see strange theme colors after this update.
Now qBitorrent is dark, the configuration manager is not, while the manjaro settings manager is dark.
Maybe this is related to the fact that I've removed the orphan packet kvantum-theme-matchama (20191118-1) after the update?


OK when I check version I get 2.0.4-Manjaro. Hope that helps. The ISO was the one from 06062020, and just thought I never switched to testing.

Getting this Not setting net/ipv4/conf/ * in systemd....

I got the same one, other than that all went just fine

Depends if it was in use.
kvantum themes are for QT styling, especially in other non-QT environments.
kvantum-matchama is most commonly used to have QT apps match the 'matcha' GTK theme.


You can simply change this in Kvantum Manager


Forum kindly sponsored by