[Testing Update] 2020-08-08 - Browsers, Systemd, Firmware, Pamac

Hello community,

Another testing branch update with some interesting updates for you!


See how smooth Lomiri performs on a PinePhone ... #stayhome, #staysafe, #stayhealthy

  • Some Browsers got updated
  • Systemd is at 246.1
  • Updated Linux-Firmware
  • Pamac adds more support to AUR
  • Usual Python and Haskell package updates and rebuilds

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest RC of Manjaro Mikah 20.1! XFCE, KDE and Gnome


Security Updates

Xorg-Server 1.20.8-4

Fixes CVE-2020-14347. No manual user intervention needed. Just update regularly.

Avoid leaking un-initalized memory to clients by zeroing the whole pixmap on initial allocation.
This vulnerability was discovered by: Jan-Niklas Sohn working with Trend Micro Zero Day Initiative

Grub 2.04-11.1

Fixes Boot-Hole issue.
You need to re-install grub on your system to complete the security fix: Bios-MBR, UEFI Systems

Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux44 4.4.232
  • linux49 4.9.232
  • linux414 4.14.193
  • linux419 4.19.138
  • linux54 5.4.57
  • linux57 5.7.14
  • linux58 5.8.0
  • linux54-rt 5.4.52_rt31
  • linux56-rt 5.6.17_rt9

Package Changes (Sat Aug 8 10:22:44 CEST 2020)

  • testing community x86_64: 273 new and 273 removed package(s)
  • testing core x86_64: 6 new and 6 removed package(s)
  • testing extra x86_64: 2 new and 2 removed package(s)
  • testing multilib x86_64: 1 new and 1 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-08-07           2020-08-08
-------------------------------------------------------------------------------
                    auto-cpufreq-git    1.2.r0.g4833367-3                    -
              manjaro-gnome-settings           20200803-1           20200807-1
                        auto-cpufreq                    -    1.2.r0.g4833367-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-08-07           2020-08-08
-------------------------------------------------------------------------------
                                agda             2.6.1-77             2.6.1-78
                       cabal-install           3.2.0.0-47           3.2.0.0-48
                               cgrep            6.6.32-51            6.6.32-53
                             cryptol              2.9.0-9             2.9.0-11
                               darcs            2.14.4-45            2.14.4-47
               deepin-control-center           5.2.0.27-1            5.3.0.5-1
                     deepin-launcher           5.2.0.16-1            5.3.0.3-1
              deepin-qt-dbus-factory            5.2.0.5-1            5.3.0.1-1
                       deepin-reader           5.7.0.12-1           5.7.0.13-1
                               dhall            1.33.1-17            1.33.1-18
                          dhall-bash            1.0.31-27            1.0.31-28
                          dhall-json             1.7.0-25             1.7.0-26
                          emscripten            1.39.20-4             1.40.1-1
                              fcitx5     0.0.0.20200806-1     0.0.0.20200807-1
               fcitx5-chinese-addons     0.0.0.20200806-1     0.0.0.20200807-1
                   fcitx5-configtool   0.0.0.20200803.1-2     0.0.0.20200807-1
           firefox-developer-edition             80.0b4-1             80.0b5-1
  firefox-developer-edition-i18n-ach             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-af             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-an             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-ar             80.0b4-1             80.0b5-1
  firefox-developer-edition-i18n-ast             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-az             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-be             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-bg             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-bn             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-br             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-bs             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-ca             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-ca-valencia       80.0b4-1             80.0b5-1
  firefox-developer-edition-i18n-cak             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-cs             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-cy             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-da             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-de             80.0b4-1             80.0b5-1
  firefox-developer-edition-i18n-dsb             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-el             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-en-ca             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-en-gb             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-en-us             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-eo             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-es-ar             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-es-cl             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-es-es             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-es-mx             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-et             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-eu             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-fa             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-ff             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-fi             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-fr             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-fy-nl             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-ga-ie             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-gd             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-gl             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-gn             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-gu-in             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-he             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-hi-in             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-hr             80.0b4-1             80.0b5-1
  firefox-developer-edition-i18n-hsb             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-hu             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-hy-am             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-ia             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-id             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-is             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-it             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-ja             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-ka             80.0b4-1             80.0b5-1
  firefox-developer-edition-i18n-kab             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-kk             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-km             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-kn             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-ko             80.0b4-1             80.0b5-1
  firefox-developer-edition-i18n-lij             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-lt             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-lv             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-mk             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-mr             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-ms             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-my             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-nb-no             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-ne-np             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-nl             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-nn-no             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-oc             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-pa-in             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-pl             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-pt-br             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-pt-pt             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-rm             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-ro             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-ru             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-si             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-sk             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-sl             80.0b4-1             80.0b5-1
  firefox-developer-edition-i18n-son             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-sq             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-sr             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-sv-se             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-ta             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-te             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-th             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-tl             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-tr             80.0b4-1             80.0b5-1
  firefox-developer-edition-i18n-trs             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-uk             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-ur             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-uz             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-vi             80.0b4-1             80.0b5-1
   firefox-developer-edition-i18n-xh             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-zh-cn             80.0b4-1             80.0b5-1
firefox-developer-edition-i18n-zh-tw             80.0b4-1             80.0b5-1
              firefox-tree-style-tab             3.5.19-1             3.5.20-1
                         gcompris-qt               0.97-1             0.97.1-1
                           git-annex      8.20200720.1-11      8.20200720.1-13
                          git-repair        1.20200504-43        1.20200504-44
                            gitolite             3.6.11-2             3.6.12-1
                  haskell-aeson-diff           1.1.0.9-46           1.1.0.9-48
                  haskell-aeson-yaml            1.1.0.0-9           1.1.0.0-10
                haskell-authenticate            1.3.5-153            1.3.5-154
          haskell-authenticate-oauth          1.6.0.1-126          1.6.0.1-127
                         haskell-aws              0.22-85              0.22-86
              haskell-binary-conduit            1.3.1-124            1.3.1-125
                 haskell-casa-client             0.0.1-74             0.0.1-75
                  haskell-casa-types             0.0.1-59             0.0.1-60
                  haskell-cheapskate          0.1.1.2-120          0.1.1.2-121
               haskell-clash-prelude              1.2.4-7              1.2.4-8
              haskell-classy-prelude             1.5.0-48             1.5.0-49
                     haskell-conduit             1.3.2-24             1.3.2-25
               haskell-conduit-extra             1.3.5-29             1.3.5-30
                   haskell-criterion           1.5.6.2-97           1.5.6.2-98
          haskell-cryptohash-conduit            0.1.1-381            0.1.1-382
          haskell-cryptonite-conduit            0.2.2-275            0.2.2-276
                         haskell-dav            1.3.4-136            1.3.4-137
                        haskell-dbus             1.2.16-9            1.2.16-11
               haskell-dbus-hslogger           0.1.0.1-61           0.1.0.1-63
              haskell-deferred-folds          0.9.10.1-90          0.9.10.1-91
                   haskell-esqueleto           3.3.3.2-14           3.3.3.2-15
                       haskell-extra              1.7.3-9              1.7.4-1
                  haskell-fdo-notify            0.3.1-313            0.3.1-315
                        haskell-feed           1.3.0.1-33           1.3.0.1-34
                 haskell-filepattern             0.1.2-23             0.1.2-24
                       haskell-foldl              1.4.7-6              1.4.8-1
           haskell-ghc-lib-parser-ex          8.10.0.15-3          8.10.0.15-4
                          haskell-gi             0.24.0-7             0.24.0-8
                     haskell-git-lfs              1.1.0-9             1.1.0-10
                     haskell-githash           0.1.4.0-64           0.1.4.0-65
                    haskell-graphviz       2999.20.0.4-21        2999.20.1.0-1
            haskell-hackage-security           0.6.0.1-53           0.6.0.1-54
                      haskell-hakyll          4.13.4.0-15          4.13.4.0-17
                       haskell-hasql            1.4.4.2-4            1.4.4.2-5
                  haskell-hasql-pool             0.5.2-26             0.5.2-27
           haskell-hasql-transaction           1.0.0.1-45           1.0.0.1-46
                 haskell-hledger-lib            1.18.1-10            1.18.1-11
                    haskell-hopenpgp            2.9.4-120            2.9.4-121
                       haskell-hpack            0.34.2-30            0.34.2-31
                haskell-html-conduit           1.3.2.1-86           1.3.2.1-87
                        haskell-http        4000.3.14-235        4000.3.14-236
                 haskell-http-client             0.7.1-23             0.7.1-24
      haskell-http-client-restricted              0.0.3-9             0.0.3-10
             haskell-http-client-tls          0.3.5.3-267          0.3.5.3-268
                haskell-http-conduit          2.3.7.3-161          2.3.7.3-162
               haskell-http-download           0.2.0.0-93           0.2.0.0-94
                haskell-http-streams           0.8.7.2-13           0.8.7.2-14
                  haskell-httpd-shed          0.4.1.1-161          0.4.1.1-162
                         haskell-hxt         9.3.1.18-109         9.3.1.18-110
                       haskell-ipynb           0.1.0.1-57           0.1.0.1-59
                        haskell-jose             0.8.3-44             0.8.3-45
                   haskell-js-jquery            3.3.1-469            3.3.1-470
                     haskell-libyaml             0.1.2-41             0.1.2-42
                haskell-monad-logger             0.3.34-6             0.3.34-7
            haskell-mono-traversable          1.0.15.1-42          1.0.15.1-43
  haskell-mono-traversable-instances           0.1.0.0-44           0.1.0.0-45
                    haskell-mustache            2.3.1-137            2.3.1-138
          haskell-mutable-containers             0.3.4-40             0.3.4-41
                 haskell-network-uri          2.6.3.0-125          2.6.3.0-126
             haskell-optparse-simple          0.1.1.2-231          0.1.1.2-232
                      haskell-pantry           0.5.1.1-13           0.5.1.1-14
                  haskell-persistent          2.10.5.2-63          2.10.5.2-64
               haskell-persistent-qq          2.9.1.1-116          2.9.1.1-117
           haskell-persistent-sqlite          2.10.6.2-91          2.10.6.2-92
         haskell-persistent-template           2.8.2.3-68           2.8.2.3-69
             haskell-persistent-test           2.0.3.1-62           2.0.3.1-63
                  haskell-pipes-http            1.0.6-180            1.0.6-181
            haskell-project-template            0.2.1.0-5            0.2.1.0-6
                 haskell-rio-orphans          0.1.1.0-139          0.1.1.0-140
                       haskell-sandi              0.5-130              0.5-131
                         haskell-sbv                8.7-6                8.7-8
                     haskell-servant              0.17-74              0.17-75
              haskell-servant-server              0.17-80              0.17-81
             haskell-servant-swagger             1.1.8-83             1.1.8-84
                       haskell-shake            0.19.1-28            0.19.1-30
             haskell-simple-sendfile            0.2.30-73            0.2.30-74
                  haskell-singletons               2.7-23               2.7-24
                 haskell-skylighting             0.8.5-17             0.8.5-18
            haskell-skylighting-core             0.8.5-17             0.8.5-18
                   haskell-snap-core            1.0.4.2-9           1.0.4.2-10
                 haskell-snap-server           1.1.1.2-59           1.1.1.2-60
                       haskell-store              0.7.5-3              0.7.5-4
           haskell-tagstream-conduit             0.5.6-18             0.5.6-19
                 haskell-tar-conduit             0.3.2-91             0.3.2-92
                     haskell-texmath          0.12.0.2-48          0.12.0.2-49
                haskell-text-builder           0.6.6.1-51           0.6.6.1-52
                      haskell-turtle            1.5.19-16            1.5.19-17
                  haskell-uri-encode          1.5.0.5-120          1.5.0.5-121
              haskell-wai-app-static          3.1.7.1-127          3.1.7.1-128
                 haskell-wai-conduit          3.0.0.4-216          3.0.0.4-217
          haskell-wai-handler-launch           3.0.3.1-90           3.0.3.1-91
                        haskell-warp            3.3.13-16            3.3.13-17
                    haskell-warp-tls             3.3.0-10             3.3.0-11
                       haskell-what4                1.0-6                1.0-7
                        haskell-wreq          0.5.3.2-236          0.5.3.2-237
                 haskell-xml-conduit           1.9.0.0-36           1.9.0.0-37
                  haskell-xml-hamlet          0.5.0.1-111          0.5.0.1-112
                haskell-xss-sanitize            0.3.6-157            0.3.6-158
                        haskell-yaml          0.11.4.0-26          0.11.4.0-27
                       haskell-yesod           1.6.0.2-13           1.6.0.2-14
                  haskell-yesod-auth            1.6.10-81            1.6.10-82
                  haskell-yesod-core            1.6.18-64            1.6.18-65
               haskell-yesod-default            1.2.0-774            1.2.0-775
                  haskell-yesod-form            1.6.7-217            1.6.7-218
            haskell-yesod-persistent          1.6.0.4-161          1.6.0.4-162
                haskell-yesod-static           1.6.1.0-13           1.6.1.0-14
                  haskell-yesod-test            1.6.10-18            1.6.10-19
                           hedgewars             1.0.0-86             1.0.0-87
                             hledger            1.18.1-10            1.18.1-11
                          hledger-ui            1.18.1-16            1.18.1-17
                         hledger-web            1.18.1-24            1.18.1-26
                               hlint              3.1.6-7              3.1.6-9
                              hoogle            5.0.18-10            5.0.18-12
                      hopenpgp-tools            0.23.1-85            0.23.1-87
                               idris             1.3.3-39             1.3.3-40
                          jupyterlab              2.2.2-1              2.2.4-1
                           leiningen              2.9.3-1              2.9.4-2
                             liteide               37.1-1               37.2-2
                              onednn                1.4-1                1.6-1
                              pandoc          2.9.2.1-113          2.9.2.1-115
                     pandoc-citeproc          0.17.0.1-23          0.17.0.1-25
                     pandoc-crossref           0.3.6.3-60           0.3.6.3-62
                    perl-test-simple           1.302175-2           1.302177-1
                    perl-test2-suite           0.000130-2           0.000132-1
                               picom                  8-2                  8-3
                              pifpaf              2.5.0-2              2.6.0-1
                              polyml                5.8-2              5.8.1-1
                           postgrest             7.0.1-46             7.0.1-47
                python-dogpile.cache              1.0.1-1              1.0.2-1
                  python-google-auth             1.20.0-1             1.20.1-1
                     python-openmdao              3.2.0-1              3.2.1-1
                       python-pytest              5.4.3-1              6.0.1-1
                      python-pytorch              1.6.0-1              1.6.0-2
                 python-pytorch-cuda              1.6.0-1              1.6.0-2
                  python-pytorch-opt              1.6.0-1              1.6.0-2
             python-pytorch-opt-cuda              1.6.0-1              1.6.0-2
                        python-qiniu              7.2.8-1              7.2.9-1
                   python-tensorflow              2.3.0-1              2.3.0-2
              python-tensorflow-cuda              2.3.0-1              2.3.0-2
               python-tensorflow-opt              2.3.0-1              2.3.0-2
          python-tensorflow-opt-cuda              2.3.0-1              2.3.0-2
                       python-yaspin             0.18.0-1              1.0.0-1
                          shellcheck             0.7.1-91             0.7.1-93
                               stack             2.3.1-77             2.3.1-79
                      tamarin-prover            1.4.1-390            1.4.1-391
                             taskell          1.9.2.0-137            1.9.3.0-1
                          tensorflow              2.3.0-1              2.3.0-2
                     tensorflow-cuda              2.3.0-1              2.3.0-2
                      tensorflow-opt              2.3.0-1              2.3.0-2
                 tensorflow-opt-cuda              2.3.0-1              2.3.0-2
         v2ray-domain-list-community     20200805043440-1     20200806135215-1
                          xcb-imdkit     0.0.0.20200806-1     0.0.0.20200808-1
                              xmobar              0.35-12              0.35-14


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-08-07           2020-08-08
-------------------------------------------------------------------------------
                   amd-ucode 20200803.r1680.9bc3789-1 20200807.r1689.c331aa9-1
              linux-firmware 20200803.r1680.9bc3789-1 20200807.r1689.c331aa9-1
                             systemd                246-1              246.1-1
                        systemd-libs                246-1              246.1-1
                  systemd-resolvconf                246-1              246.1-1
                  systemd-sysvcompat                246-1              246.1-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-08-07           2020-08-08
-------------------------------------------------------------------------------
               manjaro-arm-tools-git 2.8.6.r14.g6be384b-1 2.8.6.r18.ga51a70d-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-08-07           2020-08-08
-------------------------------------------------------------------------------
                         libbytesize                2.3-1                2.4-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-08-07           2020-08-08
-------------------------------------------------------------------------------
                       lib32-systemd                246-1              246.1-1

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

5 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

System takes a long time to boot

If you've got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable org.cups.cupsd.service
systemctl enable org.cups.cupsd.socket

I think I've some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

... and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Older issues

Thunderbird might throw an error of older version available.

Use $ thunderbird --allow-downgrade from a terminal to fix it.

HP Device Manager


Pamac stuck at "Preparing..."

Users have reported issues with the recent release candidate of Pamac 9.4.0 when initiating transactions, being stuck at "Preparing..." without being able to cancel the transaction and quit Pamac normally.

For now, it is recommended to use pacman to do package management until this issue is solved and Pamac become usable again. Please test out upcoming updates for Pamac to see if the issue becomes solved or not.

If you are stuck in "Preparing...", you will have to manually kill the pamac-managerprocess.

Reported on Gitlab:
https://gitlab.manjaro.org/applications/pamac/issues/757

Upgrading firewalld package to 0.8.1-2 requires manual intervention

Please read this announcement if you have file conflicts when trying to upgrade firewalld package to 0.8.1-2.

Firewalld requires manual intervention

khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.


Weird font glitches (see screenshots below).

If you have weird glitches like below...

Screenshots

Screenshot%20from%202020-01-16%2023-59-49
string3
strings%20mismatch
post%20transaction%20hooks

... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.


Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in

/usr/lib/python3.7/site-packages/

To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.


System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.


xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.


Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.


Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


gnome-shell-extension-desktop-icons

the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

I forgot to update grub :wink:
corrected now...

No issues went fine

Once again someone Please answer the question. If one just did a clean install of Manjaro KDE just prior to the updates from yesterday do they need to manually fix the boot-hole? Thanks

iso are "old" read dates
and we can read gub version : before 2.04.11 = make install and update


if we use a net install as architect or JADE it's ok

1 Like

yes as we did not yet released any ISO with the latest grub.

1 Like

@philm

GRUB localization is working now (fingers crossed).

Updated successfully.
Once again, thanks Manjaro team. :slightly_smiling_face:

I am on stable branch but i got pamac 9.5.7-1 update, not sure how to proceed

You may just update Pamac if you like.

Nothing went boom here on Nvidia, KDE.
I noticed in the branch comparison that kernel 5.8.0-2 should have landed in Testing, but I just have -1 available. Typo on the website?

Edit: It's available now :smiley:
Edit2: And no errors. Thanks for bringing futex patch to 5.8 :heart_eyes:

1 Like

All good here. I also got an update of kernel 5.8.0-2. Thanks guys, you keep rocking!

updates to pamac, and sometimes the browsers are expedited to the stable branch. you may update as normal. no partial upgrade encouraged or required.

1 Like

Upgraded and it runs OK. I got a missing firmware warning with kernel 5.8, but so far it doesn't have any effect on my daily usage. So I guess it's not a big deal. :+1:

Screenshot_20200809_132408

NO NEED ANYMORE, if you install latest stable staging RC2. This was grub version screenshot capture from RC2 live. I'm installing 2 days ago without any trouble on grub.

1 Like

Just switched to testing branch (from stable). Changed kernel to 5.8. Everything went fine. No issues yet.

Just checed via Pamac instead of via Konsole and it is at 2.04-11-1.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by