[Testing Update i686] 2018-09-25 to 10-07 - systemd, Firefox

The above technique has not worked on Dell Latitude D820 because I am unable to do a sudo pacman -S audit due to this error:
sudo pacman -S audit
sudo: error in /etc/sudo.conf, line 0 while loading plugin "sudoers_policy"
sudo: unable to load /usr/lib/sudo/sudoers.so: libaudit.so.1: cannot open shared object file: No such file or directory
sudo: fatal error, unable to load plugins
No choice but to use chroot for this machine.

no sudo!!!!!!!

pacman -S audit before rebooting

Somehow both options did not work before rebooting on this laptop even though it worked on 4 other computers.

But once I chrooted your instruction was instrumental in saving my bacon.

I was wary of chrooting but this tutorial helped. How to save your Manjaro installation when it breaks

Thank you for your assistance.:joy:

I found @eugen-b suggestion of using manjaro-chroot -a to be the easiest. Once there I:

  1. nano /etc/pacman-mirrors.conf (change branch & save) then
  2. pacman-mirrors -c all
  3. pacman -Syyuu

update & reboot, quick remove the USB!!!! (I think?)

1 Like

DO NOT USE sudo HERE!!!!!!

C'mon into the deep end! The water's fine & it's not so crowded!!!!

There is something called premonition, luck or even divine providence. Call it what you like or even all three. But why? Because as I was updating my desktop it froze and I had to do a hard shut down.

Now, I got a chance to use your/eugen-b's suggestion but had to modify nano to mousepad as I used an old ISO. This caused a:
Failed to synchronize all databases.
So a quick search and I found this solution:

But after this I got: Errors occurred No packages were upgraded when the system was loading files. So, once again a search and this:
I seem to think when I came across this a while back I searched, found nothing, gave up and did a pacman -Scc and it was fine…by jonathon
Did a fresh download but the upgrade is failing because systemd is corrupted.
File attached![Screenshot_2018-09-29_02-59-50|441x500]
Cannot upload whole file but uploading final error.

With you three Musketeers around I have conquered fear but now tell me where do I go from here because I cannot remove or replace corrupted systemd.

I used this:

Is depreciated.....use

pacman-mirrors -c all

I used this but encountered the same problem.

Did that. Unfortunately, it appears my system is corrupted because of the freeze. I do not use this computer as much so can wait for a solution. But since I do not have much data on it, I do not mind doing a clean reinstall of https://osdn.net/projects/manjaro32/storage/xfce/17.1.7-rc1/ or even trying out the Awesome Spin which I find quite interesting especially as this computer has only 2 Gb RAM. Thanks for your help.

I had more or less the same adventure...luckily on a somewhat redundant box as well...
What I did was start up with the live media and litteraly chroot into the system.
Did that work?

These steps should get you into the console and basically INSIDE the ailing system.
If so, then try to see if you can reach out, in one command that tests the TCP stack, the connectivity of your LAN (if any), the modem and your DNS settings:

ping www.yahoo.com

...or...any of your liking...
If you van reach out, try to update the mirrors...
The next step is to see what can be rescued...
perhaps try a resync with the mirrors...

pacman -Sy

(you are in "root mode" so SUDO is not called for)
If this works...lets gently do the update, and...get that much earned cut o' coffee :wink:

pacman -Syyuu

And watch...
now, Pacman logs everything in /var/log/pacman.log...
Since the system is mounted, you can call that up from the mousepad available from the live media, in case you need tp pasebin a log...
And...finally, make sure you have run these commands (compulsary, but you can do it at any time in the process...)

pacman -S good_mood
systemctl enable good_mood.service -f

the forum is your best friend :slight_smile:
:rose: Melissa :rose:
(having read the whole post diagonally...I will now, get coffee)

1 Like

9 posts were split to a new topic: Can't load X

To install audit after systemupgrade and before rebooting do NOT use sudo. You will get an error because audit is missing. But perhaps you can just use su command. Didn't test this.

But you can install audit before systemupgrade.

Using mousepad gives this error:
[manjaro /]# mousepad var/log/pacman.log
No protocol specified
Unable to init server: Could not connect: Connection refused

(mousepad:1251): Mousepad-ERROR **: 10:35:43.310: Cannot open display:
Trace/breakpoint trap (core dumped)

Tried nano but despite all efforts it only copied one line despite highlighting entire selection so cannot use pastebin to upload logs. From nano copied this part which shows when the error occurred.
2018-09-28 20:48] [ALPM] upgraded imagemagick ( ->
[2018-09-28 20:48] [ALPM] upgraded libmnl (1.0.4-1 -> 1.0.4-1.1)
[2018-09-28 20:48] [ALPM] upgraded libnftnl (1.1.1-1.0 -> 1.1.1-1.1)
[2018-09-28 20:48] [ALPM] upgraded libnl (3.4.0-1.1 -> 3.4.0-1.2)
[2018-09-28 20:48] [ALPM] upgraded iptables (1.6.2-2.0 -> 1.8.0-1.0)
[2018-09-28 20:48] [ALPM] upgraded kmod (25-1.0 -> 25-1.1)
[2018-09-28 20:48] [ALPM] upgraded libelf (0.171-1.0 -> 0.171-1.3)
[2018-09-28 20:48] [ALPM] upgraded libseccomp (2.3.3-1.0 -> 2.3.3-1.2)
[2018-09-28 20:48] [ALPM] upgraded util-linux (2.32.1-2.1 -> 2.32.1-2.3)

pacman -Syyuu fails due to

error: failed to commit transaction (conflicting files)
systemd: /etc/X11/xinit/xinitrc.d/50-systemd-user.sh exists in filesystem
systemd: /etc/xdg/systemd/user exists in filesystem
systemd: /usr/bin/bootctl exists in filesystem
systemd: /usr/bin/busctl exists in filesystem
systemd: /usr/bin/coredumpctl exists in filesystem
systemd: /usr/bin/hostnamectl exists in filesystem
systemd: /usr/bin/journalctl exists in filesystem
systemd: /usr/bin/kernel-install exists in filesystem

Here I was not in a Live system or chroot mode. I used pamac gui to update the system then pamac again to install audit and had no problem on 3 computers. But I appreciate your point about installing audit before upgrade. I will test this out when I update my friends computer.

There is a lot for me to learn and I am thankful to the forum for sharing. If anyone has suggestions how to get out of this mess, I will carry them out. If you'll think I should just reinstall will do that. Thanks

I never ever update in the GUI. I hit Ctrl-Alt-F2 to enter a console and update there. I think I know what might have occured...you update in the DE, the DE needed to "blip" (reboot or otherwise do something that interups the update) and poof...dead system. The one lesson I learned from Arch...where I did an update and lost the kernel...
Just me...but, try to always update inthe console, and the one alongside the GUI...not the console emulator int he DE...
How many of these "exist" int he file system? Is deleting an option? and then doing an update?
Keeping my eye on this thread...

By following this announcement thread, I was able to restore my system by booting the liveUSB, opening a terminal and executing

manjaro-chroot -a
pacman -Syu
pacman -S audit
1 Like

OK, I think libaudit.so is coming from pam:

$ ldd /usr/lib/libpam.so
	linux-gate.so.1 (0xb7f60000)
	libaudit.so.1 => /usr/lib/libaudit.so.1 (0xb7f00000)
	libdl.so.2 => /usr/lib/libdl.so.2 (0xb7efa000)
	libc.so.6 => /usr/lib/libc.so.6 (0xb7d18000)
	libcap-ng.so.0 => /usr/lib/libcap-ng.so.0 (0xb7d11000)
	/usr/lib/ld-linux.so.2 (0xb7f62000)

Let me rebuild pam and see if libaudit remains.

Rebuilding with a clean container (i.e. without audit installed) and there's no libaudit dependency.

:: Different overlay package(s) in repository core i686

                             PACKAGE          x32-testing         x32-unstable
                                 pam                    -           1.3.1-1.11

:: Different sync package(s) in repository extra i686

                             PACKAGE          x32-testing         x32-unstable
                                  gv              3.7.4-3            3.7.4-3.1
                              gweled              0.9.1-4            0.9.1-4.1
                          kobodeluxe              0.5.1-6            0.5.1-6.1
                               msmtp            1.6.8-1.0            1.6.8-1.1
                           msmtp-mta            1.6.8-1.0            1.6.8-1.1
                             udisks2            2.8.0-1.0            2.8.0-1.1

:: Different sync package(s) in repository community i686

                             PACKAGE          x32-testing         x32-unstable
                          maxima-ecl             5.41.0-1           5.41.0-1.1
                                 tup            0.7.7-1.0            0.7.7-1.1

This should properly fix the audit issue:

:: Different overlay package(s) in repository core i686

                             PACKAGE          x32-testing         x32-unstable
                                 pam           1.3.1-1.11                    -
                             systemd              239.2-1              239.2-2
                  systemd-resolvconf              239.2-1              239.2-2
                  systemd-sysvcompat              239.2-1              239.2-2

audit support has been added to systemd and audit is now a dependency.

Please downgrade pam back to 1.3.1-1 if you've upgraded in the meantime. You can also set audit back to "installed as a dependency" with:

sudo pacman -D --asdeps audit

The system was completing its update and it froze at a point which said Upgrading systemd. I thought the freeze was temporary but after 30 minutes I had to do a hard shutdown. I agree I have a dead system and because I cannot even upload the logs on that computer it is not possible for anyone to help. Hence, I first installed Manjaro Awesome, then Manjaro Openbox but unfortunately MPV player did not work and VLC froze the system. I then tried the 2 new Manjaro Xfce & Kde Beta editions but they did not display the Grub on boot creating a problem on my dual boot system. So, back to Manjaro32 Testing.

Done that.

This is what makes life and Manjaro exciting.

1 Like

This update went through on Kernel 414 without a problem except a warning came up that pam 1.3.1-1.11 is newer than 1.3.1-1.1.

Forum kindly sponsored by