[Testing Update i686] 2018-09-25 to 10-07 - systemd, Firefox

I Won!!!
Ahem...I get a kernel panic (Linux 4.4) over a non-found bit : libaudit.so.1
Okay, first off, tesdt with other kernels...
"Et hop...ça recommence" :smiling_face_with_three_hearts:
:rose: Melissa :rose:
Edit - pacman -S audit did the trick, thanks :slight_smile:

1 Like

sudo pacman -S audit resolves this. I don't know why this has appeared, it's not needed for x86_64. It's possibly a dirty build container/chroot/whatever arch32 use?


Boot with the medium (DVD, CD, stick)
open a console
enter the magic formulae:

su -
[manjaro] as password (yea, now everyone knows :stuck_out_tongue_winking_eye: )
mount /dev/sda3 /mnt
cd /mnt
mount -t proc proc proc/
mount -rbind /sys sys/
mount -bind /dev dev/
chroot /mnt

to reboot you will have to exit first so you're inthe live system and not the on-disk system...I dont think a reboot from the chroot is even possible :thinking:

I think it's good to go stable, take that audit still needs to be installed afterwards...
The package, as it is now, will cuase a kerlen panic...be aware of that...

Didn't read the posts in this thread and switched to testing. Hoped to get rid of annoying systemtray icons in i3bar since last upgrade in stable branch. Presumably culprit mesa package. Or Xorg. Only Xorg gets an upgrade.

After systemupdate I got the error message libaudit.so.1 not found with sudo (tried to edit /etc/default/grub). After reboot kernel panic 'cause absence of libaudit.so.1. The audit framework seems to be a new dependency to userspace and kernelspace but is not installed automatically 'cause it's not recommended by any new package or packageupdate.
To boot into your system you can append audit=0 to kernel paramaters according to ArchWiki Audit framework. Then do pacman -S audit.

My workaround had been a bit more complicated (using chroot).
Booted with live system. Then did the following as root:
mount /dev/'rootpartition' /mnt
mount /dev/'bootpartition' /mnt/boot
mount --bind /proc /mnt/proc
mount --bind /sys /mnt/sys
mount --bind /dev /mnt/dev
mkdir /mnt/hostrun
mount --bind /run /mnt/hostrun
mv /mnt/ect/resolv.conf /mnt/resolv.conf.bak (in case it's not autoconfigured)
cp /etc/resolv.conf /mnt/etc/resolv.conf (should be autoconfigured at next reboot)
chroot /mnt
pacman -S audit

After reboot did pacman -S audit again then removed /hostrun and /etc/resolv.conf.bak after checking it's content.

Happy again, no kernel panic, sudo working.

Many thanks again to manjaro32 developers for their great work. But please check dependency of packages to audit framework and systemtrayicons in i3bar. After an uptime of approx. 1 to 2 hours the icons seem okay but after reboot its a mess again 'til running 1 to 2 hours again.

1 Like

Oh snap!!!

Installed audit & went back into the deep end! I can swim!!!:heart_eyes:

I read this

Then this:

Was happy for the swimmer.
After updating I did sudo pacman -S audit before rebooting on 3 machines and had no problems. Thanks to the hard work of those mentioned above.

The above technique has not worked on Dell Latitude D820 because I am unable to do a sudo pacman -S audit due to this error:
sudo pacman -S audit
sudo: error in /etc/sudo.conf, line 0 while loading plugin "sudoers_policy"
sudo: unable to load /usr/lib/sudo/sudoers.so: libaudit.so.1: cannot open shared object file: No such file or directory
sudo: fatal error, unable to load plugins
No choice but to use chroot for this machine.

no sudo!!!!!!!

pacman -S audit before rebooting

Somehow both options did not work before rebooting on this laptop even though it worked on 4 other computers.

But once I chrooted your instruction was instrumental in saving my bacon.

I was wary of chrooting but this tutorial helped. How to save your Manjaro installation when it breaks

Thank you for your assistance.:joy:

I found @eugen-b suggestion of using manjaro-chroot -a to be the easiest. Once there I:

  1. nano /etc/pacman-mirrors.conf (change branch & save) then
  2. pacman-mirrors -c all
  3. pacman -Syyuu

update & reboot, quick remove the USB!!!! (I think?)

1 Like

DO NOT USE sudo HERE!!!!!!

C'mon into the deep end! The water's fine & it's not so crowded!!!!

There is something called premonition, luck or even divine providence. Call it what you like or even all three. But why? Because as I was updating my desktop it froze and I had to do a hard shut down.

Now, I got a chance to use your/eugen-b's suggestion but had to modify nano to mousepad as I used an old ISO. This caused a:
Failed to synchronize all databases.
So a quick search and I found this solution:

But after this I got: Errors occurred No packages were upgraded when the system was loading files. So, once again a search and this:
I seem to think when I came across this a while back I searched, found nothing, gave up and did a pacman -Scc and it was fine…by jonathon
Did a fresh download but the upgrade is failing because systemd is corrupted.
File attached![Screenshot_2018-09-29_02-59-50|441x500]
Cannot upload whole file but uploading final error.

With you three Musketeers around I have conquered fear but now tell me where do I go from here because I cannot remove or replace corrupted systemd.

I used this:

Is depreciated.....use

pacman-mirrors -c all

I used this but encountered the same problem.

Did that. Unfortunately, it appears my system is corrupted because of the freeze. I do not use this computer as much so can wait for a solution. But since I do not have much data on it, I do not mind doing a clean reinstall of https://osdn.net/projects/manjaro32/storage/xfce/17.1.7-rc1/ or even trying out the Awesome Spin which I find quite interesting especially as this computer has only 2 Gb RAM. Thanks for your help.

I had more or less the same adventure...luckily on a somewhat redundant box as well...
What I did was start up with the live media and litteraly chroot into the system.
Did that work?

These steps should get you into the console and basically INSIDE the ailing system.
If so, then try to see if you can reach out, in one command that tests the TCP stack, the connectivity of your LAN (if any), the modem and your DNS settings:

ping www.yahoo.com

...or...any of your liking...
If you van reach out, try to update the mirrors...
The next step is to see what can be rescued...
perhaps try a resync with the mirrors...

pacman -Sy

(you are in "root mode" so SUDO is not called for)
If this works...lets gently do the update, and...get that much earned cut o' coffee :wink:

pacman -Syyuu

And watch...
now, Pacman logs everything in /var/log/pacman.log...
Since the system is mounted, you can call that up from the mousepad available from the live media, in case you need tp pasebin a log...
And...finally, make sure you have run these commands (compulsary, but you can do it at any time in the process...)

pacman -S good_mood
systemctl enable good_mood.service -f

the forum is your best friend :slight_smile:
:rose: Melissa :rose:
(having read the whole post diagonally...I will now, get coffee)

1 Like

9 posts were split to a new topic: Can't load X

To install audit after systemupgrade and before rebooting do NOT use sudo. You will get an error because audit is missing. But perhaps you can just use su command. Didn't test this.

But you can install audit before systemupgrade.

Forum kindly sponsored by