The manjaro-chroot command does not detect my installed Manjaro

Hello, folks. This is my first contribution here.

I crashed my Manjaro Linux system yesterday replacing systemd with openrc. So I've been spending hours to fix my installed Manjaro 64 bits XFCE, with a Manjaro 64 bits XFCE live pendrive. When I was logged in at the live session, at Terminal manjaro-chroot accuses:

[manjaro@manjaro ~]$ sudo manjaro-chroot -a
==> ERROR: You can't mount 0!
[manjaro@manjaro ~]$

I tried to use mhwd-chroot too and it shows:

[manjaro manjaro]# mhwd-chroot
xfce4-terminal -e mhwd-chroot-shell

No linux system found !

[manjaro manjaro]#

What is the problem with the commands above?

The Manjaro installation in my PC was installed with a Manjaro Illyria 18.0.4 live pendrive. Under the latest Manjaro Architect, via TTY, with LUKS encryption for the root partition.

For the root partition the blkid command shows:

[manjaro@manjaro ~]$ blkid | grep crypto
/dev/sdb2: UUID="a large number" TYPE="crypto_LUKS" PARTUUID="a small number"
[manjaro@manjaro ~]$

And it returns problems with a simple mount command. I can't even open the LUKS encryption via Terminal:

[manjaro@manjaro ~]$ cryptsetup luksOpen /dev/sdb2 ManjaroRootPartition
Device /dev/sdb2 does not exist or access is denied.
[manjaro@manjaro ~]$

I've been already looking for support about the problem:

but there's no solution there.

What can I do?

Thanks for appreciatte.

PS: the manjaro-chroot command could once detected a Windows installation that I really have in my laptop, but not the Manjaro installation.

Try simply pressing Enter or answering with 1 regardless of presented option

Select system to mount [0-0]

PS: Please enclose terminal output with three backticks


or use the </> button. Makes for better readability.

1 Like

Mount your partitions manually under /mnt and run

manjaro-chroot /mnt

You can list your partitions with lsblk. Mounting your root and efi partitions looks something like this:

mount /dev/sda2 /mnt
mount /dev/sda1 /mnt/boot/efi

Actually, just run this with sudo before using manjaro-chroot

In this point

I put the bash prompt at the final to show intentionally there were no more messages from manjaro-chroot. Press Enter did not help anything.

The manjaro-chroot does not return any messages. Not even

or other thing.

Sorry, man :joy::rofl::sweat_smile:

The cryptsetup command was unable to unlock the crypto_LUKS partition. :scream::sob::disappointed_relieved:

This answer somewhat finished the problem. (I guess) Manjaro Architect Installations prevents LUKS partitions to be recognize by other Linux systems. I don't know which part of installation Manjaro Architect does it. But there's a solution for this, using graphical interface on a Manjaro live session.

  1. I logged in at a Manjaro live session
  2. I mount the Manjaro Installation root partition using Thunar (it prompts me the LUKS password and I done this) (gnome-disk-utility does it good too)
  3. HERE IS THE MAGIC TRICK no one says on Internet out there: DEDICATED LINUX INSTALLATIONS does not follows most Linux tips on Linux Q&A universe. What is "dedicated Linux installations"? This installations where /var, /boot, /opt, /usr etc is apart the root directory (/). In my case I needed to previously mount /boot at the Manjaro Installation root partition (installed on the hard disk).

The Manjaro root partition mounted using Thunar was mounted at

So I mounted MANUALLY the Manjaro Installation (not the live session) boot partition at the folder "Boot" available at Manjaro Installation root partition. I did this using the mount command:

sudo mount /dev/sdb1 /run/media/manjaro/AVeryLargeNumber/boot

After all this problem to make recognizable the Manjaro Installation to the Manjaro live session, I execute:

sudo manjaro-chroot /run/media/manjaro/AVeryLargeNumber/

and it worked. With all this job, I finally executed the manjaro-chroot command successfully.

So the problem in this case was how to mount the entire Manjaro Installation to manjaro-chroot detect it.

Sorry to explain all the story but there's a lack of didactic explanations about how to mount a Linux installed system to this system receive maintenance.

Thanks all you for reading. I promise to answer all in one answer next time.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by