The Pain of using OpenVPN

Greetings fellow Manjaro-Enthusiasts,

after searching for solutions since a couple of days, I don't have an idea how to setup OpenVPN so it can connect to the servers. Sounds pretty silly, please hear me out however.

Classification:

1) The problem
2) What I did to solve the problem
3) Questions


1) The problem


I don't know to use OpenVPN to connect to VPN servers.


2) What I tried to solve the problem

Installed everything needed for OpenVPN including networkmanager-openvpn.
The first try was done with the network manager in Manjaro Budgie by importing the .ovpn file given by the VPN service.

Screen Capture_nm-connection-editor_20200712200018

The "Save" Button is grey'd out, given the User private key is inside the .ovpn file already!

So, it does not working obviously and I started googeling around as well as searching in his forums for solutions.. and nothing helpful found except the sentence that nearly every VPN requires manual interaction to configure.

Yeah, but how?

The next logical step is going to the Arch Wiki: https://wiki.archlinux.org/index.php/OpenVPN

Next thing is: Who is even remotely able to understand all this gibberish? Me not.

To summarize it, as far as I understand: As OpenVPN profile is needed, so I've created it with:

sudo ln -sfv /home/USER/ovpn/DE1.ovpn.to.ovpn /etc/openvpn/ovpn.conf

.. and then?


3) Questions


Is it even possible to use OpenVPN on Manjaro flawlessly or am I too dumb to understand the whole process?

You can feel my frustration.. :confounded:

~ Sincerely, SudoSandwich

This is a known bug. You have to select it. It is in the same location as the other certificates. Then make sure all the other Advanced Options are set like in the ovpn file and click save. You need to do this every time you edit this connection.

1 Like

Appreciate the quick reply.

I copied the private key out of the .ovpn file and pasted it into a txt to save it as .key.

There is no User Key Password because everything goes through inline config according to the VPN service support.

VPN still can't connect.

This usually means a setting is wrong. Check the journal

journalctl -b -u NetworkManager.service --no-hostname --no-pager 

and/or

journalctl -b -t nm-openvpn --no-hostname --no-pager
1 Like

It's all gibberish..

Summary

https://pastebin.com/y5iwabAt

The second command shows:

-- Logs begin at Thu 2020-07-09 00:18:17 CEST, end at Sun 2020-07-12 20:49:31 CEST. --
-- No entries --

Well, you have to start a VPN connection. Your system will not do it automatically.

The log show just it was added, 2 times updated and then deleted. You need to save it and then start it.

op="connection-add" uuid="035939c8-89f1-45f7-99b9-559160965571" name="DE1.ovpn.to" pid=13131 uid=1000 result="success"
op="connection-update" uuid="035939c8-89f1-45f7-99b9-559160965571" name="DE1.ovpn.to" args="vpn.secrets" pid=13131 uid=1000 result="success"
op="connection-update" uuid="035939c8-89f1-45f7-99b9-559160965571" name="DE1.ovpn.to" pid=13131 uid=1000 result="success"
op="connection-delete" uuid="035939c8-89f1-45f7-99b9-559160965571" name="DE1.ovpn.to" pid=22258 uid=1000 result="success"
1 Like

Really appreciate help, @xabbu. I hope you are doing well and continuing the wholesome mission to help newbies coming into Manjaro :heart:

So, to summarize the solution for everyone reading after this day :relaxed:

1.) If the network manager can't grab the private user key and forces you to do it manually, just open the .ovpn file with a text editor and copy the private key to paste it into txt file, save it as .key
2.) Import the private key manually, now you can click on "Save".
3.) Left-click on the Network Manager GUI, choose 'VPN Connection' and click again on this VPN connection setted up.

VPN connection established!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by