The symbol "" is not found in the grub after the latest update


I updated yesterday. Then the grub stopped of working, saying the symbol "" is not found or unknown.
I also tried the tutorial by middle of Can you check the health of boot and grub of my external HDD plugged on my Mac mini before I do something stupid?, running the command sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck --debug --removable . But the same error still is here.

$ sudo parted -l
Model: ATA Hitachi HTS54755 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size   File system  Name                  Flags
 1      20.5kB  210MB  210MB  fat32        EFI System Partition  boot, esp
 2      210MB   499GB  499GB  hfs+
 3      499GB   500GB  650MB  hfs+

Model: SanDisk Cruzer Blade (scsi)
Disk /dev/sdb: 4005MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      32.8kB  2156MB  2156MB  primary               boot
 2      2156MB  2160MB  4194kB  primary               esp

Model:  Mass Storage Device (scsi)
Disk /dev/sdc: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name  Flags
 1      1049kB  317MB   316MB   fat32                 msftdata
 2      317MB   8338MB  8022MB  linux-swap(v1)
 3      8338MB  438GB   429GB   ext4
 4      438GB   500GB   62.3GB  ext4

$ sudo blkid
/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/loop3: TYPE="squashfs"
/dev/sda1: LABEL="EFI" UUID="67E3-17ED" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="2b51e9de-db7c-473e-9238-db0d2691cb4c"
/dev/sda2: UUID="0ad0d00c-4782-3d2c-a629-5acbd1792bc1" LABEL="High Sierra" TYPE="hfsplus" PARTUUID="822f779b-012e-4aa9-9596-75ebfedddec9"
/dev/sda3: UUID="01cb061d-937b-3aba-943c-0ba15f417b93" LABEL="Recovery HD" TYPE="hfsplus" PARTUUID="4cf1744f-ccc4-4df8-b7c0-71560b6792a4"
/dev/sdb1: UUID="2018-08-18-15-33-20-00" LABEL="MJR17112" TYPE="iso9660"
/dev/sdb2: SEC_TYPE="msdos" LABEL="MISO_EFI" UUID="AA50-706E" TYPE="vfat"
/dev/sdc1: UUID="6C38-1532" TYPE="vfat" PARTUUID="7ce26d75-daa5-439b-bb63-46b5c71fdf29"
/dev/sdc2: UUID="397a66af-5f80-4c81-9167-46949d22d10d" TYPE="swap" PARTUUID="6cd86873-620e-48a8-a740-06b0e015389e"
/dev/sdc3: UUID="8f89c1cd-1f62-4539-b3c0-71a85928e969" TYPE="ext4" PARTUUID="cb0febd8-9b3b-4a0f-94e2-84f83ee51832"
/dev/sdc4: UUID="aae7f601-f76a-48d3-a28a-984435822849" TYPE="ext4" PARTUUID="3a637095-e22e-4025-b30a-4de240ba2504"

$ efibootmgr
BootCurrent: 0000
Timeout: 5 seconds
BootOrder: 0003,0002,0080,0001,0000
Boot0000* ubuntu
Boot0001* deepin
Boot0002* manjaro
Boot0003* manjaro
Boot0080* Mac OS X
Boot0081* Mac OS X

Hello @gohlip, @AgentS and @jonathon!

Please, can you merge my topic into Grub_key_is_interrupt?

That appears to be a different as the other issue was during installation, not after an update. This is also what the "Flag this post" button (Custom) can be used for.

Did you run this from the installation, using chroot? Could you not boot the installation using Detect bootloader?
If yes, get to your installation again and post

inxi -Dpuoxxz
cat /etc/fstab

If not, you have to redo all that you did in your previous topic and install grub.

Describe more details on the difference between this and your previous issue, please. I thought you had already learned how to fix/configure it by now.. :sweat_smile:

Yes, I did. And the error still was the same.

Yes, but the same error still insists.

[manjaro@manjaro ~]$ inxi -Dpuoxxz
  Local Storage: total: 935.25 GiB used: 2.01 GiB (0.2%) 
  ID-1: /dev/sda vendor: Hitachi model: HTS547550A9E384 size: 465.76 GiB 
  speed: 3.0 Gb/s serial: <filter> 
  ID-2: /dev/sdb type: USB vendor: SanDisk model: Cruzer Blade 
  size: 3.73 GiB serial: <filter> 
  ID-3: /dev/sdc type: USB model: Mass Storage Device size: 465.76 GiB 
  serial: <filter> 
  ID-1: / size: 5.78 GiB used: 135.6 MiB (2.3%) fs: overlay dev: ERR-102 
  uuid: N/A 
  ID-2: /run/miso/bootmnt size: 2.01 GiB used: 2.01 GiB (100.0%) 
  fs: iso9660 dev: /dev/sdb1 uuid: 2018-08-18-15-33-20-00 
  ID-1: /dev/sda1 size: 200.0 MiB fs: vfat label: EFI uuid: 67E3-17ED 
  ID-2: /dev/sda2 size: 464.96 GiB fs: hfsplus label: High Sierra 
  uuid: 0ad0d00c-4782-3d2c-a629-5acbd1792bc1 
  ID-3: /dev/sda3 size: 619.9 MiB fs: hfsplus label: Recovery HD 
  uuid: 01cb061d-937b-3aba-943c-0ba15f417b93 
  ID-4: /dev/sdb2 size: 4.0 MiB fs: vfat label: MISO_EFI uuid: AA50-706E 
  ID-5: /dev/sdc1 size: 301.0 MiB fs: vfat label: N/A uuid: 6C38-1532 
  ID-6: /dev/sdc2 size: 7.47 GiB fs: swap label: N/A 
  uuid: 397a66af-5f80-4c81-9167-46949d22d10d 
  ID-7: /dev/sdc3 size: 400.00 GiB fs: ext4 label: N/A 
  uuid: 8f89c1cd-1f62-4539-b3c0-71a85928e969 
  ID-8: /dev/sdc4 size: 57.99 GiB fs: ext4 label: N/A 
  uuid: aae7f601-f76a-48d3-a28a-984435822849 

[manjaro@manjaro ~]$ manjaro-chroot -a /dev/sdc
==> Mounting (ManjaroLinux) [/dev/sdc3]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]
 --> mount: [/mnt/home]

[manjaro /]# cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=6C38-1532                            /boot/efi      vfat    defaults,noatime 0 2
UUID=397a66af-5f80-4c81-9167-46949d22d10d swap           swap    defaults,noatime 0 2
UUID=8f89c1cd-1f62-4539-b3c0-71a85928e969 /              ext4    defaults,noatime 0 1
UUID=aae7f601-f76a-48d3-a28a-984435822849 /home          ext4    defaults,noatime 0 2
[manjaro /]# 

I ran these commands from the external HD:

grub> search.file /etc/manjaro-release  root
grub> configfile /boot/grub/grub.cfg

But the same error still was there. Then I ran from the installation, using chroot.

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sdc -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck --debug --removable

I regret to say:

This is a Manjaro specific error
A DDG search returns Manjaro topics at the top.

I assume it is not impolite to ask help from @philm
What is this error, when does it trigger and how can one solve it?

Hello @gohlip and @AgentS!

Is it possible to run as manjaro-croot, mounting sdc3 for running sudo pacman -Syyu, from the installation? The CEO of Manjaro has just released the new packages of the testing and unstable versions today (although my version be stable). I think he seems to fix that grub key symbol.

Yes, but I didn't see any mention on your issue. Is there any?

I still did not test, I just want to make sure that I can or if it is a bad idea. I do not know if running these commands, principally sudo pacman -Syyu from chroot will fix that grub key symbol error and the broken grub.

This command is used to update your installed packages with newer versions, IF THERE ARE any. If not, it does nothing. The latest update has updated kernels, which may or not fix this issue, as we have no info regarding.. It doesn't hurt to update your system though :wink:

OK, what exactly was done. grub_key_is_interrupt got introduced with this patch and therefore got added with grub 2.03.0-10. Does a standard Manjaro v18.0 ISO release work?

To fix this issue, do I use chroot from the installation to run the upgrade (-Syyu) on the partition sdc or do I reinstall?

The problem might be your grub installation. You may try to restore it. Seems we need to write a graphical tool for it and distribute it with one of our next ISOs :wink:

Then I ran those commands, no installation errors, but the same grub error was still there. But I never used sudo pacman -S mtools os-prober. Should I try again? Or better we wait with a new release of the next ISO?

Boot to your installation with Live media (or chroot) and run update-grub.
Have you done this since you had this new issue?

OK, when I arrive home, I will try it again and test it. I am at my college and finished my thesis now.

1 Like

I have tried, it has fixed the grub, but unfortunately I am stuck in the systemctl. You can view the image:


I guess you haven't read any recent announcement about the new grub, or I am just guessing..
You need to check if you have fsck in your /etc/mkinitcpio.conf.
Have you enabled silent boot/grub?
Have you installed the silent boot service?
Have you merged pacsave/pacnew files? (run pacdiff)

Wow, I failed to read it. I will do it again.

1 Like

Sorry for my late. I felt hunger. I ate a lot.

I did like like:

fsck -a /dev/sdc
fsck -r /dev/sdc

manjaro-chroot -a /dev/sdc

# Taken from [Testing Update] 2018-11-08 by @philm

sudo pacman -S linux418

# I have quiet under GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub 

sed -i -e 's|fsck||g' /etc/mkinitcpio.conf && sudo pacman -S systemd-fsck-silent
sudo mkinitcpio -P
sudo grub-editenv - set menu_auto_hide=1
sudo update-grub

I reboot and another fail. Dependencies failed for /home and "Local File System" during systemctl.

I have checked my external HD's Manjaro branch verson. Still stable. SHould I move to tetsing or unstable?

Forum kindly sponsored by