Themes don't load in properly after boot

I've just installed a fresh install of XFCE Manjaro.

When I log in for the first time after boot, my theme doesn't load in properly. It seems to load in half-Adwaita half-Adapta-Maia when it should all load in as Adapta-Maia. The screenshot can illustrate the problem more effectively.

If I log out and log back in, the theme loads as expected.

Screenshot_2019-03-10_17-51-06

I think I've fixed it by restarting and saving the session on logout.

There are several reports of this behavior and so far there is no fix(?) . Just keep it in the head as "known issues"
Example

try this

1 Like

Unfortunately this didn't work for me. The theme still loads in incorrectly.

Running "xfsettingsd --replace" does fix it though.

I tried adding a command which ran xfsettingsd --replace on autostart, but this didn't work either.

I had to add a delay as well. This is the command on auto start:

sh -c “sleep 7 && xfsettingsd --replace“

This should work for you.

xfsettingsd handles autostart, so if it starts bad then you won't have your little command start at boot, try using a different way of autostart.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by