Thinkpad E585 - Suspend problems

Hi there,

I got this problem where my laptop more often then not doesn't come back from suspend. The screen just stays black and cutting the power is the only way to the machine going again. It's not always the case and I have not been able to reproduce it consistently. I am a bit clueless how to troubleshoot this. My specs:

inxi -Fxz

System:
  Host: Matamos Kernel: 5.4.15-2-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.2.0 Desktop: Gnome 3.34.3 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 20KV0008MH v: ThinkPad E585 
  serial: <filter> 
  Mobo: LENOVO model: 20KV0008MH v: SDK0J40697 WIN serial: <filter> 
  UEFI: LENOVO v: R0UET76W (1.56 ) date: 11/05/2019 
Battery:
  ID-1: BAT0 charge: 28.4 Wh condition: 40.5/45.0 Wh (90%) 
  model: LGC 01AV445 status: Discharging 
CPU:
  Topology: Quad Core model: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen L2 cache: 2048 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 31949 
  Speed: 1583 MHz min/max: 1600/2000 MHz Core speeds (MHz): 1: 2131 2: 2280 
  3: 2089 4: 2060 5: 1513 6: 1485 7: 1459 8: 1489 
Graphics:
  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] 
  vendor: Lenovo driver: amdgpu v: kernel bus ID: 05:00.0 
  Display: x11 server: X.Org 1.20.7 driver: amdgpu 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: AMD RAVEN (DRM 3.35.0 5.4.15-2-MANJARO LLVM 9.0.1) 
  v: 4.5 Mesa 19.3.2 direct render: Yes 
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 05:00.1 
  Device-2: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 05:00.6 
  Sound Server: ALSA v: k5.4.15-2-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8169 v: kernel port: 2000 bus ID: 02:00.0 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel port: 2000 
  bus ID: 04:00.0 
  IF: wlp4s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 704.24 GiB used: 70.88 GiB (10.1%) 
  ID-1: /dev/nvme0n1 vendor: Lenovo model: LENSE30256GMSP34MEAT3TA 
  size: 238.47 GiB 
  ID-2: /dev/sda vendor: Western Digital model: WDS500G2B0A-00SM50 
  size: 465.76 GiB 
Partition:
  ID-1: / size: 123.50 GiB used: 70.86 GiB (57.4%) fs: ext4 dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 55.4 C mobo: 0.0 C gpu: amdgpu temp: 55 C 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 252 Uptime: 6m Memory: 15.33 GiB used: 2.46 GiB (16.0%) 
  Init: systemd Compilers: gcc: 9.2.0 Shell: zsh v: 5.7.1 inxi: 3.0.37 

Yep, same here with the same APU. I've tried several things, but none of them worked reliably. What has worked the best is unplugging my Logitech Unifying Receiver for my MX Anywhere 2S mouse before closing the lid.

Maybe it’s better to have it hibernate instead of suspend. Does anyone have a good tutorial on how to set this up? I’ve seen some that requires messing with grub. Which looks scary :upside_down_face:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by