Thinkpad stalls before boot splash screen if PSU is plugged in

Hi all,

I am new to Manjaro and am experiencing the issue, that my Thinkpad L390 Yoga (Windows 10 Dual Boot) stalls at bootup (even after cold booting after shutting down Manjaro) before the splash screen if the power supply (USB-C) is plugged in. When that happens the fans are running at maximum and the screen is shut off.
If the power supply is not plugged in there are no issues booting. If I plug the power supply in after the splash screen there are no issues as well.
When running Windows and rebooting (or cold booting after shutting down Windows) the issue does not present itself at all.

So far I have tried the following:

  • checked settings in UEFI and Windows: Fast Boot = disabled, Secure Boot = disabled, CSM = disabled
  • updated firmware to latest
  • updated Manjaro packages
  • upgraded kernel from 5.4.28-1 to 5.5.13-1

Sadly to no avail.

system:

inxi -Fxxxza --no-host
System:    Kernel: 5.5.13-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.5-x86_64 root=UUID=1cbaeb68-2530-4023-aa15-77150eafd221 rw quiet 
           udev.log_priority=3 
           Desktop: KDE Plasma 5.18.3 tk: Qt 5.14.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Convertible System: LENOVO product: 20NT0011GE v: ThinkPad L390 Yoga serial: <filter> Chassis: type: 31 
           serial: <filter> 
           Mobo: LENOVO model: 20NT0011GE v: SDK0J40697 WIN serial: <filter> UEFI: LENOVO v: R10ET44W (1.29 ) date: 03/03/2020 
Battery:   ID-1: BAT0 charge: 44.9 Wh condition: 44.9/45.0 Wh (100%) volts: 12.5/11.1 model: LGC 01AV481 type: Li-poly 
           serial: <filter> status: Unknown cycles: 3 
CPU:       Topology: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 8E (142) 
           stepping: C (12) microcode: CA L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28808 
           Speed: 800 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 801 8: 800 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3ea0 
           Display: x11 server: X.Org 1.20.7 driver: intel unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11 
           tty: N/A 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics (Whiskey Lake 3x8 GT2) v: 4.6 Mesa 19.3.5 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Cannon Point-LP High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:9dc8 
           Sound Server: ALSA v: k5.5.13-1-MANJARO 
Network:   Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi v: kernel port: 2000 bus ID: 00:14.3 
           chip ID: 8086:9df0 
           IF: wlp0s20f3 state: up mac: <filter> 
           Device-2: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: 3.2.6-k port: efa0 bus ID: 00:1f.6 
           chip ID: 8086:15be 
           IF: enp0s31f6 state: down mac: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 19.95 GiB (8.4%) 
           ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKKF256G8L size: 238.47 GiB block size: physical: 512 B logical: 512 B 
           speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: L11P scheme: GPT 
Partition: ID-1: / raw size: 117.19 GiB size: 114.85 GiB (98.00%) used: 19.92 GiB (17.3%) fs: ext4 dev: /dev/nvme0n1p5 
Sensors:   System Temperatures: cpu: 49.0 C mobo: 1.0 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 230 Uptime: 14m Memory: 7.53 GiB used: 1.41 GiB (18.7%) Init: systemd v: 244 Compilers: gcc: 9.3.0 
           Shell: bash v: 5.0.16 running in: yakuake inxi: 3.0.37 

journalctl shows some errors from the previous boot attempts, but I am not sure if they are related:

journalctl -b0 | grep Suspend
Mär 28 17:00:55 Laptop-Gereon kded5[666]: kscreen.kded: PowerDevil SuspendSession action not available!
journalctl -p2 -b0
-- Logs begin at Sat 2020-03-28 12:35:50 CET, end at Sat 2020-03-28 17:04:43 CET. --
Mär 28 17:00:22 Laptop-Gereon kernel: Disabling IRQ #31
journalctl -p2 -b1
-- Logs begin at Sat 2020-03-28 12:35:50 CET, end at Sat 2020-03-28 17:04:43 CET. --
Mär 28 16:08:04 Laptop-Gereon kernel: Disabling IRQ #31
Mär 28 16:58:37 Laptop-Gereon kernel: watchdog: watchdog0: watchdog did not stop!

Any help would be much appreciated!

Have you tried any different kernels yet? High on my list would be the 5.6 RC7 (future LTS) and the 4.19 LTS...

mhwd-kernel --install linux56
mhwd-kernel --install linux419

Then reboot and choose one after the other in grub and report back, please?

:innocent:

I tried both of your suggestions, but Manjaro was not the cause after all! After I downgraded the BIOS from Version 1.29 to 1.13 the system finally boots Manjaro.

Thanks anyway! :slight_smile:

I can't figure out this should impact boot while on AC power - but I'll mention it either way. Did you disable Windows powersaving (sleep/hybrid sleep) functionality?

If downgrading your firmware works - there is something wrong.

I suspect the culprit to be tlp. Disable tlp.service and tlp-sleep.service.

I deactivated hybrid sleep, but not sleep before the installation of Manjaro (I was following your Dual-Boot tutorial). tlp.service and tlp-sleep.service are now disabled.

Thanks for your advice!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by