Timeshift Laufwerkseigenheit

Hallo und wieder habe ich eine Frage an die Spezialisten.
Ich habe für mich wieder eine Eigenheit beobachtet bei der ich nicht ganz durchblicke
Ich wunderte mich und kam eigentlich nur durch Zufall darauf das Timeshift mein Backup Laufwerk ab der Initialisierung einfach vom Desktop und aus Thunar verschwinden lässt obwohl es noch und ein-gehangen ist. Es ist auch über die Konsole /run/media/xxxx nicht vorhanden.
Witziger weise wird es über GPartet angezeigt und als EINGEHÄNGT ausgewiesen.
Timeshift funktioniert weiterhin und schriebt auf die Platte und beendet den Sync ohne Probleme..
Nach einem Neustart des Rechners taucht die Partition wieder auf und ist warum auch immer wie alle anderen SSDs und HDs bis auf die Systemplatte NICHT eingehängt?? und ändert sich erst wenn ich das Laufwerk das erste mal aktiviere. OK mag Konfiguratiosabhängig sein, ich bins von MAC OS anders gewohnt..

Im Betrieb lässt sich das verschwundene Laufwerk nur mittels GPartet zurück hohlen, indem ich es darüber aushängen lasse..

ICh mache vermutlich Linux-typische Anfängerfehler und dennoch möchte ich es einfach verstehen.

LG MK

Hallo motiongroup,
ich habe keine Lösung, nur Verständnisprobleme :frowning:

Den Desktop lasse ich mal weg, da zeige ich keine Laufwerke an. Aber Thunar schon. Ist das richtig, daß dein Backup-LW in Thunar gar nicht angezeigt wird? Oder verstehe ich das falsch?
Mein Problem dabei ist, daß es meinem Thunar egal ist, ob das LW gemountet ist oder nicht, er zeigt es auch ungemountet an, mit der Möglichkeit, es einzuhängen.


viele Grüße gosia

lassen wir den Desktop weg und bleiben bei thunar

beim Systemstart werden die Laufwerke als nicht eingehängt angezeigt und ab dem ersten anklicken eingehängt.

so und nun zu Timeshift...

starte ich Timeshift ohne vorher in thunar das Laufwerk eingehängt habe, verwindet es von Thunar und auch vom Desktop

es bleibt verschwunden bis zum Neustart des Rechners oder ich hänge es mit gpartet aus und schon ist es wieder da :roll_eyes:

nicht aber wenn ich das Laufwerk mittels Thunar schon mal eingesehen hatte.. da bleibt es vorhanden und verschwindet nicht..

Hallo motiongroup,

Ok, so sieht es bei mir auch aus.

hm, hier wird es etwas paradox oder schwierig. Ich habe mein Backup-Medium LBACK nie vorher selbst gemountet, einfach weil das timeshift schon für mich erledigt. Wäre ja auch blöd wenn das nicht automatisch passieren würde, da timeshift in der Regel ja im Hintergrund abläuft.
Aber eigentlich sollte das egal sein. Ich habe mal beide Varianten nachgespielt und nie verschwindet LBACK aus Thunar. Wüsste auch nicht warum es verschwinden sollte, weil IMHO immer alle LW (eingehängt oder nicht) in Thunar erscheinen.
Zur Sicherheit: Wir reden aber von einem per USB verbundenen LW? Und es steht auch nicht in der fstab?
Jedenfalls fällt mir partout nicht ein, warum das LW verschwinden sollte, es sei denn ich ziehe den USB-Stecker.
Tut mir leid, vielleicht hat jemand anders eine Idee zu dem Problem.

viele Grüße gosia

nein es ist kein Usb Laufwerk sondern eine sata hd mit 1TB

ich poste nachher wie sich die Platten darstellen und wie sich das verhält wenn ich TS starte..

voll krass das ganze..

so melde mich zurück und habe zwei screenshots davon gemacht..
1
vor dem Ausführen von TS

2
nach dem Ausführen von TS bekommt den mountpoint /run/media/root/LinuxBackup und verschwindet von Thunar und dem Desktop. :roll_eyes:

ich hoffe man kann dabei was erkennen

Hallo motiongroup,

naja, geht so. Beim nächsten Mal solche Textausgaben bitte auch als Text hier posten, liest sich besser.
Bin jetzt zu müde, aber das hat wohl was mit den Rechten zu tun.
/run/media/root/LinuxBackup ist ja normal, weil timeshift mit root-Rechten läuft und Du als normaler User hast keine Zugriffsrechte auf dieses Verzeichnis. Sowas in diese Richtung. Da frage ich mich aber eher, wieso ich das Verzeichnis in Thunar sehe, da muss ich morgen noch mehr experimentieren.

viele Grüße gosia

1 Like

Ja wie schon gosia gesagt hat, kommt das dadurch, dass Timeshift unter dem Root User läuft (wie es ja auch soll). Dies stellt aber technisch kein Problem dar, außer dass du die Festplatte nicht mehr sehen kannst unter deinem normalen User. Sollte das für dich nicht akzeptabel sein, kann man das unterbinden.
Die effektivste Methode das verhalten dauerhaft zu unterbinden ist, die Festplatte per fstab Eintrag schon bei Systemstart einbinden zu lassen.

Dafür müssen wir aber erstmal die UUID der Festplatte herausfinden, dies kannst du ganz einfach mit dem command

sudo lsblk -no UUID /dev/sdd1

herausfinden, solange die Festplatte eingebunden ist.
Diese UUID fügst du hier ganz einfach nach dem UUID= ein.

UUID=xxxxxxx-xxxx-xxxx-xxxxxxxxxx /run/media/martin/LinuxBackup ext4 defaults,noatime 0 0

Diese Zeile musst du nur noch an das Ende der Datei

/etc/fstab

einfügen und ab dem nächsten Neustart wird die Festplatte solange vorhanden immer eingebunden.
Wie du dies tuen kannst hattest du ja bereits beim deaktivieren des Autologins gelernt.
Aber der Vollständigkeit halber verlinke ich das hier nochmal.
Sudoedit Autologin

Referenz: https://wiki.manjaro.org/index.php?title=Fstab

2 Likes

Vielen Dank für die Rückantwort Takei.
Da ich ja mit Linux am Anfang stehe bin ich mit den Eigenheiten nicht so vertraut und habe mir die NAcht um die Ohren geschlagen was genau bei mir so zusammen kommt.
Ausgangspunkt war ein Hackintosh dessen Laufwerke APFS formatiert waren in dem Schema

SSD1 Clover EFI Clover/OSX APFS
SSD2 NTFS EFI/Windows
HD1 Daten1 APFS
HD2 Daten2 APFS

danach hatte ich eine HD2 Platt gemacht und in FAT32 Formatiert und alle Daten darauf geschrieben.
danach die SSD1 Platt gemacht und Manjaro darauf installiert.
danach hatte ich die Platten ext4 Formatiert und nach und nach die Daten zurück gespielt

Da liegt auch die Besonderheit wie ich herauslesen konnte das bei der Installation NUR ext4 Platten automatisch in die etc/fstab eingetragen werden.

nun erklärt sich auch warum die Platten nicht gemountet sind .

ich habe nun versucht die Einträge zu komplettieren und bin satt auf die Nase gefallen..
System war nicht mehr bootfähig und ging in die service console
Ich habe die FSTAB wieder hergestellt und suche nun die Fehler kann aber nicht wirklich einen finden

das ist die /etc/fstab wie ich sie geändert hatte...

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=9E74-AD8C                            /boot/efi      vfat    umask=0077 0 2
UUID=cbc53eae-cc9e-4600-95a9-2a6aac09d18a /              ext4    defaults,noatime,discard 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
# selbst eingebunden /dev/sdb1
UIID=518378df-ee27-43c2-8a59-9e03d9f24405 	/run/media/martin/Linuxdata ext4 defaults,noatime 0 0
# selbst eingebunden /dev/sdc1
UIID=f575c86f-4e54-4449-872b-3d76e3ee9374	/run/media/martin/Linuxdata2 ext4 defaults,noatime 0 0 
# selbst eingebunden /dev/sdd1
UIID=5306d687-e73b-40bc-a22e-6afb558df17d	/run/media/martin/LinuxBackup ext4 defaults,noatime 0 0

findet ihr da einen Fehler??

VG

Ich würde dir empfehlen nicht diesen Pfad zu verwenden. Dieser Ordner ist eigentlich nur für temporär eingebundene Partitionen gedacht, die nicht über den normalen mount Befehl eingehängt werden. Auch ist es möglich das es den Ordner bei System start noch gar nicht gibt.

Grundsätzlich könntest du auch Ordner in dem Home Verzeichnis verwenden. Wenn du aber auch möchtest das die Partitionen auf deinem "Desktop" angezeigt werden ist /media/ ein guter Ort.

Es kann sein das es den /media Ordner auf deinem System noch gar nicht gibt. Du müsstest dann den Ordner erstellen. Und natürlich alle Unterordner die du als mount Punkte verwenden willst.

sudo mkdir /media
sudo mkdir /media/Linuxdata /media/Linuxdata2 /media/LinuxBackup

Du musst nicht neu starten um die neue fstab zu testen. Führe einfach

sudo mount -a 

aus. Stelle sicher das die Partitionen nicht gemountet sind bevor du sudo mount -a ausführst.
Die Befehle

lsblk 

und

mount 

sollten anzeigen ob und wohin die Platten gemountet sind.

1 Like

Vielen Dank für die Rückantwort, die Ordner hat es gegeben und ich habe auch nochmals Deinen Weg über andere Verzeichnisse gewählt

sudo mkdir /media/Linuxdata /media/Linuxdata2 /media/LinuxBackup

sie Tauchen als Symbol auf am Desktop sofort nach speichern der fstab, lassen sich aber mit sudo mount -a nicht einhängen

die Pfade sind auch in der FSTAB korrigiert und die Platten sind nicht gemountet..

habe das ganze dann nochmals über /home/martin/media getestet

same procedure miss sofie..

was ich nicht verstehe, kann man Thunar nicht zwingen die Laufwerke in /run/media/martinmit automount zu belegen irgendwie strange das ganze

ich bin schon am überlegen das Teil nochmals komplett aufzusetzen da ich eh noch am Anfang stehe..

so ich muss mal mit dem Hund raus..

vieln Dank in jedem Fall für die Unterstützung

Das hört sich aber sehr komisch an. Wenn ein Symbol auf dem Desktop auftaucht, ist irgendwas gemountet. Wie testes du den ob das was gemountet wurde?

mount

ist der einzig wirklich aussagekräftige Befehl um zu sehen wo irgendwas hin gemountet wurde.

Naja, du müsstest schon mount -a ausführen und das klappt auch nur wenn nicht die Platten nicht schon irgendwo anders hin gemountet wurde.

Nein. Dieses auf Thunar klicken ist ein ganz besonders Weg um Dateisystem zu mounten. Ursprünglich populär geworden um USB-Sticks zu mounten. Das fundamentale Prinzip von diesem Weg ist, dass es temporär ist.

Wenn du eine Partition immer an den gleichen Platz mounten willst musst du einen fstab Eintrag erstellen oder ein systemd mount service schreiben.

Du solltest erstmal sicherstellen das keine von diesen Partitionen gemountet ist. Und dann erstmal per Hand versuchen.

sudo mount /dev/disk/by-uuid/518378df-ee27-43c2-8a59-9e03d9f24405 /media/Linuxdata

Ohne irgendwelche Optionen, einfach so. Hier solltest du keine weiteren Meldungen angezeigt bekommen. Wenn da irgendwas steht gibt es ein Problem.

Dann mount ausführen und suche nach dem Eintrag für /media/Linuxdata suchen.

1 Like

alles klar Danke für die Info..
ich mache mich gleich nochmals daran

so bin wieder zurück, hat nicht funktioniert

[martin@martin-pc Schreibtisch]$ sudo blkid -o list -w /dev/null
device                             fs_type      label         mount point                            UUID
-----------------------------------------------------------------------------------------------------------------------------------------
/dev/sdb1                          ext4         Linuxdata     (nicht eingehängt)                    518378df-ee27-43c2-8a59-9e03d9f24405
/dev/sdc1                          ext4         Linuxdata2    (nicht eingehängt)                    f575c86f-4e54-4449-872b-3d76e3ee9374
/dev/sda1                          vfat                       /boot/efi                              9E74-AD8C
/dev/sda2                          ext4                       /                                      cbc53eae-cc9e-4600-95a9-2a6aac09d18a
/dev/sdd1                          ext4         LinuxBackup   (nicht eingehängt)                    5306d687-e73b-40bc-a22e-6afb558df17d
[martin@martin-pc Schreibtisch]$ sudo mount -a
mount: /home/martin/media/Linuxdata: Spezialgerät UIID=518378df-ee27-43c2-8a59-9e03d9f24405 ist nicht vorhanden.
mount: /home/martin/media/Linuxdata2: Spezialgerät UIID=f575c86f-4e54-4449-872b-3d76e3ee9374 ist nicht vorhanden.
mount: /home/martin/media/LinuxBackup: Spezialgerät UIID=5306d687-e73b-40bc-a22e-6afb558df17d ist nicht vorhanden.
[martin@martin-pc Schreibtisch]$ 

die etc/fstab dazu

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=9E74-AD8C                            /boot/efi      vfat    umask=0077 0 2
UUID=cbc53eae-cc9e-4600-95a9-2a6aac09d18a /              ext4    defaults,noatime,discard 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
# selbst eingebunden /dev/sdb1
UIID=518378df-ee27-43c2-8a59-9e03d9f24405 	/home/martin/media/Linuxdata ext4 defaults,noatime 0 0
# selbst eingebunden /dev/sdc1
UIID=f575c86f-4e54-4449-872b-3d76e3ee9374	/home/martin/media/Linuxdata2 ext4 defaults,noatime 0 0 
# selbst eingebunden /dev/sdd1
UIID=5306d687-e73b-40bc-a22e-6afb558df17d	/home/martin/media/LinuxBackup ext4 defaults,noatime 0 0

keine Ahnung warum?

Es ist eine UUID und nicht eine UIID. Ist mir aber auch jetzt erst aufgefallen.

1 Like

Jup. Das scheint mir nach dem überfliegen des Threads der Hauptfehler zu sein.

1 Like

Alter Schwede ich stelle mich mal in die Ecke und geh weinen... vielen Dank... das wars...

möchte mich wirklich entschuldigen und gelobe in Zukunft genauer aufzupassen.

Hallo motiongroup,
nach diesem mit vereinten Kräften bewerkstelligten guten Abschluss noch mein sehr subjektiver Vorschlag:
Wenn es sich bei dem Laufwerk tatsächlich nur um ein reines Backup-LW für timeshift handelt, würde ich es gar nicht mounten, weder mit fstab, noch mit Thunar und auch nicht per mount.
Einfach aus dem Grund, je weniger ein LW gemountet ist, um so weniger kann passieren.
Gilt natürlich nur für reines Timeshift-LW. Wenn Du da noch andere Daten zwischenlagerst, z.B. Musik, na dann ist es was anderes.

viele Grüße gosia

1 Like

Is doch kein Problem. :smiley:
Ich hoffe du weißt dass du je nachdem bei diversen Programmen die Pfade neu einrichten musst (steam, timeshift etc.) , da du die einbindungsposition geändert hast, nicht dass du dich wunderst.
Bitte vergiss nicht eine Lösung zu markieren für den Thread und den Threadtitel mit (Gelöst) zu erweitern.
Dies hilft anderen in Zukunft das Problem schneller zu lösen.

1 Like

da habt ihr vollkommen Recht, kommt noch dazu das Thunar ab dem Zeitpunkt der Einträge die Laufwerke doppelt anzeigt ebenso der Desktop..
Also alles wieder Retour und da auf der LinuxBackup eh nur Backups liegen die Administriert werden ist es auch egal ob dieser sichtbar ist... ein Sicherheitsfeature im Falle die Demenz richtig zu schlägt.. :wink:

Wie gesagt alles Neuland für mich.. OSX verwöhnt eben..

Forum kindly sponsored by