TL-WN722N (v2) USB receiver losing signal from WR840N wireless router

Hello. I'm new to Manjaro and I ran into an issue I just cound't figure out by browsing forums.

I'm connecting to a TP-Link TL-WR840N wireless router with a TL-WN722N (v2) USB receiver (rtl8188eus chipset). So far I had no issues whatsoever (on Windows 10).

I installed Manjaro a few days ago and started setting up my work environment, but now I'm losing the wifi signal every other minute or so, which cripples my Internet access.

I was first suspecting the USB receiver driver to be the culprit, but then I tried connecting to a HUAWEI LTE mobile router, and apparently, I have no stability issues with that. So I started to suspect the router, but on my other devices, I don't have that signal problems with my TP-Link router.

So I stand clueless. How to troubleshoot this issue? As far as I remember, the system was working properly until maybe 2 days ago, maybe I was installing things that broke it? I can list the things I installed if that helps. Any help is appreciated. Thanks.

Router setup and troubleshooting tips:

Reboot both your router and computer before you do anything.

Ensure your router firmware is up to date.

Consider resetting your router back to the factory default settings.

Try assigning your computer a static IP address via MAC address association through your router configuration settings.

Disable IPv6 connections in your router and in Network Manager (set to ignore).

Do not make your connection hidden.


Disable MAC Address Randomization in NetworkManager.

Enter this command in the terminal to automatically generate the required conf file:

echo -e "[device]\nwifi.scan-rand-mac-address=no" | sudo tee /etc/NetworkManager/conf.d/disable-random-mac.conf

Please post:

inxi -Fxxxz

Unless there is no alternative, do not post terminal output as a pic.

Please post all terminal command output as text with code tags.

Information on how to properly post hardware specs and logs:

Please format any terminal output with three backticks before and after, as shown in this picture:

Did you install this driver from the AUR and headers.


First install the linuxXXX-headers:

Install the linux-headers for the currently running kernel before the driver.

Use the command below:

sudo pacman -S linux$(uname -r| grep -o -E '[0-9]+' | head -n 2 | sed 'N;s/\n//')-headers

This adapter only work OOB with Linux when adapter is having v.1x firmware.

The AUR driver may solve your issue.

@tbg I admire your extraction of the kernel version

1 Like

Thank you. Coming from you that is a great compliment.

Thanks for the responses so far. Here's my system info:

➜  ~ inxi -Fxxxz
  Host: hitbol-pc Kernel: 5.0.1-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Cinnamon 4.0.9 dm: LightDM 1.28.0 Distro: Manjaro Linux 
  Type: Desktop Mobo: ASUSTeK model: PRIME A320M-K v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 4027 date: 11/04/2018 
  Device-1: hidpp_battery_0 model: Logitech K520 serial: <filter> 
  charge: 70% (should be ignored) rechargeable: yes status: Discharging 
  Topology: Quad Core model: AMD Ryzen 3 2200G with Radeon Vega Graphics 
  bits: 64 type: MCP arch: Zen L2 cache: 2048 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 27959 
  Speed: 1509 MHz min/max: 1600/3500 MHz boost: enabled Core speeds (MHz): 
  1: 1444 2: 1419 3: 1420 4: 1414 
  Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] vendor: Micro-Star MSI 
  driver: nvidia v: 418.43 bus ID: 01:00.0 chip ID: 10de:1c02 
  Device-2: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] 
  vendor: ASUSTeK driver: N/A bus ID: 08:00.0 chip ID: 1002:15dd 
  Display: x11 server: X.Org 1.20.4 driver: nvidia 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 1060 3GB/PCIe/SSE2 v: 4.6.0 NVIDIA 418.43 
  direct render: Yes 
  Device-1: NVIDIA GP106 High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f1 
  Device-2: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 08:00.1 chip ID: 1002:15de 
  Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 08:00.6 chip ID: 1022:15e3 
  Device-4: Logitech HD Webcam C525 type: USB driver: snd-usb-audio,uvcvideo 
  bus ID: 1-6:2 chip ID: 046d:0826 serial: <filter> 
  Device-5: Focusrite-Novation type: USB driver: snd-usb-audio bus ID: 3-4:3 
  chip ID: 1235:8205 
  Sound Server: ALSA v: k5.0.1-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8168 v: 8.045.08-NAPI port: e000 bus ID: 06:00.0 
  chip ID: 10ec:8168 
  IF: enp6s0 state: down mac: <filter> 
  Device-2: TP-Link TL-WN722N v2 type: USB driver: r8188eu bus ID: 3-3:2 
  chip ID: 2357:010c serial: <filter> 
  IF: wlp8s0f3u3 state: up mac: <filter> 
  Local Storage: total: 238.47 GiB used: 93.61 GiB (39.3%) 
  ID-1: /dev/sda vendor: Samsung model: SSD PM871a M.2 2280 256GB SED 
  size: 238.47 GiB speed: 6.0 Gb/s serial: <filter> rev: 2D6Q scheme: GPT 
  ID-1: / size: 173.59 GiB used: 90.04 GiB (51.9%) fs: ext4 dev: /dev/sda7 
  ID-2: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6 
  System Temperatures: cpu: 41.4 C mobo: N/A gpu: nvidia temp: 52 C 
  Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 0% 
  Processes: 250 Uptime: 1m Memory: 6.80 GiB used: 2.37 GiB (34.9%) 
  Init: systemd v: 241 Compilers: gcc: 8.2.1 Shell: zsh v: 5.7.1 
  running in: gnome-terminal inxi: 3.0.32 

I've tried installing the dkms package from the AUR before I asked the question on the forum, and I also figured out I had to install headers first. But the device simply stops working on reboot, it doesn't even show up with inxi and the module is not loaded automatically (doesn't show in lsmod). I can load the 8188eu module with modprobe but nothing happens, I still cannot interact with the device.

(I'm still very noob with terminal commands, so please bear with me :blush: )

Just to let you know, I did all I could on the router's part (firmware update, positioning, IPv6 off etc.) and to no avail. Maybe it's the USB receiver, but then it puzzles me why I still get a perfect connection with my mobile wifi router...

Did you try changing your routers encryption type and QOS settings.Did you test all the suggested fixes in my tutorial.

Do you have a blacklist file in /etc/modprobe.d folder?

The kernel module should be blacklisted when installing the dkms driver but something could have failed.

Are you sure you are on the correct driver? And @tbg is a lot more proficient in this trouble shooting than I am!

Yes that blacklist is not automatically created sometimes.

Try this:

sudo modprobe -r r8188eu 
sudo modprobe r8188eu swenc=1

If your connection is no better after those commands then reinstall the dkms drivers from the AUR.

After the driver and headers are installed then issue this command to create a blacklist for the kernel module in /etc/modprobe.d:

echo 'blacklist 8188eu' | sudo tee /etc/modprobe.d/8188eu-blacklist.conf


I already had the recommended encryption set which has been working on all my devices so far, including linux desktops (laptops). QOS, as far as I understand is a load regulator/balancer, but my issues had nothing to do with load, they persisted with a simple no-load connection (e.g. just pinging).

Tried that. Now I don't have any wireless devices.

I have a blacklist.conf file for

  • 8188eu
  • r8188eu (without blacklist)
  • r8169
    All these files contain a single line with blacklist modulename

[update] I checked the receiver dongle on my laptop with another linux (Linux Mint 19.1) and the problem is the same as in Manjaro. The onboard wifi of my laptop has no issue with my network. So that confirms that the problem lies with the r8188eu module.

I'm sure you probably know this, but you can't have both 8188eu and r8188eu blacklisted at the same time. It's a one or the other kind of situation depending on which driver you're attempting to use.

Also put your IPv6 settings back to "allow" if they gave no improvement.

Have you tried any other live boot disks to see if they work with your adapter. Compare the modules and settings they are using if another distro works better. Perhaps try this Lxqt spin, as it uses connman instead of Network Manager. That will at least tell you if that's where your issue is coming from.

Test a live image of Manjarowish-LXQT-Kwin-Edition:

Sorry, but I'm not sure what else to tell you other than perhaps try another router (if you can get one) on your home service to see if it's the same situation.

I will try that in the weekend, thanks. FYI, I successfully installed an 8188eu kernel module which was recently built (not for Manjaro specifically). It was operating the same way as the prebuilt r8188eu, meaning it drops the signal regularly.

If your signal is dropping this could possibly be because of power saving features. Try changing your driver options.

If you are using the kernel module create this file:

blacklist r8188eu
options 8188eu rtw_power_mgnt=0 rtw_enusbss=0

Reboot after making those changes. Be sure to disable those options or delete that file if you switch to another driver from the AUR.


That is most likely the case, as I have absolutely no issues with the same setup in Win10.

I'm testing the solution. So far, so good. I'll come back to you after some days and confirm if it works consistently.

1 Like

Please be sure to give us an update on how those options worked out for you. I can't remember recommending that combination of options before. It would be nice to know if they were a big improvement, so I'll know to recommend that in the future.

Alright, here are the results so far:

  1. The compiled module seemed to be working with the settings until the next kernel update, when it vanished (of course) :upside_down_face:
  2. The 8188eu-dkms package in the AUR doesn't work at all.
  3. I tested the 8188eu-dkms-git package from the AUR for a long time, and it seemed to work, but I recently noticed some glitches every now and then (like 2-4 within an hour)
  4. I have just tested lwfinger's module from github - upon which no. 3 is based -, but obviously, it gives me the same results: pretty stable, but not quite perfect.
  5. Right now I'm testing quickreflex's module from github. I'll report on it soon.

I maintain a kernel package for 8723bu module.

It also uses the driver from lwfinger and to have that one working - one have to disable concurrent mode in the makefile.

I have no means of testing it but it might be worth a try.

NetworkManager can sometimes disrupt connectivity with a too aggressive power saving setting.

You can prevent this by creating a new Network Manager configuration file:

Create a default-wifi-powersave-on.conf file:

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Add the following contents to the conf file:

wifi.powersave = 0

A setting of "0" will totally disable power saving features in the WiFi adapter.

A setting of "2" or "1" will be less aggressive, but still leave powersaving enabled.

Also try the option:

options 8188eu rtw_power_mgnt=0 

minus the "rtw_enusbss=0" option.

Forum kindly sponsored by