[TLP] 2017-12-14 - Call for testing: new TLP defaults

Introduction

I've pushed a new version for TLP to unstable (tlp=1.0-1.4). This changes several default settings for TLP. These need testing to make sure they don't have any unseen side-effects (though I've been running these myself for the last few months on three systems without issue).

You will have to merge or replace /etc/default/tlp with the new settings if you have made any changes to that file - check for a /etc/default/tlp.pacnew.

You'll also either have to reboot or reload and restart TLP (systemctl daemon-reload; systemctl restart tlp) for the changes to take effect.

Please test as best you can (e.g. check powertop output before and after) and feed back. Please post if you find any changes or you have any issues; please also include your hardware details where relevant.

If you can't see the update yet it will be mirrors - you can download directly from e.g.

Changes

SATA_LINKPWR_ON_BAT=min_power => max_performance

Be conservative with SATA ALPM to prevent poor SSD performance and potential data corruption. Makes little or no difference under normal use (web browsing etc.); you will notice higher power use if you leave a laptop idling for long periods on battery.

1.0-1: min_power
1.0-1.1: medium_power
1.0-1.3: max_performance
1.0-1.4: max_performance

RADEON_POWER_PROFILE_ON_AC=high => default

Use hardware defaults for open-source AMD drivers. This allows demand-based power scaling and can vastly reduce heat generation.

1.0-1: high
1.0-1.1: default
1.0-1.3: default
1.0-1.4: default

SOUND_POWER_SAVE_ON_AC=0 => 1

Enable audio power saving on AC power. We don't need to run things constantly at full power. Reverted because pops are annoying.

1.0-1: 0
1.0-1.1: 1
1.0-1.3: 0
1.0-1.4: 0

#### RUNTIME_PM_ON_AC=on => auto
Enable runtime power management for PCI(e) on AC power. We don't need to run things constantly at full power. Reverted due to issues on desktop systems.

1.0-1: on
1.0-1.1: auto
1.0-1.3: auto
1.0-1.4: on

USB_AUTOSUSPEND=1 => 0

Disable aggressive USB device autosuspend. This prevents "hidden" issues with USB hardware that is incompatible.

Note: this may increase power usage - it remains to be seen what effect it will have. However, IMHO better compatibility with devices (and fewer random issues) makes it better as a default.

1.0-1: 1
1.0-1.1: 0
1.0-1.3: 0
1.0-1.4: 0

Development thread with more detail

Previous default settings "call for testing"


Any issues or annoyances?

  • No obvious issues
  • I have an issue (post)

0 voters

Any effect on power draw?

  • No obvious effect on power draw
  • Power draw is reduced
  • Power draw is increased

0 voters

Any effect on heat generation?

  • No obvious change to heat
  • Heat output is reduced
  • Heat output is increased

0 voters

Any effect on system performance?

  • No obvious change to performance
  • Performance is increased
  • Performance is reduced

0 voters

Any effect on hardware functionality?

  • No obvious changes to hardware
  • Hardware works that didn't before
  • Hardware no longer works

0 voters

2 Likes

Previous thread for reference:

am getting invalid signature for tlp-draw package which is signed by you right?

Yes, the package is signed by me. Weird that you're getting an invalid signature... have you retried the download?

yes few times and i get the same thing everytime
i had to excelude the two packages in order to complete the update

This is definitely a "works for me" thing so maybe your keyrings needs updating/refreshing... ?

Reading the announcement thread,

noone else has mentioned this so I don't think there's any problem with the package itself.

I also have this issue!

I get the following error:

error: tlp-rdw: signature from "Jonathon Fernyhough jonathon@manjaro.org" is invalid
:: File /var/cache/pacman/pkg/tlp-rdw-1.0-1.2-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

I had to remove (I should have exclude it of course) that package to be able to update all the other packages. Now I can't re-install it.
I have updated/refreshed my keyrings and tried everything mentioned in "Issues with “signature is marginal trust” or “invalid or corrupted package” -thread but no avail.

Hmm... apparently the tlp-rdw package doesn't verify, but tlp is fine. Interesting.

Rebuild incoming.


Edit: rebuild done and pushed. Please verify:

gpg --recv-key 76C6E477042BFE985CC220BD9C08A255442FAFF0
wget https://mirror.netzspielplatz.de/manjaro/packages/unstable/community/x86_64/tlp-rdw-1.0-1.3-any.pkg.tar.xz
wget https://mirror.netzspielplatz.de/manjaro/packages/unstable/community/x86_64/tlp-rdw-1.0-1.3-any.pkg.tar.xz.sig
gpg --verify tlp-rdw-1.0-1.3-any.pkg.tar.xz.sig

If this works, not sure what hapened with the previous version...


1.0-1.3 installs fine for me (no key errors). Please check.

1 Like

@xircon You voted heat output increased: what are you running, and how much extra heat is there?

Core i5 - idle at 47 now 50 ish.

System:    Host: steve-pc Kernel: 4.15.0-1-MANJARO x86_64 bits: 64 gcc: 7.2.1 Desktop: N/A Distro: Manjaro Linux
Machine:   Device: laptop System: Notebook product: W65_67SZ serial: N/A
           Mobo: Notebook model: W65_67SZ serial: N/A BIOS: American Megatrends v: 1.03.05 date: 02/26/2014
Battery    BAT0: charge: 46.6 Wh 100.0% condition: 46.6/48.8 Wh (95%) model: Notebook BAT status: Full
CPU:       Dual core Intel Core i5-4310M (-MT-MCP-) arch: Haswell rev.3 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10779
           clock speeds: max: 3400 MHz 1: 3292 MHz 2: 3382 MHz 3: 3292 MHz 4: 3368 MHz
Graphics:  Card: Intel 4th Gen Core Processor Integrated Graphics Controller bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.5 ) driver: modesetting Resolution: 1600x900@60.01hz
           OpenGL: renderer: Mesa DRI Intel Haswell Mobile version: 4.5 Mesa 17.3.0 Direct Render: Yes
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-1-MANJARO
Network:   Card-1: Intel Wireless 7260 driver: iwlwifi bus-ID: 04:00.0
           IF: wlp4s0 state: up mac: 48:51:b7:bb:7a:33
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 05:00.2
           IF: enp5s0f2 state: down mac: 80:fa:5b:03:32:0f
Drives:    HDD Total Size: 2000.4GB (40.6% used)
           ID-1: /dev/sda model: ST2000LM003_HN size: 2000.4GB
Partition: ID-1: / size: 1.8T used: 746G (44%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 9.45GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
           ID-3: swap-2 size: 0.41GB used: 0.00GB (0%) fs: swap dev: /dev/zram0
           ID-4: swap-3 size: 0.41GB used: 0.00GB (0%) fs: swap dev: /dev/zram1
           ID-5: swap-4 size: 0.41GB used: 0.00GB (0%) fs: swap dev: /dev/zram2
           ID-6: swap-5 size: 0.41GB used: 0.00GB (0%) fs: swap dev: /dev/zram3
Sensors:   System Temperatures: cpu: 58.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 191 Uptime: 12:42 Memory: 2771.6/7904.9MB Init: systemd Gcc sys: 7.2.1
           Client: Shell (zsh 5.4.2) inxi: 2.3.53

The two changes from 1.0-1.1 are SATA_LINKPWR_ON_BAT=power_medium => max_performance and SOUND_POWER_SAVE_ON_AC=1 => 0

Could you check whether these are influencing your idle temp?

Will do but not tonight :smiley: What are the options you want me to try? Off to bed, work tomorrow.

1 Like

Pffft ... amateur... also, work on a Saturday? :sob:

Just a case of checking the two settings to see if either are responsible, or if its possibly kernel-related instead. No rush though. :wink:

NHS 24/7 365 - so just remark them out? (long day)

1 Like

Actually, if you're running on AC the only one that can influence temp should be SOUND_POWER_SAVE_ON_AC...

So, switch SOUND_POWER_SAVE_ON_AC from 0 to 1 and restart TLP.

But, not tonight. I work with an ex-(mental health nurse), and several of my friends are medics; sleep is way more important than this Manjaro rubbish.

Got it! Been screamed and shouted at for 8 hours in Italian :exploding_head: Sorry for being thick tonight. (I work in Mental Health & EMI).

Yep. Installed and working just fine.
Thanks jonathon!

yeah it upgrades fine now thanks!!

I'm sorry if this reply is the wrong place,but since I just created an account it seems I cannot reply to the post located here.

https://archived.forum.manjaro.org/t/tlp-2017-12-14-call-for-testing-new-tlp-defaults/36420/17

I installed the tlp-1.0-1.3 package to fix an audio popping sound I was having after updating to the tlp-1.0-1.1. Well it fixed the audio problem,but killed my network connection. I went into pacman cache and reinstalled the old tlp-1.0-1 and everythings back to normal for me.

If you need some more information from me just let me know,and again sorry if this is in the wrong spot.

Assuming you're running on AC power and not battery, the only settings that would have had any effect would have been

SOUND_POWER_SAVE_ON_AC=0 => 1
RUNTIME_PM_ON_AC=on => auto

The first was reverted (no more pops), and the second hasn't changed between 1.0-1.1 and 1.0-1.3, so if your network was fine with 1.0-1.1 this can't be the cause...

Could you post the output of inxi -Fxxxz ?

Forum kindly sponsored by