TLP config file question mark

,

I am using a Thinkpad running KDE and using TLP. I've noticed a decrease in battery life over the last few weeks. I thought I would refer to the TLP config file. In dolphin the file icon is represented by a question mark and I am unable to open the file.

Does anyone know why this might be? Thanks.

tlp

you need to open it in root, since reading is also protected.
Cheers,

Thanks. I tried 'Root Actions > Open as text' but nothing happens when I input my password.

Got it. Seleted 'Open With > Gedit' and managed to open the file. Apologies for extreme noobiness!

EDIT: I don't understand why I can't open this file with Kate but I can with Gedit.

Didn't you have to enter your password?
Can you run ls -l /etc/default/tlp ?

1 Like

This was the result:

-rw------- 1 root root 11315 Nov 10 12:16 /etc/default/tlp

So the file is not readable by the normal user, so Dolphin and Kate are behaving as they should (although one can wonder why this file is not readable for a normal user).
Didn't you enter your password to read it with Gedit? Otherwise it shouldn't work...

It asks for my password when I try and open this file in either Kate or Gedit.

However, It will only let me open the file in Gedit. In Kate nothing happens. It's not a big deal and I'm probably worrying unduly. But just seems strange.

By default, Kate is not allowed root or superuser privileges in Arch and most Arch-based distributions. Kate is a normal QT application intended to be used in KDE Plasma, whereas Gedit is the default text editor in GNOME.

regards

how to read and modify (if necessary but read the notes in the file) the tlp config, open terminal (Konsole or Yakuake) and type:

sudo nano /etc/default/tlp

1 Like

Thanks all - that really clears it up :+1:

I don't think this is normal. Mine is readable, by group.
I guess you are in group wheel?

It should be

-rw-r--r--

or is it a new setting of tlp?

Seems to be the new set up, it is the same on my computer (gnome edition).

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by