TLP persists on the same power mode (AC or BAT) that was on startup

I have been messing with the peristent parameters in TLPUI and now even after I reverted it back to the defaults, tlp is not working properly.

I changed the parameters back to the defaults:
TLP_DEFAULT_MODE=AC
TLP_PERSISTENT_DEFAULT=0

It also shows up correctly when I use tlp-stat

For some reason the power state now is persisting on the same state as it is in bootup or wake from suspend. If I boot with the AC plugged in, it claims it is always charging. And in reverse I boot in bat it claims it is discharging.

Right now I have it claim it is on battery mode discharging with the AC plugged in and the power with the power increasing from being charged. It is persisting even with a reinstallation of the tlp packages.

How do I revert TLP back to the manjaro stock it came with, and how should I be configuring it to get battery lifetime?

uninstall tlp, remove the tlp config file and reinstall

Did no effect. The problem persisted even with tlp uninstalled.

was this problem there before you installed tlp or was it caused by tlp and you cant get it to revert to how it was before installing?

I belive i had tlp installed before hand and have had it running in the background for a while. The problem only maniested after I tinkered with those two settings. Perhaps more arguements got saved along with it.

While trying to fix I put in the command
sudo pacman -S --needed tlp tlp-rdw iw smartmontools ethtool x86_energy_perf_policy
Perhaps one of the dependencies did something else as well.

I am currently not using the uefi boot right now, just the old fasioned boot in my bios.

did you modify anything with this?

did you remove /etc/default/tlp after uninstall? if not then uninstall tlp and delete /etc/default/tlp .
also uninstall x86_energy_perf_policy while your at it and restart, see if you still have the same issues.

then if it works out, you can reinstall tlp , change power mode, restart and see if the same problems come back.

why did you install x86_energy_perf_policy?

also if you could post the output of tlp-stat

I removed the /etc/default/tlp and uninstalled tlp along with all the related packages.

I restarted and reinstalled tlp and it still has not corrected itself.

Here is the tlp output.

--- TLP 1.1 --------------------------------------------

+++ Configured Settings: /etc/default/tlp
TLP_ENABLE=1
TLP_DEFAULT_MODE=AC
TLP_PERSISTENT_DEFAULT=0
DISK_IDLE_SECS_ON_AC=0
DISK_IDLE_SECS_ON_BAT=2
MAX_LOST_WORK_SECS_ON_AC=15
MAX_LOST_WORK_SECS_ON_BAT=60
CPU_HWP_ON_AC=balance_performance
CPU_HWP_ON_BAT=balance_power
SCHED_POWERSAVE_ON_AC=0
SCHED_POWERSAVE_ON_BAT=1
NMI_WATCHDOG=0
ENERGY_PERF_POLICY_ON_AC=performance
ENERGY_PERF_POLICY_ON_BAT=power
DISK_DEVICES="sda sdb"
DISK_APM_LEVEL_ON_AC="254 254"
DISK_APM_LEVEL_ON_BAT="128 128"
SATA_LINKPWR_ON_AC="med_power_with_dipm max_performance"
SATA_LINKPWR_ON_BAT="med_power_with_dipm max_performance"
AHCI_RUNTIME_PM_TIMEOUT=15
PCIE_ASPM_ON_AC=performance
PCIE_ASPM_ON_BAT=powersave
RADEON_POWER_PROFILE_ON_AC=default
RADEON_POWER_PROFILE_ON_BAT=low
RADEON_DPM_STATE_ON_AC=performance
RADEON_DPM_STATE_ON_BAT=battery
RADEON_DPM_PERF_LEVEL_ON_AC=auto
RADEON_DPM_PERF_LEVEL_ON_BAT=auto
WIFI_PWR_ON_AC=off
WIFI_PWR_ON_BAT=on
WOL_DISABLE=Y
SOUND_POWER_SAVE_ON_AC=0
SOUND_POWER_SAVE_ON_BAT=1
SOUND_POWER_SAVE_CONTROLLER=Y
BAY_POWEROFF_ON_AC=0
BAY_POWEROFF_ON_BAT=0
BAY_DEVICE="sr0"
RUNTIME_PM_ON_AC=on
RUNTIME_PM_ON_BAT=auto
RUNTIME_PM_DRIVER_BLACKLIST="amdgpu nouveau nvidia radeon pcieport"
USB_AUTOSUSPEND=0
USB_BLACKLIST_BTUSB=0
USB_BLACKLIST_PHONE=0
USB_BLACKLIST_PRINTER=1
USB_BLACKLIST_WWAN=1
RESTORE_DEVICE_STATE_ON_STARTUP=0

+++ System Info
System         = Acer V1.06 Switch SA5-271P
BIOS           = V1.06
Release        = "Manjaro Linux"
Kernel         = 4.19.2-1-MANJARO #1 SMP PREEMPT Tue Nov 13 22:35:25 UTC 2018 x86_64
/proc/cmdline  = BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64 root=UUID=d8cc9112-7b2a-4377-b51c-12efde9f623f rw quiet resume=UUID=f5729ad3-1d7a-460a-9b0a-e04c019eaf21
Init system    = systemd 
Boot mode      = BIOS (CSM, Legacy)

+++ TLP Status
State          = enabled
Last run       = 09:04:19 PM,    119 sec(s) ago
Mode           = AC
Power source   = AC

+++ Processor
CPU model      = Intel(R) Core(TM) i5-6200U CPU @ 2.30GHz

/sys/devices/system/cpu/cpu0/cpufreq/scaling_driver    = intel_pstate
/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor  = powersave
/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors = performance powersave
/sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq  =   400000 [kHz]
/sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq  =  2800000 [kHz]
/sys/devices/system/cpu/cpu0/cpufreq/energy_performance_preference = balance_performance
/sys/devices/system/cpu/cpu0/cpufreq/energy_performance_available_preferences = default performance balance_performance balance_power power 

/sys/devices/system/cpu/cpu1/cpufreq/scaling_driver    = intel_pstate
/sys/devices/system/cpu/cpu1/cpufreq/scaling_governor  = powersave
/sys/devices/system/cpu/cpu1/cpufreq/scaling_available_governors = performance powersave
/sys/devices/system/cpu/cpu1/cpufreq/scaling_min_freq  =   400000 [kHz]
/sys/devices/system/cpu/cpu1/cpufreq/scaling_max_freq  =  2800000 [kHz]
/sys/devices/system/cpu/cpu1/cpufreq/energy_performance_preference = balance_performance
/sys/devices/system/cpu/cpu1/cpufreq/energy_performance_available_preferences = default performance balance_performance balance_power power 

/sys/devices/system/cpu/cpu2/cpufreq/scaling_driver    = intel_pstate
/sys/devices/system/cpu/cpu2/cpufreq/scaling_governor  = powersave
/sys/devices/system/cpu/cpu2/cpufreq/scaling_available_governors = performance powersave
/sys/devices/system/cpu/cpu2/cpufreq/scaling_min_freq  =   400000 [kHz]
/sys/devices/system/cpu/cpu2/cpufreq/scaling_max_freq  =  2800000 [kHz]
/sys/devices/system/cpu/cpu2/cpufreq/energy_performance_preference = balance_performance
/sys/devices/system/cpu/cpu2/cpufreq/energy_performance_available_preferences = default performance balance_performance balance_power power 

/sys/devices/system/cpu/cpu3/cpufreq/scaling_driver    = intel_pstate
/sys/devices/system/cpu/cpu3/cpufreq/scaling_governor  = powersave
/sys/devices/system/cpu/cpu3/cpufreq/scaling_available_governors = performance powersave
/sys/devices/system/cpu/cpu3/cpufreq/scaling_min_freq  =   400000 [kHz]
/sys/devices/system/cpu/cpu3/cpufreq/scaling_max_freq  =  2800000 [kHz]
/sys/devices/system/cpu/cpu3/cpufreq/energy_performance_preference = balance_performance
/sys/devices/system/cpu/cpu3/cpufreq/energy_performance_available_preferences = default performance balance_performance balance_power power 

/sys/devices/system/cpu/intel_pstate/min_perf_pct      =  14 [%]
/sys/devices/system/cpu/intel_pstate/max_perf_pct      = 100 [%]
/sys/devices/system/cpu/intel_pstate/no_turbo          =   0
/sys/devices/system/cpu/intel_pstate/turbo_pct         =  21 [%]
/sys/devices/system/cpu/intel_pstate/num_pstates       =  25

x86_energy_perf_policy: program not installed.

/sys/module/workqueue/parameters/power_efficient       = Y
/proc/sys/kernel/nmi_watchdog                          = 0

+++ Undervolting
PHC kernel not available.

+++ Temperatures
CPU temp               =    40 [°C]
Fan speed              = (not available)

+++ File System
/proc/sys/vm/laptop_mode               =     0
/proc/sys/vm/dirty_writeback_centisecs =  1500
/proc/sys/vm/dirty_expire_centisecs    =  1500
/proc/sys/vm/dirty_ratio               =    20
/proc/sys/vm/dirty_background_ratio    =    10

+++ Storage Devices
/dev/sda:
  Model     = KINGSTON RBU-SNS8152S3256GG2            
  Firmware  = SAFM01.R
  APM Level = 254
  Status    = active/idle
  TRIM      = supported
  Scheduler = cfq

  Runtime PM: control = on, autosuspend_delay =   -1

  SMART info:
      5 Reallocated_Sector_Ct     =        0 
      9 Power_On_Hours            =       90 [h]
     12 Power_Cycle_Count         =      296 
    194 Temperature_Celsius       =       30 (Min/Max 24/65)  [°C]
    231 Temperature_Celsius       =      100    [°C]
    233 Media_Wearout_Indicator   =      100 [%]
    241 Total_LBAs_Written        =    0.000 [TB]


+++ AHCI Link Power Management (ALPM)
/sys/class/scsi_host/host0/link_power_management_policy  = med_power_with_dipm
/sys/class/scsi_host/host1/link_power_management_policy  = med_power_with_dipm
/sys/class/scsi_host/host2/link_power_management_policy  = med_power_with_dipm

+++ AHCI Host Controller Runtime Power Management
/sys/bus/pci/devices/0000:00:17.0/ata1/power/control = on
/sys/bus/pci/devices/0000:00:17.0/ata2/power/control = on
/sys/bus/pci/devices/0000:00:17.0/ata3/power/control = on

+++ PCIe Active State Power Management
/sys/module/pcie_aspm/parameters/policy = default (using bios preferences)

+++ Intel Graphics
/sys/module/i915/parameters/enable_dc        = -1 (use per-chip default)
/sys/module/i915/parameters/enable_fbc       =  1 (enabled)
/sys/module/i915/parameters/enable_psr       = -1 (use per-chip default)
/sys/module/i915/parameters/modeset          = -1 (use per-chip default)

+++ Wireless
bluetooth = on
wifi      = on
wwan      = none (no device)

hci0(btusb)                   : bluetooth, not connected
wlp1s0(ath10k_pci)            : wifi, connected, power management = off

+++ Audio
/sys/module/snd_hda_intel/parameters/power_save            = 0
/sys/module/snd_hda_intel/parameters/power_save_controller = N

+++ Runtime Power Management
Device blacklist = (not configured)
Driver blacklist = amdgpu nouveau nvidia radeon pcieport

/sys/bus/pci/devices/0000:00:00.0/power/control = on   (0x060000, Host bridge, skl_uncore)
/sys/bus/pci/devices/0000:00:02.0/power/control = on   (0x030000, VGA compatible controller, i915)
/sys/bus/pci/devices/0000:00:04.0/power/control = on   (0x118000, Signal processing controller, proc_thermal)
/sys/bus/pci/devices/0000:00:05.0/power/control = on   (0x048000, Multimedia controller, no driver)
/sys/bus/pci/devices/0000:00:13.0/power/control = on   (0x000000, Non-VGA unclassified device, intel_ish_ipc)
/sys/bus/pci/devices/0000:00:14.0/power/control = on   (0x0c0330, USB controller, xhci_hcd)
/sys/bus/pci/devices/0000:00:14.2/power/control = on   (0x118000, Signal processing controller, intel_pch_thermal)
/sys/bus/pci/devices/0000:00:14.3/power/control = on   (0x048000, Multimedia controller, no driver)
/sys/bus/pci/devices/0000:00:15.0/power/control = on   (0x118000, Signal processing controller, intel-lpss)
/sys/bus/pci/devices/0000:00:15.1/power/control = on   (0x118000, Signal processing controller, intel-lpss)
/sys/bus/pci/devices/0000:00:15.2/power/control = on   (0x118000, Signal processing controller, intel-lpss)
/sys/bus/pci/devices/0000:00:16.0/power/control = on   (0x078000, Communication controller, mei_me)
/sys/bus/pci/devices/0000:00:17.0/power/control = on   (0x010601, SATA controller, ahci)
/sys/bus/pci/devices/0000:00:1d.0/power/control = auto (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:1f.0/power/control = on   (0x060100, ISA bridge, no driver)
/sys/bus/pci/devices/0000:00:1f.2/power/control = on   (0x058000, Memory controller, no driver)
/sys/bus/pci/devices/0000:00:1f.3/power/control = on   (0x040300, Audio device, snd_hda_intel)
/sys/bus/pci/devices/0000:00:1f.4/power/control = on   (0x0c0500, SMBus, i801_smbus)
/sys/bus/pci/devices/0000:01:00.0/power/control = on   (0x028000, Network controller, ath10k_pci)

+++ USB
Autosuspend         = disabled
Device whitelist    = (not configured)
Device blacklist    = (not configured)
Bluetooth blacklist = disabled
Phone blacklist     = disabled
WWAN blacklist      = enabled

Bus 002 Device 001 ID 1d6b:0003 control = auto, autosuspend_delay_ms =     0 -- Linux Foundation 3.0 root hub (hub)
Bus 001 Device 005 ID 0bda:0129 control = auto, autosuspend_delay_ms =  2000 -- Realtek Semiconductor Corp. RTS5129 Card Reader Controller (rtsx_usb)
Bus 001 Device 004 ID 0bda:56c1 control = auto, autosuspend_delay_ms =  2000 -- Realtek Semiconductor Corp.  (uvcvideo)
Bus 001 Device 003 ID 04ca:3016 control = auto, autosuspend_delay_ms =  2000 -- Lite-On Technology Corp.  (btusb)
Bus 001 Device 002 ID 04f2:1558 control = on,   autosuspend_delay_ms =  2000 -- Chicony Electronics Co., Ltd  (usbhid)
Bus 001 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =     0 -- Linux Foundation 2.0 root hub (hub)

+++ Battery Status
/sys/class/power_supply/BAT0/manufacturer                   = OEM
/sys/class/power_supply/BAT0/model_name                     = AP16B4J
/sys/class/power_supply/BAT0/cycle_count                    = (not supported)
/sys/class/power_supply/BAT0/charge_full_design             =   4870 [mAh]
/sys/class/power_supply/BAT0/charge_full                    =   4600 [mAh]
/sys/class/power_supply/BAT0/charge_now                     =   3138 [mAh]
/sys/class/power_supply/BAT0/current_now                    =   2209 [mA]
/sys/class/power_supply/BAT0/status                         = Charging

Charge                                                      =   68.2 [%]
Capacity                                                    =   94.5 [%]

Honestly, I may just do a fresh install after backing up my files.

Well... the glitch survived a system wipe.

well, on the bright side of things, you can narrow down your search for the issue to your home folder :grin:

i know you uninstalled, removed config and then reinstalled. did you see if it behaves the same without TLP all together and reboot?

if same continues then TLP is probably not your issue.

did you check for this behavior before you restored your backed up home folder?

The only files I recovered are ~/Documents ~/Pictures and .vimrc

does it happen when TLP is uninstalled and reboot?

Yes. I hope that I have not broke something. The power circutry seems to be charging and discharging correctly, for some reason manjaro isn't recognizing the event when it changes power.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by