Today's update killed wifi and sound (XPS13 9300)

Today there was a huge update, which I installed.
After a reboot the wifi module is not working anymore. So I have to write this on my mobile...

I work on a Dell XPS13 9300. It has a Killer Wi-Fi 6 AX1650i.

Kernel module iwlwifi is loaded.
Connections are still configured, though not shown on the Applet.

Device is wlp0s20f3. On ip link set dev wlp0s20f3 up it says "cannot find device".

I need wifi to work! It worked until the update...

Any help or ideas are highly appreciated!

can you add kernel 5.4
and reboot with Grub ( press Esc or Shift )
and select kernel5.4

sudo mhwd-kernel -i linux54

Can't downgrade. No network.
I am on 5.6 and it previously worked fine with that.

I even downgraded the linux-firmware.

Great that you created a thread i n the appropriate section, but you should of also reported this is the update thread for your branch.

I found the thread you mentioned. But obviously I am not allowed to post there.
image

I doubt, it makes sense to block users from that thread :wink:

I just noticed that not only the wifi is dead but also the sound.
That update killed wifi and sound... there is only a dummy for playback left...

What the hell happened... :pensive:

Running Manjaro for a year now, coming from arch, because that was too unstable... and now this huge boom :woozy_face:

Managed to get some network from my smartphone by Bluetooth...
So I am running 5.4LTS now.
Nothing changed. No sound, no wifi. :frowning:

And a flickering line (1-2 pixels) at the top of the screen. Flickers once or twice a second.

Man, that update was a huge downer... I need to actually work. Don't really want to change distribution...

can you returns

inxi -Fxxxza

have you also
kernels5*-headers installed , and version linux-firmware

sudo pacman -Qi linux-firmware
1 Like

Currently running newest kernel and firmware again. Playing around the whole day instead of working... nice.

inxi -Fxxxza

System:    Host: jwe Kernel: 5.7.9-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 root=UUID=fee7cebb-62e0-49e9-b175-14923f78e09b rw quiet 
           udev.log_priority=3 
           Desktop: Cinnamon 4.6.6 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: XPS 13 9300 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Dell model: 077Y9N v: A00 serial: <filter> UEFI: Dell v: 1.0.11 date: 05/08/2020 
Battery:   ID-1: BAT0 charge: 47.4 Wh condition: 47.4/51.0 Wh (93%) volts: 8.5/7.6 model: BYD DELL FP86V02 type: Li-poly 
           serial: <filter> status: Full 
CPU:       Topology: Quad Core model: Intel Core i7-1065G7 bits: 64 type: MT MCP arch: Ice Lake family: 6 model-id: 7E (126) 
           stepping: 5 microcode: 78 L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23968 
           Speed: 1000 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 987 2: 1000 3: 1000 4: 1000 5: 1000 6: 1001 7: 1000 
           8: 1000 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Iris Plus Graphics G7 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:8a52 
           Display: x11 server: X.Org 1.20.8 driver: modesetting alternate: fbdev,intel,vesa tty: N/A 
           OpenGL: renderer: Mesa Intel Iris Plus Graphics (ICL GT2) v: 4.6 Mesa 20.1.3 direct render: Yes 
Audio:     Device-1: Intel Smart Sound Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:34c8 
           Sound Server: ALSA v: k5.7.9-1-MANJARO 
Network:   Device-1: Intel Killer Wi-Fi 6 AX1650i 160MHz Wireless Network Adapter vendor: Bigfoot Networks driver: iwlwifi 
           v: kernel port: 4000 bus ID: 00:14.3 chip ID: 8086:34f0 
           IF-ID-1: bnep0 state: unknown speed: N/A duplex: N/A mac: <filter> 
           IF-ID-2: br-706d6083b3e5 state: up speed: 10000 Mbps duplex: unknown mac: <filter> 
           IF-ID-3: docker0 state: down mac: <filter> 
           IF-ID-4: veth027e7f0 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-5: veth05b0955 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-6: veth07c0d69 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-7: veth09827f9 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-8: veth11bf13e state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-9: veth1c0d8a9 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-10: veth1d36ab4 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-11: veth1eaeebd state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-12: veth20f9526 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-13: veth244b7ef state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-14: veth24dab5a state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-15: veth29aeeef state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-16: veth341f795 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-17: veth429d4e2 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-18: veth465aaa9 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-19: veth4661ce5 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-20: veth49322ca state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-21: veth4c48e0a state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-22: veth4d98829 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-23: veth4ddf1d0 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-24: veth552d798 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-25: veth5d452ef state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-26: veth6e91c4c state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-27: veth73004d9 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-28: veth770e338 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-29: veth7751005 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-30: veth7de4507 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-31: veth7fb7be5 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-32: veth7fd10fc state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-33: veth8418d98 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-34: veth857a3af state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-35: veth88b6a8f state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-36: veth89a390f state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-37: veth93601c7 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-38: veth9b02b0b state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-39: vethb07d88a state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-40: vethb6a1b61 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-41: vethbb14190 state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-42: vethc20e37d state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-43: vethce45c9a state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-44: vethf507c8f state: up speed: 10000 Mbps duplex: full mac: <filter> 
           IF-ID-45: vethf65b260 state: up speed: 10000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 105.61 GiB (22.1%) 
           ID-1: /dev/nvme0n1 vendor: SK Hynix model: PC611 NVMe 512GB size: 476.94 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 11000111 scheme: GPT 
Partition: ID-1: / raw size: 97.66 GiB size: 95.62 GiB (97.92%) used: 36.10 GiB (37.8%) fs: ext4 dev: /dev/nvme0n1p3 
           ID-2: /home raw size: 363.56 GiB size: 356.85 GiB (98.16%) used: 69.50 GiB (19.5%) fs: ext4 dev: /dev/dm-0 
           ID-3: swap-1 size: 15.62 GiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default) cache pressure: 100 (default) 
           dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 52.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 506 Uptime: 1m Memory: 15.23 GiB used: 2.31 GiB (15.2%) Init: systemd v: 245 Compilers: gcc: 10.1.0 
           Shell: bash v: 5.0.18 running in: gnome-terminal inxi: 3.0.37

sudo pacman -Qi linux-firmware

Name            : linux-firmware
Version         : 20200716.r1675.1d1c80b-1
Description     : Firmware files for Linux (Manjaro Overlay Package)
Architecture    : any
URL             : https://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git;a=summary
Licenses        : GPL2  GPL3  custom
Groups          : None
Provides        : None
Depends On      : None
Optional Deps   : None
Required By     : linux54  linux56  linux57
Optional For    : None
Conflicts With  : linux-firmware-git  kernel26-firmware  ar9170-fw  iwlwifi-1000-ucode  iwlwifi-3945-ucode  iwlwifi-4965-ucode  iwlwifi-5000-ucode  iwlwifi-5150-ucode  iwlwifi-6000-ucode  rt2870usb-fw  rt2x00-rt61-fw
                  rt2x00-rt71w-fw
Replaces        : kernel26-firmware  ar9170-fw  iwlwifi-1000-ucode  iwlwifi-3945-ucode  iwlwifi-4965-ucode  iwlwifi-5000-ucode  iwlwifi-5150-ucode  iwlwifi-6000-ucode  rt2870usb-fw  rt2x00-rt61-fw  rt2x00-rt71w-fw
Installed Size  : 558,56 MiB
Packager        : Helmut Stult <helmut@manjaro.org>
Build Date      : Do 16 Jul 2020 18:47:35 CEST
Install Date    : Mo 20 Jul 2020 15:24:52 CEST
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

Just installed the headers for 54, 56 and 57. They weren't isntalled yet...

Not sure but could this have something to do with networkmanager if that got updated. If so could downgrading resolve the issue at least for the moment?

There seems to had not been any update to that. I also thought it could be nm.
But sound is also broken...

1 Like

I also had no luck at all reverting like here.
Sound and Wifi stays broken.

Only solution seems to be to install a different distribution :frowning:

Use Timeshift auto snap for machines like xps 13, faced similar issue on xps 13 9343 just restored my image, everythings fine now

1 Like

I will in the future. Too late for now...
I relied on the "stable" and recommendation of colleagues :wink:

I can't speak to the stable update, but, My roommates machine lost the network shortly after the last testing update. We were both on the 5.8 kernel. I rolled him back to the 5.7 and all is good. Now as for sound he lost his bluetooth speakers, but his phone worked fine. Had him switch to a old set of speakers that aren't bluetooth and removed the bluetooth altogether since transferring files to the phone is faster via USB anyway, and that's all he needed the bluetooth for.

that's some aggressive fix..xD

For now I tried kernel versions 54, 56, 57 and the previous linux-firmware.

Nothing helps. Sound and wifi stay broken. Really annoying. Couldn't work the whole day because Manjaro totally messed up my machine today :weary:

It was just a quick workaround till the next kernel update for testing. That more than likely will address both issues. I just did not feel like spending half a day trying to figure out what got broken. Then if it doesn't correct the issues I can yell for help.

@DasJott and you don't have a snapshot at all you can rollback to? For now I'd use whichever kernel you prefer, install timeshift-autosnap, then try getting one of the two issues resolved first then move on to the second issue.

I rolled back to the last LTS Kernel, even though it perfectly worked with newer versions before.
I also rolled back linux-firmware.

But Manjaro still has no sound and no wifi. The worst update that could have ever happend. Why is that one called stable?
I seem to have to setup my system completely to another distribution in order to be able to work again. This would be day 2 where Manjaro keeps me from working... Can not do that, even though I always loved and recommended Manjaro.

I don't know, what to try anymore. This is so messed up...

these changes comes from Kernel Stable , not from Manjaro

1 Like

Forum kindly sponsored by