Touchpad broken on HP envy x360

First some details about my setup, Manjaro kde running on hp envy x360 ryzen 4500 15 in. kernel 5.7.9-1

My touch pad doesn't work at all, in system settings under input devices it detects the touchpad but its grayed out, and doesn't work at all. Not sure if drivers is the right category, but i thought there might be some drivers missing for my processor. (I'm a bit of a newbie). If anyone can help me that it would be much appreciated! :slight_smile:

Do you see the touchpad if you run sudo evtest? And if you select it, do you see events appear as you touch the touchpad?

sudo evtest shows up as command not found, maybe you spelled it wrong?

Then install it: sudo pacman -Syu evtest.

just installed it with the software installer, events show up when i select it but when i scroll or click nothing shows up.

Can you attach the output of sudo dmesg | egrep -i "(input|hid)"

it says new images cant post photos so heres an imgur link https://imgur.com/xgmIhfz

not sure if i was supposed to replace "(input|hid)" with somthing else... thanks for your help btw

Empty... I guess you rebooted long ago? Anyways, can you attach the output of ls -l /sys/bus/i2c/devices/?

yeah i reboot pretty often, heres the ouput photo https://imgur.com/a/U7lUy2G

Do you have a touchscreen or two touchpads or anything like that?

my laptop has a touchscreen, and i have a mouse connected.
should i rerun the command without the mouse connected?

Does the touchscreen work?

And please run sudo libinput debug-events and see if it shows anything when you try to use the touchpad. If you see any errors, warnings appear, please include those in your reply.

I ran the command a couple times and the touchpad worked in none of them, scrolling around on the touchpad does not show up on the screen at all and i dont see any errors. https://imgur.com/gCp7TUI the keyboard key you see is the me taking a screenshot

Try the following: sudo rmmod i2c_hid, then sudo dmesg -w, then in a different terminal, run sudo modprobe i2c_hid debug=1, try to use a touchpad a bit, then go back to dmesg, stop it (press Ctrl+C), and then attach the output.

https://imgur.com/a/8o53VK5 heres the output, not sure if i did somthing wrong, in the three images in imgur theres some explanations telling what the images are

also heres the terminal after running sudo rmmod i2c_hid https://imgur.com/a/oFhcUK9

Can you attach the output of lsmod? Have you tried any other kernel beside 5.7? And try running this: echo "on" | sudo tee /sys/bus/i2c/devices/i2c-SYNA3290\:01/power/control and see if the touchpad starts working.

still doesnt work https://imgur.com/a/AvQzJ8N

Can you send the whole output of lsmod? If you run lsmod > out.txt, then everything will be in out.txt and you don't have to take a screenshot.

not sure what out.txt is... heres what happens when i run that command https://imgur.com/a/KWxAu0d

Open your home folder in a file manager, there should be a file named out.txt. Upload that.

Forum kindly sponsored by