Touchpad not working properly in KDE Plasma

Yesterday I installed Manjaro KDE on my laptop and I noticed, that the toucpad isn't working properly. I can do left/right click, but I'm not able to move the mouse cursor or scroll up and down. In the KDE Systemsettings app I can change the options for the touchpad (buttons, sliders, etc.), but the first line at the top where it says "Device: SYNA7DB5:00 06CB:7DB7 Touchpad" is greyed out. Could this be a driver issue? Does anyone how to gett it working properly?

Please provide from terminal:
inxi -Fxxxza --no-host

In principle i think is the same issue as described here
https://bugzilla.kernel.org/show_bug.cgi?id=205745
So, update the system, test with a different kernel too.

This is the output:

System:
  Kernel: 5.7.0-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 
  root=UUID=4162dd6a-20d2-408c-b413-484f213d17c4 rw quiet apparmor=1 
  security=apparmor resume=UUID=20f14307-f739-4ac8-8c8d-d550588d864b 
  udev.log_priority=3 
  Desktop: KDE Plasma 5.18.5 tk: Qt 5.15.0 info: latte-dock wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Acer product: Aspire F5-573G v: V1.12 serial: <filter> 
  Mobo: Acer model: Captain_SK v: V1.12 serial: <filter> UEFI: Insyde v: 1.12 
  date: 08/02/2016 
CPU:
  Topology: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP 
  arch: Amber Lake family: 6 model-id: 8E (142) stepping: 9 microcode: CA 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21607 
  Speed: 500 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 500 2: 500 3: 500 
  4: 500 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel HD Graphics 620 vendor: Acer Incorporated ALI driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:5916 
  Device-2: NVIDIA GM107 [GeForce 940MX] vendor: Acer Incorporated ALI 
  driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:179c 
  Display: x11 server: X.Org 1.20.8 driver: intel,nouveau unloaded: modesetting 
  alternate: fbdev,nv,vesa compositor: kwin_x11 resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.0.7 
  direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71 
  Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX] 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  chip ID: 10de:0fbc 
  Sound Server: ALSA v: k5.7.0-3-MANJARO 
Network:
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Lite-On driver: ath10k_pci v: kernel port: 4000 bus ID: 03:00.0 
  chip ID: 168c:0042 
  IF: wlp3s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000 
  bus ID: 04:00.1 chip ID: 10ec:8168 
  IF: enp4s0f1 state: down mac: <filter> 
Drives:
  Local Storage: total: 1.03 TiB used: 233.45 GiB (22.2%) 
  ID-1: /dev/sda vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB block size: 
  physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm 
  serial: <filter> rev: 5J scheme: GPT 
  ID-2: /dev/sdb vendor: SK Hynix model: HFS128G39TND-N210A size: 119.24 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: 1P10 scheme: GPT 
Partition:
  ID-1: / raw size: 110.15 GiB size: 107.92 GiB (97.98%) used: 13.33 GiB (12.4%) 
  fs: ext4 dev: /dev/sdb2 
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap 
  swappiness: 60 (default) cache pressure: 100 (default) dev: /dev/sdb3 
Sensors:
  System Temperatures: cpu: 57.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 222 Uptime: 2m Memory: 7.65 GiB used: 1.30 GiB (17.1%) Init: systemd 
  v: 245 Compilers: gcc: 10.1.0 Shell: bash v: 5.0.17 running in: konsole 
  inxi: 3.0.37 

After reading a bit about it, it seems that model has a Synaptics touchpad. It should work with libinput, but maybe not, so try to follow this:
https://wiki.archlinux.org/index.php/Touchpad_Synaptics

So my system is up to date (stable branch), I tried with kernel 5.6 and 5.7. I also installed the xf86-input-synaptics package. Sometimes it works when I boot the system and move cursor right after seeing the it for the first time. But when I stop moving the cursor, it won't move the cursor again and only left and right click are working.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by