Touchpad stops working on battery power

Every time I unplug charging cable from my laptop the touchpad stops reacting to any input. And after plugging power back touchpad starts to work as normal.

Here's inxi output:
$ inxi -Fxz

System:    Host: vivacer-laptop Kernel: 4.19.20-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 
           Desktop: KDE Plasma 5.14.5 Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP Notebook v: Type1ProductConfigId serial: <filter> 
           Mobo: HP model: 81F1 v: 64.29 serial: <filter> UEFI: Insyde v: F.09 date: 05/19/2016 
Battery:   ID-1: BAT1 charge: 37.9 Wh condition: 37.9/41.6 Wh (91%) model: COMPAL PABAS0241231 
           status: Full 
CPU:       Topology: Quad Core model: Intel Pentium N3710 bits: 64 type: MCP arch: Airmont rev: 4 
           L2 cache: 1024 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 12805 
           Speed: 896 MHz min/max: 480/2560 MHz Core speeds (MHz): 1: 896 2: 876 3: 2012 4: 1223 
Graphics:  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics 
           vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.3 driver: intel unloaded: modesetting 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 405 (Braswell) v: 4.5 Mesa 18.3.2 
           direct render: Yes 
Audio:     Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High Definition 
           vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k4.19.20-1-MANJARO 
Network:   Device-1: Broadcom and subsidiaries BCM43142 802.11b/g/n vendor: Hewlett-Packard driver: wl 
           v: kernel port: 2040 bus ID: 02:00.0 
           IF: wlp2s0 state: up mac: <filter> 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169 
           v: kernel port: 1000 bus ID: 03:00.0 
           IF: enp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 119.24 GiB used: 67.66 GiB (56.7%) 
           ID-1: /dev/sda vendor: Samsung model: MZNTY128HDHP-000H1 size: 119.24 GiB 
Partition: ID-1: / size: 107.03 GiB used: 67.61 GiB (63.2%) fs: ext4 dev: /dev/sda5 
           ID-2: /boot size: 755.9 MiB used: 50.9 MiB (6.7%) fs: ext2 dev: /dev/sda2 
           ID-3: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4 
Sensors:   System Temperatures: cpu: 35.0 C mobo: 27.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 177 Uptime: 35m Memory: 3.70 GiB used: 776.4 MiB (20.5%) Init: systemd Compilers: 
           gcc: 8.2.1 clang: 7.0.1 Shell: bash v: 5.0.0 inxi: 3.0.30

And xinput output. The command was run when touchpad wasn't working.
$ xinput list

⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Synaptics TM3127-001                      id=10   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ HP Webcam: HP Webcam                      id=8    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=9    [slave  keyboard (3)]
    ↳ HP Wireless hotkeys                       id=11   [slave  keyboard (3)]
    ↳ HP WMI hotkeys                            id=12   [slave  keyboard (3)]

I apologize for my probably bad english.

Thanks for your help in advance!

you could first try and update your bios. also maybe disable tlp, reboot and see if the behavior is the same, if it fixes it them look through your tlp config

1 Like

I tried disabling tlp service, but it didn't give any results. For some reason only if I start and stop the tlp service touchpad starts functioning again.

I also tried tweaking tlp config file. I disabled autosuspension for all USB devices, but it didn't give any results.

My touchpad is recognized as PS/2 mouse if that would be any help:

46: PS/2 00.0: 10500 PS/2 Mouse
  [Created at input.249]
  Unique ID: AH6Q.rrD3kaQuFt2
  Hardware Class: mouse
  Model: "Synaptics TM3127-001"
  Vendor: 0x06cb 
  Device: "Synaptics TM3127-001"
  Compatible to: int 0x0210 0x0002
  Device File: /dev/input/mice (/dev/input/mouse1)
  Device Files: /dev/input/mice, /dev/input/mouse1, /dev/input/event9
  Device Number: char 13:63 (char 13:33)
  Driver Info #0:
    Buttons: 2
    Wheels: 0
    XFree86 Protocol: explorerps/2
    GPM Protocol: exps2
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Here's my tlp config:

# ------------------------------------------------------------------------------
# tlp - Parameters for power saving
# See full explanation:

# Hint: some features are disabled by default, remove the leading # to enable
# them.

# Set to 0 to disable, 1 to enable TLP.

# Operation mode when no power supply can be detected: AC, BAT.
# Concerns some desktop and embedded hardware only.

# Operation mode select: 0=depend on power source, 1=always use TLP_DEFAULT_MODE
# Hint: use in conjunction with TLP_DEFAULT_MODE=BAT for BAT settings on AC.

# Seconds laptop mode has to wait after the disk goes idle before doing a sync.
# Non-zero value enables, zero disables laptop mode.

# Dirty page values (timeouts in secs).

# Hint: CPU parameters below are disabled by default, remove the leading #
# to enable them, otherwise kernel default values are used.

# Select a CPU frequency scaling governor.
# Intel Core i processor with intel_pstate driver:
#   powersave(*), performance.
# Older hardware with acpi-cpufreq driver:
#   ondemand(*), powersave, performance, conservative, schedutil.
# (*) is recommended.
# Hint: use tlp-stat -p to show the active driver and available governors.
# Important:
#   powersave for intel_pstate and ondemand for acpi-cpufreq are power
#   efficient for *almost all* workloads and therefore kernel and most
#   distributions have chosen them as defaults. If you still want to change,
#   you should know what you're doing! You *must* disable your distribution's
#   governor settings or conflicts will occur.

# Set the min/max frequency available for the scaling governor.
# Possible values strongly depend on your CPU. For available frequencies see
# the output of tlp-stat -p.

# Set energy performance hints (HWP) for Intel P-state governor:
#   performance, balance_performance, default, balance_power, power
# Values are given in order of increasing power saving.
# Note: Intel Skylake or newer CPU and Kernel >= 4.10 required.

# Set Intel P-state performance: 0..100 (%).
# Limit the max/min P-state to control the power dissipation of the CPU.
# Values are stated as a percentage of the available performance.
# Requires an Intel Core i processor with intel_pstate driver.

# Set the CPU "turbo boost" feature: 0=disable, 1=allow
# Requires an Intel Core i processor.
# Important:
# - This may conflict with your distribution's governor settings
# - A value of 1 does *not* activate boosting, it just allows it

# Minimize number of used CPU cores/hyper-threads under light load conditions:
#   0=disable, 1=enable.

# Kernel NMI Watchdog:
#   0=disable (default, saves power), 1=enable (for kernel debugging only).

# Change CPU voltages aka "undervolting" - Kernel with PHC patch required.
# Frequency voltage pairs are written to:
#   /sys/devices/system/cpu/cpu0/cpufreq/phc_controls
# CAUTION: only use this, if you thoroughly understand what you are doing!

# Set CPU performance versus energy savings policy:
#   performance, balance-performance, default, balance-power, power.
# Values are given in order of increasing power saving.
# Requires kernel module msr and x86_energy_perf_policy from linux-tools.

# Disk devices; separate multiple devices with spaces (default: sda).
# Devices can be specified by disk ID also (lookup with: tlp diskid).
DISK_DEVICES="sda sdb"

# Disk advanced power management level: 1..254, 255 (max saving, min, off).
# Levels 1..127 may spin down the disk; 255 allowable on most drives.
# Separate values for multiple disks with spaces. Use the special value 'keep'
# to keep the hardware default for the particular disk.

# Hard disk spin down timeout:
#   0:        spin down disabled
#   1..240:   timeouts from 5s to 20min (in units of 5s)
#   241..251: timeouts from 30min to 5.5 hours (in units of 30min)
# See 'man hdparm' for details.
# Separate values for multiple disks with spaces. Use the special value 'keep'
# to keep the hardware default for the particular disk.

# Select IO scheduler for the disk devices: cfq, deadline, noop (Default: cfq).
# Separate values for multiple disks with spaces. Use the special value 'keep'
# to keep the kernel default scheduler for the particular disk.
#DISK_IOSCHED="cfq cfq"

# AHCI link power management (ALPM) for disk devices:
#   min_power, med_power_with_dipm(*), medium_power, max_performance.
# (*) Kernel >= 4.15 required, then recommended.
# Multiple values separated with spaces are tried sequentially until success.
SATA_LINKPWR_ON_AC="med_power_with_dipm max_performance"
SATA_LINKPWR_ON_BAT="med_power_with_dipm max_performance"

# Exclude host devices from AHCI link power management.
# Separate multiple hosts with spaces.

# Runtime Power Management for AHCI host and disks devices:
#   on=disable, auto=enable.
# EXPERIMENTAL ** WARNING: auto will most likely cause system lockups/data loss.

# Seconds of inactivity before disk is suspended.

# PCI Express Active State Power Management (PCIe ASPM):
#   default, performance, powersave.

# Radeon graphics clock speed (profile method): low, mid, high, auto, default;
# auto = mid on BAT, high on AC; default = use hardware defaults.

# Radeon dynamic power management method (DPM): battery, performance.

# Radeon DPM performance level: auto, low, high; auto is recommended.

# WiFi power saving mode: on=enable, off=disable; not supported by all adapters.

# Disable wake on LAN: Y/N.

# Enable audio power saving for Intel HDA, AC97 devices (timeout in secs).
# A value of 0 disables, >=1 enables power saving (recommended: 1).

# Disable controller too (HDA only): Y/N.

# Power off optical drive in UltraBay/MediaBay: 0=disable, 1=enable.
# Drive can be powered on again by releasing (and reinserting) the eject lever
# or by pressing the disc eject button on newer models.
# Note: an UltraBay/MediaBay hard disk is never powered off.
# Optical drive device to power off (default sr0).

# Runtime Power Management for PCI(e) bus devices: on=disable, auto=enable.

# Exclude PCI(e) device adresses the following list from Runtime PM
# (separate with spaces). Use lspci to get the adresses (1st column).

# Exclude PCI(e) devices assigned to the listed drivers from Runtime PM.
# Default when unconfigured is "amdgpu nouveau nvidia radeon" which
# prevents accidential power-on of dGPU in hybrid graphics setups.
# Use "" to disable the feature completely.
# Separate multiple drivers with spaces.
RUNTIME_PM_DRIVER_BLACKLIST="amdgpu nouveau nvidia radeon pcieport"

# Set to 0 to disable, 1 to enable aggressive USB autosuspend feature.

# Exclude listed devices from USB autosuspend (separate with spaces).
# Use lsusb to get the ids.
# Note: input devices (usbhid) are excluded automatically

# Bluetooth devices are excluded from USB autosuspend:
#   0=do not exclude, 1=exclude.

# Phone devices are excluded from USB autosuspend:
#   0=do not exclude, 1=exclude (enable charging).

# Printers are excluded from USB autosuspend:
#   0=do not exclude, 1=exclude.

# WWAN devices are excluded from USB autosuspend:
#   0=do not exclude, 1=exclude.

# Include listed devices into USB autosuspend even if already excluded
# by the blacklists above (separate with spaces).
# Use lsusb to get the ids.
#USB_WHITELIST="1111:2222 3333:4444"

# Set to 1 to disable autosuspend before shutdown, 0 to do nothing
# (workaround for USB devices that cause shutdown problems).

# Restore radio device state (Bluetooth, WiFi, WWAN) from previous shutdown
# on system startup: 0=disable, 1=enable.
#   are ignored when this is enabled!

# Radio devices to disable on startup: bluetooth, wifi, wwan.
# Separate multiple devices with spaces.
#DEVICES_TO_DISABLE_ON_STARTUP="bluetooth wifi wwan"

# Radio devices to enable on startup: bluetooth, wifi, wwan.
# Separate multiple devices with spaces.

# Radio devices to disable on shutdown: bluetooth, wifi, wwan.
# (workaround for devices that are blocking shutdown).
#DEVICES_TO_DISABLE_ON_SHUTDOWN="bluetooth wifi wwan"

# Radio devices to enable on shutdown: bluetooth, wifi, wwan.
# (to prevent other operating systems from missing radios).

# Radio devices to enable on AC: bluetooth, wifi, wwan.
#DEVICES_TO_ENABLE_ON_AC="bluetooth wifi wwan"

# Radio devices to disable on battery: bluetooth, wifi, wwan.
#DEVICES_TO_DISABLE_ON_BAT="bluetooth wifi wwan"

# Radio devices to disable on battery when not in use (not connected):
#   bluetooth, wifi, wwan.
#DEVICES_TO_DISABLE_ON_BAT_NOT_IN_USE="bluetooth wifi wwan"

# Battery charge thresholds (ThinkPad only, tp-smapi or acpi-call kernel module
# required). Charging starts when the remaining capacity falls below the
# START_CHARGE_THRESH value and stops when exceeding the STOP_CHARGE_THRESH value.
# Main / Internal battery (values in %)
# Ultrabay / Slice / Replaceable battery (values in %)

# Restore charge thresholds when AC is unplugged: 0=disable, 1=enable.

# ------------------------------------------------------------------------------
# tlp-rdw - Parameters for the radio device wizard
# Possible devices: bluetooth, wifi, wwan.

# Hints:
# - Parameters are disabled by default, remove the leading # to enable them
# - Separate multiple radio devices with spaces

# Radio devices to disable on connect.

# Radio devices to enable on disconnect.

# Radio devices to enable/disable when docked.

# Radio devices to enable/disable when undocked.

I'll also try updating BIOS this evening.

Thank you for your help!

you could change this to 1, save/reboot, and see if it behaves differently. since the touchpad starts to work after restarting tlp, i would think a change to tlp's behavior may fix it. so if i understand correctly, your touchpad works fine while plugged into AC but after unplugging from AC it stops working? does the touchpad then start to work again if you plug back in to AC? or does tlp need to be restarted for it to begin working again?


Setting TLP_PERSISTENT_DEFAULT to 1 actually fixed everything!

Yes, this is correct.

Yes, touchpad works again after plugging AC back. No, I meant that on battery touchpad starts working only after I start tlp service and stop it. Simply disabling service wasn't enough so I had to manually start it and then stop it.

Thank you so much for your help!

your welcome, im glad it worked out. just remember that changing that setting will likely effect battery life since it's telling your laptop to run as if its on AC even when its on battery. i have mine set this way anyway because i mainly use AC. but now that you know its related to power saving(tlp), if you cared to you could play a little more with the tlp config and see if you can get it to work even when using a battery and not set to AC. for now i would just see if you notice any battery life shortening and if not, leave it alone. :+1:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by