Touchpad SYNA3602 (0911:5288) not working at all

https://patchwork.kernel.org/patch/10046575/

Anyone could help me understand how to apply this patch? Will it come automatically with 4.15? Or do I have to add the patch and compile it myself?

Hi haphaeu,
I have the same laptop as you (ezbook 3 pro probably v5)
We have the same touchpad and mine works with no problems (well if you suspend the touchpad does not work on login or after reboot and you have to fully shutdown (not just reboot) and login again).

see here about what i did

I just did a simple installation (wiped out windows completely) and used refind.

I had the same fear about the touchpad since the problem is on a lot of forums and it s kernel related, but after I installed 17.1.1 I had no problem right from the beginning.

[dimitrios@dimitrios-laptop ~]$ inxi -Fxxxz
Resuming in non X mode: xrandr not found. For package install advice run: inxi --recommends
System:    Host: dimitrios-laptop Kernel: 4.14.14-1-MANJARO x86_64 bits: 64 gcc: 7.2.1
           Desktop: N/A info: xfce4-panel dm: lightdm Distro: Manjaro Linux
Machine:   Device: laptop System: Jumper product: EZbook serial: N/A
           Mobo: Jumper model: P3132 serial: N/A
           UEFI: American Megatrends v: Jumper10x.P8.WP3132.NHNAUHL01 date: 12/05/2017
Battery    BAT0: charge: 34.1 Wh 71.0% condition: 48.0/48.0 Wh (100%) volts: 7.6
           model: Intel SR 1 SR Real serial: <filter>status: Discharging cycles: 0
CPU:       Quad core Intel Celeron N3450 (-MCP-) arch: N/A cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8756
           clock speeds: min/max: 800/2200 MHz 1: 842 MHz 2: 1604 MHz 3: 1238 MHz 4: 905 MHz
Graphics:  Card: Intel Device 5a85 bus-ID: 00:02.0 chip-ID: 8086:5a85
           Display Server: N/A drivers: intel (unloaded: modesetting) tty size: 152x24
Audio:     Card Intel Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster
           driver: snd_hda_intel bus-ID: 00:0e.0 chip-ID: 8086:5a98
           Sound: Advanced Linux Sound Architecture v: k4.14.14-1-MANJARO
Network:   Card: Intel Wireless 3165 driver: iwlwifi bus-ID: 01:00.0 chip-ID: 8086:3165
           IF: wlp1s0 state: up mac: <filter>
Drives:    HDD Total Size: 120.0GB (17.1% used)
           ID-1: /dev/mmcblk0 model: N/A size: 62.5GB serial: <filter>
           ID-2: /dev/sda model: RD size: 120.0GB serial: <filter>
Partition: ID-1: / size: 24G used: 7.4G (33%) fs: ext4 dev: /dev/mmcblk0p3
           ID-2: /home size: 27G used: 6.1G (24%) fs: ext4 dev: /dev/mmcblk0p4
           ID-3: swap-1 size: 6.29GB used: 0.00GB (0%) fs: swap dev: /dev/mmcblk0p2
Sensors:   System Temperatures: cpu: 29.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 182 Uptime: 20 min Memory: 1484.7/5813.8MB Init: systemd v: 236 Gcc sys: 7.2.1
           Client: Shell (bash 4.4.121 running in xfce4-terminal) inxi: 2.3.56 

Screenshot_2018-01-26_11-39-22

1 Like

Hi DimitriosM,

that is good news and gives me some hope.

I'm keeping the windows ssd untouched and with boot disabled. So I've installed Manjaro in a second ssd and boot directly from it. Just in case I need wiindows, I can switch boot in bios...

But just to make sure, do we really have same device?
SYNA3602:00 0911:5288 Touchpad
Are you using libinput ? Can you please check what this gives to you:

[\raf@talisa ~] $ sudo libinput list-devices | grep -i touch
libinput error: event10 - libinput error: SYNA3602:00 0911:5288 Touchpad: libinput error: kernel bug: clickpad advertising right button
Device:           SYNA3602:00 0911:5288 Touchpad

By the way, did you have problems booting other distros installations? It was sort of a pain for me to boot in this laptop, in the end apparently it doesn't like grub so I have to dig out a distro which uses systemd boot, which manjaro 16 did. More details in here. Did you see any of this?

If this doesn't work, then I'll have to wait until kernel 4.15 becomes released for Manjaro since it corrects the bug. So far I've tried the unstable version but it freezes the system in less than a minute :confused:

If I make any progress I'll sign in and update your post in TechTablets as well!

Cheers

Hi haphaeu,
We have the same touchpad and i use libinput.

[dimitrios@dimitrios-laptop ~]$ sudo libinput list-devices | grep -i touch
[sudo] password for dimitrios:
Device: SYNA3602:00 0911:5288 Touchpad

I haven' t checked any other distros, but a I had numerous problems booting manjaro with windows installed. I installed manjaro on the m.2 but couldntboot it even with rEFInd and under all possible combinations. Windows booted fine. On live usb, touchpad worked great in manjaro 17.1.1
So I became frustrated and decided to delete windows (more so since I use windows like.... never).
After that all things went smooth with me using rEFInd to boot.
As I write in TechTablets, the touchpad worked out of the box.
Other people in TechTablets (Brad) have installed Antergos and I think Ubuntu. But all go with rEFInd to boot it.
I now use:

[dimitrios@dimitrios-laptop ~]$ uname -r
4.14.14-1-MANJARO
and I installed with Manjaro 17.1.1

The only problem with the touch pad is when you suspend. When you start again, the touchpad is dead and if you restart you get a boot error on the touchpad (still dead). You have to shutdown the laptop completely and then boot it again for the touchpad to start working again.
Since I never suspend, I dont care much.
The only thing that troubles me is a bunch of I/O errors at boot, but the laptop works fine. Everything works fine . Even battery time is great.

This is good to know. Thanks for that.

I'll consider getting rid of windows next time. But I'm not willing to reinstall now, since all is working fine except touchpad. I'm not a big fan of touchpads so I keep a small wireless mouse all the time and problem solved. So for now I'll wait on next kernels... and in case something crashes and I need re-install, I'll follow your post and use rEFInd.

kernel 4.15 doesn't solve this, currently testing on my new jumper.

I'm sooo frustrated, i'll have to check the double usb stick trick mentioned above...

Hello!

I'm creating this post because i have tried every solution online, among those there are:
+Usingxf86-synaptics
+Modifying libinput
+Installing method and tricks mentioned here Touchpad SYNA3602 (0911:5288) not working at all
+Switching kernel (4.15 to 3.8, all available ones in Manjaro's settings GUI)

I'm so desperated, i've been for 7 days trying all these methods and nothing seems to work, any idea i should try?

Thanks in advance!

If you have tried everything, and nothing has worked, it's quite possible the hardware is not compatible.

A couple of immediate choices:

  1. Use a mouse
  2. Return the hardware and buy something that is compatible.

Did you guys tried this method i mentioned here?

the package libinput-gestures from AUR might help.
Cheers!

It is compatible, some people have succeded in this! I am just trying to get it working, but cannot find the right method

In which case: if they have posted about this, it would be on the forum.

If you can't find the right method, how do you know people have got it working?

Have you tried using kernel 4.9 lts instead?

Still not working in kernel 4.17 ... my wireless USB mouse became my best friend =)

On this forum:


someones says it works with compiled kernel version that can be found here:
https://people.canonical.com/~khfeng/lp1728244-testing/
Can you try?
There is a way to try it on our manjaro distro?

I'm currently working on that issue :wink:

Please try linux417 4.17.11-1 from unstable. It should work now, based on my current development.

1 Like

Hi philm!
I update mirror to unstable branch and then linux417 4.17.11-1 showed up to pamac so I installed and solved one and for good touchpad bug on ezbook 3 pro!!
Thank you very much!!

2 Likes

Do you have v4 of the EZbook 3 Pro or another? What is the date of the BIOS?

Hi, I got a ezbook 3 pro v4 (flashed to newer bios).

Touchpad never worked in stock bios, neiter in flashed newer bios, and all tricks I tried failed until I installed the kernel 4.17.11.1 (I had changed in unstable branch mirror to find it).

Now touchpad works flawlessy (I restart the machine several time to confirm it).

I bet the patched kernel (compiled by philm for arch-based distro and available to debian-based distro in link above) solve the bug for all the ezbook 3 pro.

I hope this patch will be in the mainline kernel so we can upgrade kernel without fear of regression to bugged touchpad.

Good luck!

Forum kindly sponsored by