Touchpad SYNA3602 (0911:5288) not working at all

It is compatible, some people have succeded in this! I am just trying to get it working, but cannot find the right method

In which case: if they have posted about this, it would be on the forum.

If you can't find the right method, how do you know people have got it working?

Have you tried using kernel 4.9 lts instead?

Still not working in kernel 4.17 ... my wireless USB mouse became my best friend =)

On this forum:

someones says it works with compiled kernel version that can be found here:
Can you try?
There is a way to try it on our manjaro distro?

I'm currently working on that issue :wink:

Please try linux417 4.17.11-1 from unstable. It should work now, based on my current development.

1 Like

Hi philm!
I update mirror to unstable branch and then linux417 4.17.11-1 showed up to pamac so I installed and solved one and for good touchpad bug on ezbook 3 pro!!
Thank you very much!!


Do you have v4 of the EZbook 3 Pro or another? What is the date of the BIOS?

Hi, I got a ezbook 3 pro v4 (flashed to newer bios).

Touchpad never worked in stock bios, neiter in flashed newer bios, and all tricks I tried failed until I installed the kernel (I had changed in unstable branch mirror to find it).

Now touchpad works flawlessy (I restart the machine several time to confirm it).

I bet the patched kernel (compiled by philm for arch-based distro and available to debian-based distro in link above) solve the bug for all the ezbook 3 pro.

I hope this patch will be in the mainline kernel so we can upgrade kernel without fear of regression to bugged touchpad.

Good luck!

Nice. Quick on the heals of the same patch for Ubuntu. How do you download this kernel?

This touchpad problem also happens with the Jumper EZbook X4 shown in this TechTablets video using Manjaro, so hopefully this fix will work for that one as well. I'm guessing this same touchpad is used in MANY different low cost China-branded systems with N3450/N4200 Apollo-Lake and N4000/N5000 Gemini-Lake Intel CPU's. I think these low power quad-core SoC's are a good value in their balance of price, performance, and low power (6 watts TDP) so low on battery power consumption. But these notebooks durable/long-lasting? dunno.

Wow, you are brave! How did you do that? Jumper does not provide an app for upgrading the BIOS, right? I was lucky and the v4 that I have always had a working touchpad. They must have built it with a different part makers. I will probably test this build to make sure it does not break my touchpad function!

I manage to flash newer bios following instructions on techtablets forum (ezbook section - you can find it here: ) some month ago, reading carefully other users feedback and guide before my attempt.

To install kernel, according to manjaro wiki (I followed this method), you have to type in terminal:

sudo pacman-mirrors --api --set-branch unstable

Then update the new unstabe mirrors typing in terminal:

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

Then you will find that kernel version in pamac/pacman and/or in manjaro-settings-manager/kernel section, and, once you installed it, reboot your machine. After that, its done.

Do it all above at your risk (I got no problem but I tested only on my ezbook 3 pro v.4 flashed to newer kernel).

Ps.: my bios was dated 11/06/17 – Bios Tag 3BANS010 (I cant remember what is now).

Good luck bro!

So did your touchpad works? Then why would you install patched kernel on your machine?

Yes my touchpad works. I just to want to test that this fix (for yours) does not break mine in a future kernel release. Most likely not. The change was only adding new device ID, correct?
Where is the souce code? I prefer just compile the one module not install the whole kernel.

Can you guys please post your inxi -Fxzc0 and dmesg and attach them with a kernel boot <4.17.11 and one with >=4.17.11. I already added mine:

v4.18 is still broken and it seems I've to revert more for that series ...

I also patched now linux418 series. However, I'll still try to find a proper fix with upstream on that matter. At least I could narrow it down further.

Seems the way I tried to fix it, created a regression on some other end. Therefore please test the following kernels and report back, on which of these it my work. When you booted to one, which is not working, please try this:

sudo echo 'on' > /sys/bus/i2c/devices/i2c-SYNA3602\:00/power/control
sudo rmmod i2c_hid
sudo modprobe i2c_hid

Here's the output of

inxi -Fxzc0


inxi -Fxzc0
  Host: ezb3p Kernel: 4.17.11-3-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.1.1 Desktop: N/A Distro: Manjaro Linux 
  Type: Laptop System: Jumper product: EZbook v: N/A serial: <filter> 
  Mobo: Jumper model: P3132 serial: <filter> UEFI: American Megatrends 
  v: Jumper10x.P8.WP3132.NHNAUHL01 date: 12/05/2017 
  ID-1: BAT0 charge: 5.3 Wh condition: 48.0/48.0 Wh (100%) 
  model: Intel SR 1 SR Real Battery status: Charging 
  Topology: Quad Core model: Intel Celeron N3450 bits: 64 type: MCP 
  arch: N/A L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 8756 
  Speed: 940 MHz min/max: 800/2200 MHz Core speeds (MHz): 1: 954 2: 941 
  3: 943 4: 957 
  Card-1: Intel driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: N/A driver: modesetting 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 500 (Broxton 2x6) 
  v: 4.5 Mesa 18.1.5 direct render: Yes 
  Card-1: Intel Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster 
  driver: snd_hda_intel v: kernel bus ID: 00:0e.0 
  Sound Server: ALSA v: k4.17.11-3-MANJARO 
  Card-1: Intel Wireless 3165 driver: iwlwifi v: kernel bus ID: 01:00 
  IF: wlp1s0 state: up mac: <filter> 
  Local Storage: total: 58.24 GiB used: 12.99 GiB (22.3%) 
  ID-1: /dev/mmcblk1 model: SDW64G size: 58.24 GiB 
  ID-1: / size: 5.62 GiB used: 4.96 GiB (88.3%) fs: ext4 dev: /dev/mmcblk1p5 
  ID-2: /home size: 23.62 GiB used: 7.98 GiB (33.8%) fs: ext4 
  dev: /dev/mmcblk1p6 
  System Temperatures: cpu: 50.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 172 Uptime: 5m Memory: 5.68 GiB used: 1.21 GiB (21.3%) 
  Init: systemd Compilers: gcc: 8.1.1 Shell: bash v: 4.4.23 inxi: 3.0.18 

Forum kindly sponsored by