TP-LINK TL-WN821N - Can't connect to any network

Hello guys Trent here.
I'm super newbie regarding linux, I started using it today. Saw my friends using Manjaro for gaming and work and I decided to give it a try.

My problem is with my USB WiFi adaptor, it is an TP-LINK TL-WN821N V6. I already tried all kernels available but nothing works. The prioblem is that I can see the device when I list it on the terminal and I can see a list of all available networks but I can't connect to any of them. When i click and add the password it stays "connecting" forever then it just tells me it wasn't able to connect.

I know this issue is related to drivers but i just have no idea how to update or install drivers on linux, I would really appreciate if you guys can help the newbie here hahah :slight_smile:

Post the output of

inxi -Nxxx

EDIT: The device must be connected when you type the command.

etwork:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: 3000 bus ID: 02:00.0 
  chip ID: 10ec:8168 
  Device-2: TP-Link TL-WN821N Version 5 RTL8192EU type: USB driver: rtl8xxxu 
  bus ID: 1-3:4 chip ID: 2357:0107 serial: 00e04c000001 

That is the output

You will need the driver "rtl8192eu" from the AUR and the kernel headers for every kernel you use.

okay.... what... how do i get those drivers? XD

First of all, fully update your system. You said you installed every kernel series. You may want to uninstall the ones you don't intend to use as well.

Do you have pamac installed?

Yes I have pacmac installed and I removed the old Kernels, I'm currently running kernel 5.6.11-1

Install linux56-headers with

sudo pacman -Syyu linux56-headers

Then install the driver with

pamac build rtl8192eu

When it builds the DKMS module, it may take a while, depending on the speed of your processor.

I needed to add, reboot after the installation completes. The wifi module should work.

Okay, when i tried the second command i got this output:

# Maintainer: TJM <tommy.mairo@gmail.com>
pkgname=rtl8192eu
pkgver=4.4.1
pkgrel=2
pkgdesc="Driver for the Realtek8192eu chipset."
arch=("x86_64" "armv6h")
url="https://github.com/Mange/rtl8192eu-linux-driver"
license=('GPL')
depends=("dkms")
makedepends=('linux-headers' 'git' 'bc')
source=("git+https://github.com/Mange/rtl8192eu-linux-driver.git" "fix.patch")
sha256sums=("SKIP" "582f8e8f8bd513b598ada3a1ac625f188fbf313cddf018a440ca4cd8aaf>
install=${pkgname}.install

build() {
        cd "rtl8192eu-linux-driver"
        make -j`cat /proc/cpuinfo |grep "processor"|wc -l`
}
prepare(){
        cd "rtl8192eu-linux-driver"

I can edit the text of this there but i don't see any drivers being build

You selected yes when asked if you wanted to edit the build files. That is the PKGBUILD file.

Oh okay... I just had to say n, my bad. Now it worked. I'm waiting it finish then I give you a feedback :wink:

Okay, now i got an error while building.

==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating rtl8192eu-linux-driver git repo...
Fetching origin
  -> Found fix.patch
==> Validating source files with sha256sums...
    rtl8192eu-linux-driver ... Skipped
    fix.patch ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Creating working copy of rtl8192eu-linux-driver git repo...
Cloning into 'rtl8192eu-linux-driver'...
done.
==> Starting prepare()...
patching file Makefile
Hunk #3 succeeded at 2300 (offset 957 lines).
Hunk #4 succeeded at 2304 (offset 957 lines).
==> Removing existing $pkgdir/ directory...
==> Starting build()...
Makefile:1341: *** recipe commences before first target.  Stop.
==> ERROR: A failure occurred in build().
    Aborting...

I don't know what that means. There are 2 other AUR packages with the same driver: 8192eu-dkms and rtl8192eu-git. You could try them.

EDIT: I had typos in the names of both packages. They are fixed now. It seems I need to go to bed.

I could only build the 8192eu-dkms but still the all networks are listed but I just can't connect to any of them. The rtl8192eu-git output the same error I was having with the first one.

Keep rtl8192eu-dkms installed. You also need to blacklist the kernel driver it's using for your wifi adapter.

Try the following command, then reboot.

echo 'blacklist rtl8xxxu' | sudo tee --append /etc/modprobe.d/rtl8xxxu.conf

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by