Trackpad problem after resuming from suspend


I am running 4.14.53-1-MANJARO with the KDE destop environment on a T440s thinkpad. I am experiencing trackpad problems, maybe someone has an idea how to tackle them?

Often (though not always) after resuming from suspend, my trackpad acts weirdly. Most noticeable, two or more finger gestures do not work anymore. I created a workaround with modprobe -r psmouse which seemed to solve the problem. After some days though, after issuing this command, my scrolling isn't natural anymore. If I then go to System Settings > Touchpad, a notifiaction at the top comes up, saying:

Active settings don't match saved settings. You currently see saved settings.

If I hit apply at the bottom of the window, everything works.

Anyone has any idea how to solve this or how to create a workaround for the natural scrolling similar to the modprobe -r psmouse?

Thanks for any kind of help!

sudo pacman -S fprintd                                        #D-Bus service to access fingerprint readers

Lenovo ThinkPad T440s
Power management/Suspend and hibernate

Thanks for replying.

I'm sorry if my explanation was not clear. By two or more finger gestures I mean double click if tapping with two fingers on the trackpad and middle click emulation if tapping with three. So I don't think fprintd is of any relevance for me.

Thank you for the two links. However, I cannot extract any useful information from them.

This is a confirmed KDE bug here. I've been experiencing similar problems for quite some time and haven't been able to find any good solution either.


Thanks @shivanshs9 for the link to the bug! I've found there

kcminit kcm_touchpad

which seems to be the workaround I've been looking for :slight_smile:

1 Like

Glad to be of some help! :smiley:

Is this issue fixed? I have updated all latest packages but still have this issue.

Still unfixed on Manjaro 18.0.2 and kde Plasma 5.14.5
The link from @shivanshs9 refers to a bug fixed in 5.14. Maybe it is a similar bug or I don't know why it is fixed there and not in Manjaro Plasma.

This service I wrote a few days back has a good likelihood of solving this issue.

Details here:

1 Like

modprobe -r psmouse didn't work but modprobe psmouse worked :slight_smile:

@Goblin I think you wanted to say

sudo modprobe -r psmouse
sudo modprobe psmouse

that's the workaround script working for me
Also, i'm on GNOME desktop environment so i did not tried kcminit

Forum kindly sponsored by