Tried updating LMMS, now getting an "incompatible Qt library" error.

I tried updating LMMS hoping that it would crash less in a future update, so I tried doing a standard sudo pacman -Sy lmms, which worked. But lmms wouldn't start anymore. I forgot what the error was at this part, but it something about Qt, so I tried reinstalling Qt5, removing & installing and now I'm getting this error:

qt5ct: using qt5ct plugin
Cannot mix incompatible Qt library (version 0x50d02) with this library (version 0x50e01)
Aborted (core dumped)

Not sure what else to put here as I don't know how Qt works in detail.

This command caused you to have a partially updated system which is a problem. That will pretty much always break something. In all honestly, you are lucky it is only the application that is broken and not something more.

On a rolling release distro, you need to update your whole system at once. The applications are intended to roll forward together.

If you update your system the problem should be resolved.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by