Triple boot - grub disappeared (win7, manjaro bspwm, arch)

Situation 1: (Dell XPS M1330 - legacy BIOS) So I attempted the following just as a learning experience. Manjaro BSPWM along Win7 (no issues), then I created a separate partition and tried to install Arch, this caused a conflict with the grub. If I delete the Arch partition and reinstall Manjaro BSPWM, both manjaro and windows 7 reappear. I then tried to install arch along the 2 again and got the same issue. I would like to be able to solve the boot issue, it boots into GRUB rescue and no forum threads I have followed work. I have tried these solution suggestions:

Suggestion 1
grub rescue:
grub rescue> set boot=(hd1,msdos2)
grub rescue> set prefix=(hd1,msdos2)/boot/grub
grub rescue> insmod normal
grub rescue> normal

(after insmod normal entry I get this: "error: unknown filesystem")

Suggestion 2

grub> echo $grub_platform
If output is pc, you've booted up in bios-legacy.
If output is efi, you've booted up in uefi.
If you're in the wrong mode, reboot livecd in the right mode.
4. If you are in the right mode, continue.
grub> search.file /etc/manjaro-release root
grub> probe -u $root --set=abc
grub> ls ($root)/boot/

I get this error message: "Error: attempting to read or write between partitions".

Suggestion 3

grub> search.file /etc/manjaro-release
There will be multiple output of your manjaro partitions, use the right one (say (hd2,5)) you want to boot into as follows
grub> set root=(hd2,5)
grub> probe -u $root--set=abc
grub> ls ($root)/boot/
error: "Error: attempting to read or write between partitions".
grub> linux /boot/vmlinuz-4.19-x86_64 root=UUID=$abc rw
grub> initrd /boot/initramfs-4.19-x86_64.img
grub> boot

I get this error: "Error: attempting to read or write between partitions".

In cfdisk from a liveusb, I have sda1 (win7, boot), sda2 manjaro BSPWM, then I created an sda3 (arch) and an sda4 (SWAP). I followed this following Arch installation guide: (https://www.fosslinux.com/7117/how-to-install-arch-linux-complete-guide.htm)

Using Gparted I have discovered that I cannot mount sda2.

When su in bspwm liveusb running command # mount /dev/sda2 /mnt
gives me the following output:

mount: /mnt: wrong fs type, bad option, bad superblock on /Dev/sda2, missing codepage or helper program, or other error.

Situation 2: (ASUS - modern gaming laptop)
I had Ubuntu Studio, Manjaro i3 and Windows 8 multiboot, all working fine until I had to update Windos 8. This broke the manjaro file system and the GRUB Loader. Booting into the bios (this is a modern UEFI) I could select windows or Ubuntu GRUB or manjaro live usb.

Booting into the live USB, I could detect the original i3 GRUB and boot into that, but only through the live USB. Attempts at GRUB recovery through mounting and changing configs, updating GRUB and following suggestions such as the ones described in situation 1, all failed.

I could not remember my passwords either, so I changed the passwords on the mounted partitions using guides for both manjaro and ubuntu. In both cases, the terminal gave back output saying the reset had been successful, however on rebooting into either system, the passwords were still invalid. I ended up just reinstalling everything.

I would still like be able to solve situation 1 though.

I followed these forum posts:

have you resume your last use of win 7 ?
because it will still locked /boot/efi for that

  • disable fast-startup from an Administrators CMD-Shell, within Win10 with “powercfg /h off”
1 Like

What @stephane said and after you install Arch, boot with a Manjaro USB and then do a

manjaro-chroot -a
sudo update-grub

as Manjaro has a heavily patched version of grub, so needs its grub to be restored after another distro is installed.

¯\_(ツ)_/¯ Don't kill the messenger!

Follow Fabby's & stephane's suggestions and also do
sudo grub-install before leaving the chroot.
That should put Manjaro's grub back in charge. update-grub updates the grub menu content, grub-install puts the bootstrap in the MBR (and adjusts the boot order.)

Each linux distro's installer tries to set itself to #1 in the boot order. That's why it is recommended to install Manjaro last in a multi-boot system. Or just skip the Arch grub install as suggested by the above links (AgentS)

3rd edit to account for legacy system not uefi.

I don´t have windows 10 installed

from a live usb terminal i get the following:

" Detected systems

  1. Windows
  2. ManjaroLINUX
  3. Arch

then before doing anything i get the following error messages:
"Select system to mount (0-2)
usr/lib/manjaro-tools/util-mount.sh: line 65: : syntax error: operand expected (error token is " ")

chroot: failed to run command ´bin/bash ´ no such file or directory.

The from the terminal prompt I enter: sudo update-grub and get the following error message:
/usr/bin/grub-probe: error: failed to get canonical path of ´overlay´.

The again from the prompt I enter: sudo grub-install. error. install device isn´t specified.

Well its one of those situations. Thanks for the suggestions but along the way something has gone wrong to the point where nothing seems to work and I have run out of blog post to follow, articles to read, forums and ideas, so I will delete the Arch system by deleting sda3 and sda4, which I know will restore win7 and Manjaro. Then at a later date I will try again with the help of others who have already done it, and not use articles which are designed for similar, but not identical, situations until I get it right. For instance the Arch install article I followed was designed for replacing a windows system. Ah the joys of learning through failure.

No it will not:

Your system is hosed.

At this point your best solution is to take a full data backup and to reinstall... (And even if you don't re-install, take a full data backup while the Manjaro USB is still booted booted before trying to do anything that would incur any data loss)

:sob:

Are you doing all that from within a manjaro-chroot -a or are you just using a normal terminal session? Because, you need to manjaro-chroot into your system before you run those commands.

I might be wrong but manjaro-chroot calls util-mount.sh:

so I'm thinking all the errors I quoted above happen because the Arch install overwrote the Manjaro / and why my advice is to immediately perform a data backup while booted from the Manjaro USB stick as that can read both NTFS and EXTn partitions...

:scream:

That is totally possible.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by