triple boot problem

so i have 3 separate hard drives in my desktop computer. i've been successful in dual booting to linux mint and manjaro. just today i installed windows 10 on my third hard drive. after installing windows 10, it boots up in windows, so i went to bios and changed the top booting priority to manjaro and was able to dual boot. however the grub file didn't detect windows 10. i ran the os-prober in terminal but windows was not detected.
anyways, i was able to dual boot by reading on a tutorial in youtube, but i couldn't find it again for some reason.
the procedure has something to do with mounting the partition, if i remember correctly.
the following is the info i gleaned from running fdisk -l command in the terminal

/dev/sda1 2048 923647 921600 450M Windows recovery environment
/dev/sda2 923648 1126399 202752 99M EFI System
/dev/sda3 1126400 1159167 32768 16M Microsoft reserved
/dev/sda4 1159168 468860927 467701760 223G Microsoft basic data

suggestions? i know i have to modify grub file somehow and sda2 partition probably have to be mounted. thanks in advance.

You probably installed manjaro and mint in bios-legacy and your windows in uefi.
At manjaro terminal, provide

sudo parted -l
cat /etc/fstab

PRINT output of all disks, do not omit or truncate.
"parted -l" --> small 'L', not 'one'
if error, print error message. continue.

here is the printout for sudo parted -l

Model: ATA KINGSTON SA400S3 (scsi)
Disk /dev/sda: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 473MB 472MB ntfs Basic data partition hidden, diag
2 473MB 577MB 104MB fat32 EFI system partition boot, esp
3 577MB 593MB 16.8MB Microsoft reserved partition msftres
4 593MB 240GB 239GB ntfs Basic data partition msftdata

Model: ATA OCZ-ARC100 (scsi)
Disk /dev/sdb: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 538MB 537MB fat32 EFI System Partition boot, esp
2 538MB 232GB 231GB ext4
3 232GB 240GB 8539MB linux-swap(v1)

Model: ATA KINGSTON SA400S3 (scsi)
Disk /dev/sdc: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 240GB 240GB primary ext4

efibootmgr command brings:

EFI variables are not supported on this system.

cat /etc/fstab command brings:

/etc/fstab: static file system information.

Use 'blkid' to print the universally unique identifier for a device; this may

be used with UUID= as a more robust way to name devices that works even if

disks are added and removed. See fstab(5).

UUID=2f657840-65b8-4a2b-8d67-1bb42328507d / ext4 defaults,noatime,discard 0 1
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0

Right, your manjaro fstab does not have a /boot/efi entry and it is not booted in uefi but in bios-legacy though your sdb is in gpt and has a $esp partition.

In short, as expected, it is in bios-legacy and your windows in uefi.

If you want to correct this, make an entry for /boot/efi in its fstab, boot live media in uefi and do grub-install command. However your Mint, which I assume is in sdc is also in bios-legacy and the disk, sdc is in msdos. It cannot be made uefi like manjaro can be (without reinstalling and making disk gpt).

Let us know what you want done. And if you want to convert manjaro to uefi, provide 'sudo blkid' as well. It may be easier (for you) to reinstall manjaro, this time boot live media in uefi and select the $esp (sdb1) as /boot/efi.

Good luck.

thank you for taking the time to explain.
i've read a dual boot how-to from this forum and it talked about disabling fast boot and hibernating sleep and i'm in windows now to do just that.
with that out of the way, i think i'm going to follow your first suggestion, except i'm a little lost. how exactly do you make an entry for /boot/efi in its fstab?
about your second suggestion about booting live media in uefi, i actually created a boot-repair usb flash drive, but unfortunately, i wasn't able to boot off it. it's about 700 meg if i remember correctly and i used netbootin to create a bootable flash drive. on that note, i noticed with manjaro's grub, you can actually access the grub file command line when booting up. is there anything i can type in the grub command line to solve this problem?
another thing i find puzzling is manjaro has gpt but it's in bios-legacy mode. i didn't know they can co-exist. why is it that windows 10 uses uefi while manjaro and mint use bios-legacy? i haven't tampered with the bios setting at all when i installed the os.
again, thanks for your time.

Just make an entry for it in /etc/fstab and then save the file. An example of how that fstab looks. I included root and swap entries so you can see if it tallies with your ssd entries.

UUID=EEE7-35F9                         /boot/efi      vfat    defaults,noatime 0       2
UUID=6d67915e-8add-41ec-a47b-18a574659b8a swap           swap    defaults,noatime 0 0
UUID=2b259af0-f5c5-4b3d-a2f6-19f1d83ee208 /              ext4    defaults,noatime 0 1

That must be done at the bios. You must specify the media to be booted in uefi. You cannot change uefi boot to bios-legacy and vice-versa at grub. All must happen at bios before grub.

As for unetbootin, it won't work for manjaro. You will need etcher, rufus or use 'dd' commands. I do not use usb boots but I am sure unetbootin won't work for manjaro.

Yes, it is a bad thing that installation goes through in bios-legacy with gpt (without a bios_grub unallocated partition, never mind this for now - it is worse with uefi installation on msdos). Nothing I can do about it. I tried, as with many other things. I'm just a user. I can't even code. I can however suggest you go to your bios and make it boot only uefi and make all your disks gpt.

Welcome. Happy to help.

this is what i did after your reply. first, i went to bios and enabled mass storage uefi option where it was defaulted to legacy. i think i also disabled fast boot.
second step: i updated the bio. there were 5 bios versions i needed to update in order to reach to the latest version. i told you i never tinker with bios except the boot order.
third step: i booted into the flash drive which contains the os and disk-repair program. ran it and voila, it sees all the os contained in the 3 drives. i felt triumphant and elated.
however, the feeling of elation was short-lived. when i tried to boot into manjaro via linux mint grub, i just saw the bios splash screen. i think i borked something in the process. also in the process, i found out that i installed the grub file in sdb2 during the previous installation, where the os resides. i discovered that's a no-no. the proper location for me should have been in sdb1.
fourth step: i research some more and discovered your instruction here about fixing bootloader

it's a long read and i was running thin on patience. however, i decided to gamble with just following a few steps. if i fail, i will try again when i have time to kill. this is very, very demoralizing to spend so much time and get nowhere.
so i followed through with step 1 through step 5 given. reboot. went to bio to change manjaro to first place in the booting order, but i found that after following step 1 through 5, manjaro is at the top by default. exit the bios. the manjaro grub appeared with linux mint and windows 10 shown. at least manjaro is bootable once more and all the os were recognized.
so thank you for your dedication. this is a very troublesome area as i see many people have experienced problems with this issue, and it's very time-consuming to explain it in detail.


Good to hear and you're welcome.
Yes, it's a long read but I just cannot find a way with making it simpler with the grub we have. I hope it will be easier with a simpler grub.

Cheers and welcome to Manjaro.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by