Trouble installing Manjaro on emachines W3623 computer

Okay so I’ve been working on installing Manjaro for four days. I’ve tried going through the installer with default and manual settings. My computer will not recognize my hdd as a bootable drive once installed.

I’ve downloaded the distro multiple times and I don’t believe it’s corrupt. The strange part is I got it to install only if I first got Debian and then partitioned the drive for Manjaro. That was the only thing that worked.

Any help would be much appreciated!

Oh btw I’m using a 1tb hard drive and I’ve upgraded the ram to 3gbs.

  1. Don't believe the ISO isn't corrupt - check it!

    1a. Which ISO did you download?

  2. Go to the installer process than again and make notices what you have done exactly.

  • partitions
  • file systems
  • language
  • ...
    A screenshot of the failing might be also helpfull.
  1. Post your inxi
    Dump your "inxi -Fxxxza --no-host" here and bookmark it

    3a. Post the output of dmesg when the installer fails.

  1. Is it possible to check on Mac OS?

    1a. I downloaded the KDE version.

  2. Okay so for the install I went through the settings as is all the way to Partitions.

From there I had originally picked Erase disk for a fresh install.

Then I set up my account, went through the summary, install, and then finished with a reboot.

  1. Do I put in inxi from the installer? The computer isn’t booting the hard drive.

  2. I have made a post about this on Reddit with some more information and what one of the users did to help me.

Here is the link if that helps.

Host: manjaro Kernel: 4.14.65-1-MANJARO x86_64 bits: 64 compiler: gcc
v: 8.2.0 Desktop: KDE Plasma 5.13.4 Distro: Manjaro Linux
Type: Unknown System: emachines product: W3623 v: N/A serial:
Mobo: Intel model: D945GCCRG1 v: AAD86518-300 serial:
BIOS: Intel v: CR94510J.15A.1015.2007.0712.1513 date: 07/12/2007
Topology: Single Core model: Intel Pentium 4 bits: 64 type: MT
arch: Presler rev: 5 L2 cache: 2048 KiB
flags: lm nx pae sse sse2 sse3 bogomips: 12772
Speed: 2400 MHz min/max: 2400/3200 MHz Core speeds (MHz): 1: 2400
2: 2400
Card-1: NVIDIA GF119 [GeForce GT 610] driver: nouveau v: kernel
bus ID: 01:00.0
Display: x11 server: X.Org 1.20.1 driver: nouveau unloaded: modesetting
resolution: 1024x768~60Hz
OpenGL: renderer: NVD9 v: 4.3 Mesa 18.1.6 direct render: Yes
Card-1: Intel NM10/ICH7 Family High Definition Audio
driver: snd_hda_intel v: kernel bus ID: 00:1b.0
Card-2: NVIDIA GF119 HDMI Audio driver: snd_hda_intel v: kernel
bus ID: 01:00.1
Sound Server: ALSA v: k4.14.65-1-MANJARO
Card-1: Intel PRO/100 VE Network driver: e100 v: 3.5.24-k2-NAPI
port: 1000 bus ID: 05:08
IF: enp5s8 state: up speed: 100 Mbps duplex: full mac:
Local Storage: total: 960.39 GiB used: 2.01 GiB (0.2%)
ID-1: /dev/sda vendor: Western Digital model: WD1003FZEX-00MK2A0
size: 931.51 GiB
ID-2: /dev/sdb type: USB vendor: PNY model: USB 2.0 FD size: 28.88 GiB
ID-1: / size: 2.20 GiB used: 135.9 MiB (6.0%) fs: overlay dev: ERR-102
Message: No sensors data was found. Is sensors configured?
Processes: 146 Uptime: 4h 08m Memory: 2.93 GiB used: 1.02 GiB (34.8%)
Init: systemd Compilers: gcc: 8.2.0 Shell: bash v: 4.4.23 inxi: 3.0.20'''

I'm not sure, if the actual Manjaro runs on such an old machine (Presler is from 2006)... but the HDD is there and was found.

ID-1: /dev/sda vendor: Western Digital model: WD1003FZEX-00MK2A0
size: 931.51 GiB

I assume, the old BIOS down't work with the new HDD - so have to partion this a bit.

Please try an installation and create this paritions:

| sda1 | /boot | ext2 | 512 MB
| sda2 | / | ext4 | ~ 928 GB
| sdax |swap | swap | 3 GB

You can also create a fourth partition for /home which is better, cause on a reinstallation you keep your own data.
If you do so, make sda2 for root about 16 GB in size (should be enough if you don't program or install all games :wink: ) and roundabout 900 GB for /home.

Sounds like a case of "The bootloader didn't install properly".

In the partitioning selection, where do you opt to install the bootloader?
That should be in /dev/sda, or if you are follwing @LAZA's advice, in /boot.

1 Like

Your machine has a 2007 BIOS date. Does the Mfg. offer a newer one? If so, I would update it prior to doing anything else. Nothing like starting with a clean, fresh machine. :smiley:

And how/what did you use to burn the ISO?


Hmm... I actually tried doing a partition like that. I gave root 40gbs, swap 5gbs, boot 500mbs and I gave home the rest. I will try this again just to make sure I did this correctly. I’ll update you on this in a bit.

I still have windows vista on a different drive I can plug back in. I thought I did update it... haha :sweat_smile:. I think they discontinued support for it back in 2009? Do you recommend any particular program for updating this?

It’s strange though because I did have Manjaro running really well on my machine, but only if I installed Debian first. Then I could load the manjaro installer and use part of the drive to run the OS. Once I did this it changed the Debian grub to the Manjaro grub. It was kinda backwards and I do not understand why this worked.

I used Etcher on my MacBook Pro to burn the iso to a flash drive. The OS boots from there on the computer I’m trying to install this on.

Emachines W3623? Use who ever mfg your computer. My laptop is a Dell Inspiron 7000 series, model 7537. So I goto Dell's website, look up drivers, etc. for this model. Since you run Windows Vista on another drive, I would boot from it and check for BIOS and other firmware updates for your specific machine.

Correctamundo. :smiley:

But now your Manjaro installation works and you just want to know why?
To figure out why, with some help, you have to repeat the installation process.
Delete everything in your drive, boot up Manjaro installer and report if your computer can see the drive.

I am joking.. :rofl:

This needs some clarification, IMHO. What exactly does it mean?
After a successful Manjaro installation, after reboot... what? can you describe what you see? a cat, or a penguin?:grinning:

Haha idk exactly it just skips over the drive like nothing is installed. It recognizes Debian but not Manjaro for some reason. So if I have Debian as the main OS it will then recognize Manjaro as an OS from grub. The grub is themed for Debian, but after I install Manjaro alongside it grub will be themed for Manjaro.

Yes, because I’d just like to have Manjaro and not Debian. I did this as an experiment to see if I could boot up Manjaro at all. It worked but I’d rather just have the one OS.

Lol I actually did this and it recognized the drive but won’t boot from it.

So I tried this and it told me I was up to date :expressionless:. So there’s not really anything I can do about the bios it would seem. Anymore ideas?

Assuming this is done with Manjaro installed and no Debian instalaltion, I expected you see a black screen with an error message. That was the "cat"..:wink:

Which means that Manjaro grub was installed efficiently. Now it seems that grub installation or the installer process, fails to properly install grub or report an error to inform you.

Since your Manjaro installation is fine, Manjaro grub is installed and active, you can delete Debian partition and that's all!

In your Manjaro installation run this and post

sudo parted -l
sudo blkid

@Strit okay so I tried it @LAZA way and this did not work. I hit F10 and selected the drive but it still did not boot. Sorry about the wait.

Do you guys suppose I could do the install with Debian and then proceed to install Manjaro on a partition of the drive and then delete Debian as @AgentS suggested?

Oh I see haha. It put me on pixie and says that failed. That’s even when I tell it to boot directly to Manjaro.... I’m assuming that’s because it is next on the boot list after checking the cd drive and usb. Other than that it just doesn’t show anything at all.

I will have to redo the process of installing Debian and then Manjaro. Do I need to keep any specific part of Debian for it to keep working afterwards? This is seemingly my only option for an install to keep just the one OS.

So ...

  1. can you boot up to Manjaro?
  2. Can you boot up to manjaro using manjaro's grub?

If yes, why this ....... ?

I reinstalled using @LAZA’s method and so I’ll need to redo the process.

Okey dokey. So you then (after working fine) used laza's method and you have a problem?
Just install manjaro (or just reinstall the bootloader) without needing to install debian. Unless you want to continue experimenting.
Whatever, good luck; keep in touch.

Haha I didn’t know to do that before and I just wanted one OS. I had it working like that awhile back. Just trying to have only one OS.

Forum kindly sponsored by