Trouble installing Manjaro on emachines W3623 computer

Oh I see haha. It put me on pixie and says that failed. That’s even when I tell it to boot directly to Manjaro.... I’m assuming that’s because it is next on the boot list after checking the cd drive and usb. Other than that it just doesn’t show anything at all.

I will have to redo the process of installing Debian and then Manjaro. Do I need to keep any specific part of Debian for it to keep working afterwards? This is seemingly my only option for an install to keep just the one OS.

So ...

  1. can you boot up to Manjaro?
  2. Can you boot up to manjaro using manjaro's grub?

If yes, why this ....... ?

I reinstalled using @LAZA’s method and so I’ll need to redo the process.

Okey dokey. So you then (after working fine) used laza's method and you have a problem?
Just install manjaro (or just reinstall the bootloader) without needing to install debian. Unless you want to continue experimenting.
Whatever, good luck; keep in touch.

Haha I didn’t know to do that before and I just wanted one OS. I had it working like that awhile back. Just trying to have only one OS.

I don't know exactly what stage you're in now.
Just get rid of debian as petsam said. just format out the debian partition.
If you have to reinstall Manjaro, suggest you do not have a boot partition, unnecessary and more hassles to handle. Get partitions ready for installation and install. That''s it.

If you run into problems and cannot boot, take a look at the first post of this. I won't think you will run into any problem. I can't see why you should, actually.

I would recommend you to listen to petsam for issues like this. He will get you up and running.
Except he's sleeping now. Not like me who doesn't need sleep.

Pretty much step one again

Thanks! I will try out this method here in a bit and let you know! Since you don’t sleep I should be able to get a message back from you right away, right? :stuck_out_tongue_winking_eye:

Heh heh.. I do have other things to do, like taking my dog for a walk and breakfast and...
You'll do fine.

Haha thanks again! I’ll let you know!

Okay I’ve had no luck with your method either. Looks like I’m gonna have to go with that backwards install using Debian.... unless you have another idea?

So installation was successfull but you cannot boot?

Have you choosen the file systems as i suggested?

Yes, this exactly.

Yes, it’s very weird how none of this works.

So i think, we need the help of @strit or @philm cause this could be a (serious?) bug.

Well right now I’m trying the way @AgentS suggested with just using Debian to get Manjaro installed and then proceeding with deleting Debian. Should I not do this yet?

You can try this - or wait for professional help :wink:

Haha I hope I’m just not being dumb and it’s something really obvious :sweat_smile:. I’ve probably tried this install over ten times though.
Oh and I forgot to let you know my sha1 checksum was correct. So there was no problem with the download.

1 Like

Let us know after you installed anything, what is parted -l

Okay I ran the parted -l in Debian. Should I post the results and then follow up with Manjaro installed? Would this help you guys at all?

Yes, that would be good. Note 2 output.
sudo parted -l

And after installing manjaro,
would also be good to have.
Good luck.

1 Like

Okay this is with Debian installed.

parted -l

Model: ATA WDC WD1003FZEX-0 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 997GB 997GB primary ext4 boot
2 997GB 1000GB 3217MB extended
5 997GB 1000GB 3217MB logical linux-swap(v1)

Model: PNY USB 2.0 FD (scsi)
Disk /dev/sdb: 31.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 32.8kB 2156MB 2156MB primary boot
2 2156MB 2160MB 4194kB primary esp

I'm not sure about efibootmgr. The command would not work.

Forum kindly sponsored by