Trouble installing Manjaro on emachines W3623 computer

Okay here is the parted -l from Manjaro

Model: ATA WDC WD1003FZEX-0 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 538MB 537MB primary ext2
2 538MB 993GB 993GB primary ext4
3 993GB 1000GB 6981MB extended
5 993GB 1000GB 6981MB logical linux-swap(v1)

Model: PNY USB 2.0 FD (scsi)
Disk /dev/sdb: 31.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 32.8kB 2156MB 2156MB primary boot
2 2156MB 2160MB 4194kB primary esp


EFI variables are not supported on this system.

okay. So it works?

No that was from the live installer. It still doesn’t boot.

Didn't you select sda1 to be root in the manual installation?
How is that you have a new sda2?
That shouldn't happen if you had just use manual installation and chose sda1.

But never mind,
My previous link is easier but you said it didn't work, so here's the harder method.
boot up to livecd OS.
At livecd OS, do the commands at the livecd terminal

sudo mount /dev/sda2 /mnt
sudo grub-install --boot-directory=/mnt/boot /dev/sda

Reboot, you will boot to a grub prompt.
at grub prompt, do the following

grub> set root=(hd0,2)
grub> ls ($root)/boot/

copy down the linus kernel and initramfs files
then assuming they are vmlinuz-4.14-x86_64 and initramfs-4.14-x86_64.img

grub> linux /boot/vmlinuz-4.14-x86_64 root=/dev/sda2 rw
grub> initrd /boot /initramfs-4.14-x86_64.img
grub> boot

When booted up, do

sudo grub-install /dev/sda
sudo update-grub

[EDIT] - Is your sda1 now your /boot partition?
The above won't work if that is so.
Didn't we (I) ask you not to have a /boot partition?
Is that the /boot partition?
Let us know.
In the (easier) link), theere is a section to deal with a separate boot.
You must follow that. Otherwise that (easier) link won't work either.
Repeat> A separate boot partition is unnecessary and useless.

Oops sorry I’ll redo the installation real quick. Give me a few.

Alright, it would appear highly likely you did not do manual installation and followed my instructions.
It is also almost certain your sda1 is now your boot partition.

It can still be restored.
Follow this link and take extreme care to use the [Step 4 Variations] for a separate boot.

The instructions are not as easy as the ones we gave you how to install.
If you have difficulty following the easier installation instructions, it is possible you may not be able to follow th instructions on the link instructions.

If that is the case, I'll advise you to reinstall one more time.
But again suggest you prepare the partitions ready
Again suggest you do not have a boot partition.

Take care. Good night.
(its been over 30hours I did not have sleep)

Oh wow yeah get you some sleep. I removed the boot partition

I set up the new installation:

sda1 /

Okay, good luck.
Oh, if I am away, @AgentS will be more than capable (and willing) to help you.

Take care. Hope you have more success this time.

1 Like

Thank you!

This machine may be old enough to have a 32bit bios but I can not figure out how to verify.
Anyhow Debian bootloader handles 32bit bios booting much better than some others maybe that explains why it works with Debian.

I had amd64 version installed on it. Does it somehow revert to a x86 if it’s wrong?

Edit: I did have Manjaro run when I partitioned half my Debian drive. It booted up and ran really smooth.

You know I’ve been at this long enough that I think you’re right. It doesn’t work if Debian isn’t installed

Take a long hard look at the link again.
Read completely the first post. It is not difficult.
Whether you have a separate boot or not, there are instructions in it.
And there are output required should you need help.

If you had successfully installed/booted up before in 64 bits, it should be 64 bit capable.
Confirm with the specs in the manufacturer website.

> 64-bit Computing                  Yes

Just for your own sanity you can check with the terminal command.
sudo dmidecode -t bios
and see if it reports >> runtime size = 64 kbs.

Anyway please do not get side tracked from @gohlip's advise.

Okay so just to make sure I am doing this correctly I took pictures. Sorry for the bad image quality. Also thank you for your patience.
image image image image

Okay those photos uploaded out of order. After I went to the grub menu it looped me back to the installer

Should be 4th photo as showing you how I did the manual installation

Then the first photo because again it didn’t recognize my hdd so I got back to the installer

Then the 3rd photo was when I was about to hit enter on the grub terminal.

After I did that I was looped back to the 2nd photo

grub> search.file /etc/manjaro-release  root


grub> search.file /etc/manjaro-release 

:expressionless: are you serious!? Lmao I have been reading from my phone and did not see root. Is that two spaces? God I can’t believe I did that! Here’s what I saw from my phone not realizing it scrolls to the side: image


Okay thank you! I booted into manjaro that way and installed and updated grub. So then I rebooted to see if it worked and I’m getting this:

Edit: it says No bootable device. The photo got cropped a bit

Forum kindly sponsored by