Trouble with Windows 10/Manjaro dual boot

I'm having trouble getting Manjaro KDE to work on my computer. I've got Windows 10 pro 64-bit running now and followed instructions for shrinking my C: drive, manually creating /, /home, swap, and putting /boot/efi on my EFI partition (as windows calls it).

After going through the install, Windows continues to boot. I then followed the instructions for reinstalling grub. Everything looked good. After a little bit of work, I was able to figure out how to get grub-install to run with no errors (I'm a little rusty with Linux. Forgot to reference where my root fs was the first time I ran grub-install).

Anyway, after running grub-install to completion I was expecting it to work when I rebooted. No joy. Windows 10 started up again, leading me to where I am now. I did reboot one more time to see if maybe there was an option to select a grub bootloader in my UEFI/BIOS, but no luck there. Windows Boot manager was the only option to select.

Any ideas? I'd really appreciate any suggestions.



If it matters, here's my hardware config:

ASRock H270M-ITX/ac
Plextor 512GB NVMe SSD
3TB Toshiba SATA HDD

you should also run
sudo update-grub
better follow this tutorial, or at least start with it ...

1 Like

check also

Hey. Thanks a lot for your response. After I made it to the "UEFI - additional commands" section I thought that was going to resolve my issue. After a reboot, I was back in Windows 10 though. Using my Manjaro installer USB to boot from is working well as a work around.

Below you'll find info requested in the "UEFI - if problem persists" section.




[mhankins@mhankins-pc ~]$ efibootmgr -v
BootCurrent: 0005
Timeout: 1 seconds
BootOrder: 0001,0005,0000,0006
Boot0000 Windows Boot Manager HD(2,GPT,d9895045-cd15-40b5-84ba-5ffcaf875386,0xe1800,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...5................
Boot0001* ࠜmanjaroࠝ HD(2,GPT,d9895045-cd15-40b5-84ba-5ffcaf875386,0xe1800,0x32000)/File(ࠜEFIMANJAROGRUBX64.EFI)
Boot0005* UEFI: JetFlashTranscend 16GB 1.00 PciRoot(0x0)/Pci(0x14,0x0)/USB(17,0)/CDROM(1,0x3fa900,0x8000)..BO
Boot0006 UEFI: JetFlashTranscend 16GB 1.00, Partition 2 PciRoot(0x0)/Pci(0x14,0x0)/USB(17,0)/HD(2,MBR,0x7b585698,0x3fa900,0x2000)..BO
[mhankins@mhankins-pc ~]$ sudo parted -l
[sudo] password for mhankins:
Model: ATA Micron_1100_MTFD (scsi)
Disk /dev/sda: 2048GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 17.4kB 134MB 134MB Microsoft reserved partition msftres
2 135MB 1519GB 1518GB ntfs Basic data partition msftdata
3 1519GB 2048GB 530GB ext4

Model: ATA TOSHIBA DT01ACA3 (scsi)
Disk /dev/sdb: 3001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 17.4kB 134MB 134MB Microsoft reserved partition msftres
2 135MB 3001GB 3000GB ntfs Basic data partition msftdata

Model: JetFlash Transcend 16GB (scsi)
Disk /dev/sdc: 15.8GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 32.8kB 2136MB 2136MB primary boot
2 2136MB 2140MB 4194kB primary esp

Model: WD My Book 25EE (scsi)
Disk /dev/sdd: 8002GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 8002GB 8002GB My Book msftdata

Model: Unknown (unknown)
Disk /dev/nvme0n1: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 473MB 472MB ntfs Basic data partition hidden, diag
2 473MB 578MB 105MB fat32 EFI system partition boot, esp
3 578MB 595MB 16.8MB Microsoft reserved partition msftres
4 595MB 464GB 463GB ntfs Basic data partition msftdata
5 464GB 502GB 38.8GB ext4
6 502GB 512GB 9632MB linux-swap(v1)

[mhankins@mhankins-pc ~]$ sudo blkid
/dev/nvme0n1: PTUUID="2d23663a-865f-4b42-b9bd-edea2c5bd96b" PTTYPE="gpt"
/dev/nvme0n1p1: LABEL="Recovery" UUID="9248C0DA48C0BDEB" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="b336cbc7-6db8-4bba-ad8a-23af840cd740"
/dev/nvme0n1p2: UUID="CA7A-622D" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="d9895045-cd15-40b5-84ba-5ffcaf875386"
/dev/nvme0n1p3: PARTLABEL="Microsoft reserved partition" PARTUUID="5bf137a5-a7c1-4be8-bef3-63ef44c9cfe4"
/dev/nvme0n1p4: LABEL="disk0" UUID="AA82DE6B82DE3C0F" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="6bd3d843-22ab-423b-b76a-c88a08c78532"
/dev/nvme0n1p5: UUID="8c617ba0-90c4-416c-9ca9-61169838de16" TYPE="ext4" PARTUUID="9872723f-a079-485b-9ed8-5f430bcb11df"
/dev/nvme0n1p6: UUID="cbfc22a8-67b0-451e-8ce3-e934bf5c6f0e" TYPE="swap" PARTUUID="747fd8ec-dec9-40dc-93bf-4d3a37e9201e"
/dev/sda1: PARTLABEL="Microsoft reserved partition" PARTUUID="2b435983-f3bf-4865-81f7-9621c1eca2be"
/dev/sda2: LABEL="disk1" UUID="5A4CCC244CCBF931" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="296614c4-cc46-4cd4-9f39-732e1befc7e5"
/dev/sda3: UUID="05c74e0c-c67b-4bed-aa48-ba4fa5e8607a" TYPE="ext4" PARTUUID="251ba266-efa3-4d91-bdce-b39f3b9337ae"
/dev/sdb1: PARTLABEL="Microsoft reserved partition" PARTUUID="a18e8a71-5197-4fc6-9191-636a2fa3b9e5"
/dev/sdb2: LABEL="disk2" UUID="143488C13488A6F8" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="30ed483f-6e17-413b-9bec-0d11ff8bce4a"
/dev/sdc1: UUID="2018-05-07-19-31-30-00" LABEL="MJR17110" TYPE="iso9660" PARTUUID="7b585698-01"
/dev/sdc2: SEC_TYPE="msdos" LABEL="MISO_EFI" UUID="0040-24ED" TYPE="vfat" PARTUUID="7b585698-02"
/dev/sdd1: LABEL="MyBook" UUID="D021-7D7E" TYPE="exfat" PTTYPE="atari" PARTLABEL="My Book" PARTUUID="219d1943-6cae-4a6b-91cc-1c45f91f4998"
[mhankins@mhankins-pc ~]$ findmnt -s
UUID=CA7A-622D vfat defaults,noatime
/ UUID=8c617ba0-90c4-416c-9ca9-61169838de16 ext4 defaults,noatime
swap UUID=cbfc22a8-67b0-451e-8ce3-e934bf5c6f0e swap defaults,noatime
/home UUID=05c74e0c-c67b-4bed-aa48-ba4fa5e8607a ext4 defaults,noatime,disc
[mhankins@mhankins-pc ~]$ findmnt /boot/efi
/boot/efi /dev/nvme0n1p2 vfat rw,noatime,fmask=0022,dmask=0022,codepage=437

Yes, you did all correctly and your output shows that.
It may be that your HP needs more fixing at the bios-setup level.
Further down on the link [some difficult uefi setups], there are 2 further links for HP.


See if these help or if your HP has a different way to go about it, detail it here so others can learn from you.

Good luck and cheers.

Hopefully your HP is not one of the models which is tied in with windows; and will not boot any other OS other than windows. (signature edition ?). Even if that is so, there is a workaround in this link.
If you have to use it (hopefully not), be careful you copy first the windows efi file, make a custom.cfg and be prepared for any windows update (some) that will regenerate the boot and you will have to redo all these again. Or just get rid of windows. :smile:

Thanks for your reply, but I'm not sure where you got the idea that I have a HP computer. Mine is a custom built system, based on an ASRock motherboard. Specs are in my first post.

Right, I've no idea where I got the idea either. :smiley:

So, since you've done all things correctly and your efibootmgr shows 'manjaro' is in your uefi firmware and on top of the list. Try go to your uefi bios setup and see if there's anything there that can help you get the manjaro to boot.

The other links (Asus, MSI) may give an idea. If you've found a way, detail it here so others can learn from you.


I did that have manjaro listed as a boot manager. Selecting it does nothing though. I guess I'll check out the ASUS and MSI links to see what others have tried.

pls post your "efibootmgr -v" one more time and put it into preformatted text (click </> above) I think there is a forward slash missing in that output right between manjaro and the grubx64.efi
Edit: I ment back slash and they are actually all missing.
You posted this:

Boot0001* ࠜmanjaroࠝ HD(2,GPT,d9895045-cd15-40b5-84ba-5ffcaf875386,0xe1800,0x32000)/File(ࠜEFIMANJAROGRUBX64.EFI)

But it should be this: (where are these fancy character coming from btw?)

Boot0001* ࠜmanjaroࠝ HD(2,GPT,d9895045-cd15-40b5-84ba-5ffcaf875386,0xe1800,0x32000)/File(ࠜ\EFI\MANJARO\GRUBX64.EFI)

Hmm. Maybe those characters came from copying and pasting the text from my browser into Konsole.

You might be on to something. I'll check it out pretty soon. I decided for now to just forget trying to share the same disk with Windows and Manjaro, instead to install Manjaro on it's on SSD (sda). Keeping Windows and Linux on separate disks worked the last time I was using Linux (CentOS 7) on my computer.

If the syntax is wrong, as per the link, do again at manjaro terminal

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

It should be okay copying from the link or from above.
Note the difference of the appostrophes (") below



When you have fixed this, please let us know (or guess) how this happen.
Copying from the link direct to terminal is okay and typing directly into konsole should also be okay.
Unless you copied this from another link (not mine) that does not have the commands in 'codes'.
It has happened before and we need to prevent it happening again.

Of course, the best is that this discourse forum does not 'modify' our apostrophes to be aesthetic.
Our linux commands need to be correct, not beautiful.
@jonathon ? as @AgentS has pointed out and requested ? (Thanks petsam)


It's an annoyance which (IIRC) has been raised upstream. It's not a priority as it's not something they have an issue with and the "workaround" is straightforward.

Essentially, put code in a code "tag".


Well, it did turn out that the root cause of my problem was that I copied/pasted the command directly into Konsole. After re-typing the command manually to add Manjaro to my EFI list, it works fine.

I did end up keeping Windows 10 and Manjaro on separate SSDs. I probably could have gotten it to all work on my boot/NVMe SSD, but I ran into the issue of my EFI partition there appearing as read-only to Linux. Windows must have done something again to the partition. Last time this happened, I deleted it and re-created it (using Windows tools). Wish I would have documented the process, as it was a pain in the a**. Anyway, I don't have the patience to have to deal with this issue - so keeping Windows and Linux on separate disks is for me the best way to go.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by