try to install mhwd prime-offloading on nvidia 820M

doesn't work, black screen again.

What doesn't work? If you mean the optimus-switch, I can't help with that as I have no experience with it myself.

As I recall, optimus-manager didn't work for you from some unknown reason, so making optimus-switch work would be the best solution, although if I'm not mistaken, optimus-switch is not as flexible as optimus-manager.

hi :hugs:
maybe i should install 390 or 340 Nvidia drivers.

What doesn't work?

i mean optimus-switch nvidia mode

I'm confused. You wrote

but in the topic you said it's 820M which isn't fermi. If 440 drivers worked for you then it is not fermi and you shouldn't install any 390 or 340 drivers.

You did some risky, deep level changes to drivers manually. Since I didn't know optimus-switch and how it is set, I didn't follow what you have done. And if I had followed, I didn't know why you did those changes, because as I said, I don't understand what it has to do with optimus-switch.

Optimus-manager require from you now to have video-hybrid-intel-440-prime. When you install this, you will have a permanent Hybrid mode. If you want to be able to switch to Intel or Nvidia, you need to install and configure optimus-manager as described in my guide. Because the video-hybrid-intel-440-prime setup doesn't have bumblebee you ignore part where I say about disabling bumblebee, the rest stays the same.
I expanded the point 9 which discusses Hybird setup.

I'm not sure what was the issue in the past, maybe you can make optimus-manager work or maybe it will continue to not work for you. If you already taken steps to set optimus-switch, wait for the helpf of those who know how it works before you jump into different solution.

@dglt, can you make head or tails from this mess?

EDIT: @fla, I noticed, you didn't follow the instruction and didn't do this step, that @dglt told you :

sudo set-nvidia.sh

So if I understand it correctly, you stopped half-way, so no wonder you get black screen.

https://nvidia.custhelp.com/app/answers/detail/a_id/4656/~/list-of-fermi-series-geforce-gpus
· NVIDIA GeForce 820M

440 drivers

It doesn't work for me.
i remember when i installed ubuntu i saw just one nvidia option (340)
what's you mean? when i did this sudo set-nvidia.sh after reboot got black screen

Ah, you are right. In that case, you won't be able to use modern Hybrid mode (Prime Offloading) at all and you need to install video-hybrid-intel-390xx-nvidia-bumblebee and then switch from it to optimus-switch or optimus-manager. Possibly, stay on video-hybrid-intel-390xx-nvidia-bumblebee and use nvidia-xrun. And if you don't care about energy usage, you can set a permanent Nvidia PRIME setup.

So again, your reasonable options are:

why should i install bumblebee and not this method?

i mistakenly thought it was a GeForce GTX 820m but it's a GeForce 820M. nvidia.com says 430.xx works with either way but i do remember something a bout fermi cards not working on newer drivers. :man_shrugging:

run these

sudo mhwd -r pci video-nvidia-430xx
sudo mhwd -i pci video-nvidia-390xx
sudo rm /etc/X11/xorg.conf.d/90-mhwd.conf
sudo rm /etc/modprobe.d/mhwd-gpu.conf
sudo rm /etc/modules-load.d/mhwd-gpu.conf

set nvidia mode after and reboot, also make sure xorg-xrandr is installed before you reboot. without it this wont work

2 Likes

For now follow what @dglt told you to avoid further complications.

1 Like

thank you, it's work.
just have a problem with windows decoration and font size.

screenshots

(windows decoration on maximum it's good)
nvidia
nvidia2
nvidia3
nvidia4

if your talking about everything looking small when using nvidia mode then thats to be expected with KDE. i included a DPI option line in the nvidia config

sudo nano /etc/switch/nvidia/nvidia-xorg.conf

uncomment (remove the #) the DPI option line

Section "Device"
    Identifier "nvidia"
    Driver  "nvidia"
    BusID   "PCI:1:0:0"
    #Option  "DPI" "96 x 96"    #adjust this value as needed to fix scaling
    Option  "AllowEmptyInitialConfiguration"
EndSection

save/exit then set nvidia mode after to apply the changes. log out/in or reboot and the scaling should match that of intel mode

"96 x 96" can be adjusted to your liking

also, i noticed in your previous outputs you dont have certain nvidia optional packages installed like vulkan.

vulkan-icd-loader 
lib32-vulkan-icd-loader
libvdpau 
lb32-libvdpau

i thought they were part of the video-nvidia-* packages, but you might want to check. im on arch right now so no mhwd to verify

1 Like

these both tools (Optimus-manager and Optimus-switch) worked for me but my laptop power button has backlight color when it's intel mode color is blue and when going to Nvidia, color switching to orange (Windows). so before installing Nvidia using video-Linux, the color is blue but after install Nvidia and using these tools on the Intel mode color is Orange.
i think the problem is blacklisting nouveau.
i don't saw this problem on Ubuntu (using nouveau for intel mode?)
also, one time i removed intel conf file in /etc/modprobe.d (Optimus-switch) after reboot the color was back to blue (intel mode)
can we use nouveau for intel mode?

set intel mode and reboot, once your on a desktop is the light orange or blue?

then open a terminal and run

sudo /etc/switch/gpu_switch_check.sh

is the light now blue?

right now i'm on Optimus-manager.
when i was on optimus-switch intel mode (sudo set-intel.sh)
the color was orange (in /etc/modprobe.d intel conf file nouveau was blacklisted) but after removing the conf file and reboot color back to blue

optimus-switch uses acpi_call to disable to nvidia gpu, nouveau is blacklisted because of the number of issues it causes just by being loaded on some machines and bbswitch more often than not just leaves users with a black screen on boot so that was a non-starter as well.

i also instead of having nvidia be unloaded or blacklisted which doesnt always work, i have them load to /bin/false so even if you wanted to manually load them you couldnt on intel mode.

anyway since your on optimus-manager now you should be able to select the switching method in one of the conf files. if im not mistaken you have a choice of nouveau, bbswitch, or acpi_call so you can try and see which works for you. just remember bbswitch needs to be installed or acpi_call if you go with that

1 Like

i'm not installed optimus-manager-qt on my gnome just using switch command in terminal.
i want to nouveau out of blacklist in Intel mode is that possible? @michaldybczak @openminded

intel mode
[fla@fla-pc ~]$ optimus-manager --print-mode

Current GPU mode : intel
[fla@fla-pc ~]$ mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
    video-nvidia-390xx            2019.10.25               false            PCI


Warning: No installed USB configs!
[fla@fla-pc ~]$ ls -laR /etc/X11/
/etc/X11/:
total 32
drwxr-xr-x   5 root root 4096 Feb  8 01:21 .
drwxr-xr-x 100 root root 4096 Feb 13 17:04 ..
drwxr-xr-x   2 root root 4096 Feb 12 22:20 mhwd.d
drwxr-xr-x   3 root root 4096 Feb  8 01:22 xinit
drwxr-xr-x   2 root root 4096 Feb 13 17:03 xorg.conf.d

/etc/X11/mhwd.d:
total 12
drwxr-xr-x 2 root root 4096 Feb 12 22:20 .
drwxr-xr-x 5 root root 4096 Feb  8 01:21 ..

/etc/X11/xinit:
total 28
drwxr-xr-x 3 root root 4096 Feb  8 01:22 .
drwxr-xr-x 5 root root 4096 Feb  8 01:21 ..
-rw-r--r-- 1 root root  739 Mar  4  2019 xinitrc
drwxr-xr-x 2 root root 4096 Feb  8 01:21 xinitrc.d
-rw-r--r-- 1 root root   45 Mar  4  2019 xserverrc

/etc/X11/xinit/xinitrc.d:
total 20
drwxr-xr-x 2 root root 4096 Feb  8 01:21 .
drwxr-xr-x 3 root root 4096 Feb  8 01:22 ..
-rwxr-xr-x 1 root root  318 Nov 10  2018 40-libcanberra-gtk-module.sh
-rwxr-xr-x 1 root root  203 Jan 23 01:46 50-systemd-user.sh

/etc/X11/xorg.conf.d:
total 20
drwxr-xr-x 2 root root 4096 Feb 13 17:03 .
drwxr-xr-x 5 root root 4096 Feb  8 01:21 ..
-rw-r--r-- 1 root root  356 Feb 11 19:34 00-keyboard.conf
-rw-r--r-- 1 root root  108 Feb 13 17:03 10-optimus-manager.conf
[fla@fla-pc ~]$ cat /etc/X11/xorg.conf.d/10-optimus-manager.conf
Section "Device"
	Identifier "intel"
	Driver "modesetting"
	BusID "PCI:0:2:0"
	Option "DRI" "3"
EndSection

[fla@fla-pc ~]$ ls -laR /etc/modprobe.d/
/etc/modprobe.d/:
total 12
drwxr-xr-x   2 root root 4096 Feb 12 22:20 .
drwxr-xr-x 100 root root 4096 Feb 13 17:04 ..
[fla@fla-pc ~]$ ls -laR /etc/modules-load.d/
/etc/modules-load.d/:
total 16
drwxr-xr-x   2 root root 4096 Feb 12 22:20 .
drwxr-xr-x 100 root root 4096 Feb 13 17:04 ..
-rw-r--r--   1 root root   34 Nov 20 01:54 modules.conf
[fla@fla-pc ~]$ ls -laR /usr/share/X11/xorg.conf.d/
/usr/share/X11/xorg.conf.d/:
total 32
drwxr-xr-x 2 root root 4096 Feb 12 22:20 .
drwxr-xr-x 7 root root 4096 Feb  8 01:22 ..
-rw-r--r-- 1 root root   92 Oct 11 21:07 10-amdgpu.conf
-rw-r--r-- 1 root root 1099 Jun  3  2018 10-evdev.conf
-rw-r--r-- 1 root root 1350 Jan 14 16:57 10-quirks.conf
-rw-r--r-- 1 root root   92 Oct 15 20:39 10-radeon.conf
-rw-r--r-- 1 root root 1429 Aug 12  2019 40-libinput.conf
-rw-r--r-- 1 root root 3458 Dec 25 15:02 70-wacom.conf
[fla@fla-pc ~]$ ls -laR /etc/optimus-manager/
/etc/optimus-manager/:
total 28
drwxr-xr-x   2 root root 4096 Feb 13 01:56 .
drwxr-xr-x 100 root root 4096 Feb 13 17:04 ..
-rw-r--r--   1 root root  305 Nov 15 15:04 xorg-intel.conf
-rw-r--r--   1 root root  298 Nov 15 15:04 xorg-nvidia.conf
-rwxr-xr-x   1 root root  127 Nov 15 15:04 xsetup-intel.sh
-rwxr-xr-x   1 root root  195 Nov 15 15:04 xsetup-nvidia.sh
[fla@fla-pc ~]$ cat /etc/optimus-manager/xorg-intel.conf
# You can use this file to add Xorg options which are not covered in the configuration file.
#
# Everything you put here will go to the "Device" section corresponding
# to the Intel GPU in the Xorg configuration.
# Lines starting with # are ignored.
#
# Example :
#
# Option "Backlight" "intel_backlight"
[fla@fla-pc ~]$ cat /etc/optimus-manager/xorg-nvidia.conf
# You can use this file to add Xorg options which are not covered in the configuration file.
#
# Everything you put here will go to the "Device" section corresponding
# to the Nvidia GPU in the Xorg configuration.
# Lines starting with # are ignored.
#
# Example :
#
# Option "ConnectToAcpid" "0" 
[fla@fla-pc ~]$ 

nvidia mode

i have this issue too:

Another quirk of GDM is that the X server may not automatically restart after a GPU switch. If you see an empty black screen or a black screen with a blinking cursor, try switching back to an empty TTY (with Ctrl+Alt+F5 for instance), then back to TTY1 with Ctrl+Alt+F1

[fla@fla-pc ~]$ /.local/share/xorg/Xorg.0.log
bash: /.local/share/xorg/Xorg.0.log: No such file or directory
[fla@fla-pc ~]$ /var/log/Xorg.0.log
bash: /var/log/Xorg.0.log: No such file or directory
[fla@fla-pc ~]$ optimus-manager --print-mode

Current GPU mode : nvidia
[fla@fla-pc ~]$
[fla@fla-pc ~]$ journalctl -u optimus-manager.service
-- Logs begin at Tue 2020-02-11 18:53:41 +0330, end at Thu 2020-02-13 17:43:40 +0330. --
Feb 13 02:00:50 fla-pc systemd[1]: Starting Optimus Manager Commands Daemon...
Feb 13 02:00:50 fla-pc prime-switch-boot[23405]: 2020-02-13 02:00:50 AM +0330 ====================
Feb 13 02:00:50 fla-pc prime-switch-boot[23405]: Optimus Manager (Setup script) version 1.2.2
Feb 13 02:00:50 fla-pc prime-switch-boot[23405]: Setting up boot
Feb 13 02:00:50 fla-pc prime-switch-boot[23405]: Removing config copy
Feb 13 02:00:50 fla-pc prime-switch-boot[23405]: removing last acpi_call state (if any)
Feb 13 02:00:50 fla-pc prime-switch-boot[23405]: Copying user config
Feb 13 02:00:50 fla-pc prime-switch-boot[23405]: Error : attempting to run the initial boot setup while a X server is already running ! Skipping init>
Feb 13 02:00:50 fla-pc systemd[1]: Started Optimus Manager Commands Daemon.
Feb 13 02:00:50 fla-pc python3[23411]: Optimus Manager (Daemon) version 1.2.2
Feb 13 02:00:50 fla-pc python3[23411]: Automatic log cropping
Feb 13 02:00:50 fla-pc python3[23411]: Opening UNIX socket
Feb 13 02:00:50 fla-pc python3[23411]: Awaiting commands
Feb 13 02:02:11 fla-pc python3[23411]: Received command : {"type": "startup", "args": {"mode": "intel"}}
Feb 13 02:02:11 fla-pc python3[23411]: Writing startup mode intel
Feb 13 02:08:30 fla-pc python3[23411]: Process stop requested
Feb 13 02:08:30 fla-pc python3[23411]: Closing and removing the socket...
Feb 13 02:08:30 fla-pc python3[23411]: Cleaning up Xorg conf...
Feb 13 02:08:30 fla-pc python3[23411]: Goodbye !
Feb 13 02:08:30 fla-pc systemd[1]: Stopping Optimus Manager Commands Daemon...
Feb 13 02:08:30 fla-pc systemd[1]: optimus-manager.service: Succeeded.
Feb 13 02:08:30 fla-pc systemd[1]: Stopped Optimus Manager Commands Daemon.
-- Reboot --
Feb 13 02:08:53 fla-pc systemd[1]: Starting Optimus Manager Commands Daemon...
Feb 13 02:08:54 fla-pc prime-switch-boot[482]: 2020-02-13 02:08:54 AM +0330 ====================
Feb 13 02:08:54 fla-pc prime-switch-boot[482]: Optimus Manager (Setup script) version 1.2.2
Feb 13 02:08:54 fla-pc prime-switch-boot[482]: Setting up boot
Feb 13 02:08:54 fla-pc prime-switch-boot[482]: Removing config copy
Feb 13 02:08:54 fla-pc prime-switch-boot[482]: removing last acpi_call state (if any)
Feb 13 02:08:54 fla-pc prime-switch-boot[482]: Copying user config
Feb 13 02:08:54 fla-pc prime-switch-boot[482]: Cleaning up leftover Xorg conf
Feb 13 02:08:54 fla-pc prime-switch-boot[482]: Loading config
Feb 13 02:08:54 fla-pc prime-switch-boot[482]: Reading startup mode
Feb 13 02:08:54 fla-pc prime-switch-boot[482]: No kernel parameter set for startup, reading from file
lines 1-35
[fla@fla-pc ~]$ journalctl -u display-manager.service
-- Logs begin at Tue 2020-02-11 18:53:41 +0330, end at Thu 2020-02-13 17:44:32 +0330. --
-- No entries --
[fla@fla-pc ~]$ ls -laR /etc/X11/
/etc/X11/:
total 32
drwxr-xr-x   5 root root 4096 Feb  8 01:21 .
drwxr-xr-x 100 root root 4096 Feb 13 17:37 ..
drwxr-xr-x   2 root root 4096 Feb 12 22:20 mhwd.d
drwxr-xr-x   3 root root 4096 Feb  8 01:22 xinit
drwxr-xr-x   2 root root 4096 Feb 13 17:41 xorg.conf.d

/etc/X11/mhwd.d:
total 12
drwxr-xr-x 2 root root 4096 Feb 12 22:20 .
drwxr-xr-x 5 root root 4096 Feb  8 01:21 ..

/etc/X11/xinit:
total 28
drwxr-xr-x 3 root root 4096 Feb  8 01:22 .
drwxr-xr-x 5 root root 4096 Feb  8 01:21 ..
-rw-r--r-- 1 root root  739 Mar  4  2019 xinitrc
drwxr-xr-x 2 root root 4096 Feb  8 01:21 xinitrc.d
-rw-r--r-- 1 root root   45 Mar  4  2019 xserverrc

/etc/X11/xinit/xinitrc.d:
total 20
drwxr-xr-x 2 root root 4096 Feb  8 01:21 .
drwxr-xr-x 3 root root 4096 Feb  8 01:22 ..
-rwxr-xr-x 1 root root  318 Nov 10  2018 40-libcanberra-gtk-module.sh
-rwxr-xr-x 1 root root  203 Jan 23 01:46 50-systemd-user.sh

/etc/X11/xorg.conf.d:
total 20
drwxr-xr-x 2 root root 4096 Feb 13 17:41 .
drwxr-xr-x 5 root root 4096 Feb  8 01:21 ..
-rw-r--r-- 1 root root  356 Feb 11 19:34 00-keyboard.conf
-rw-r--r-- 1 root root  759 Feb 13 17:41 10-optimus-manager.conf
[fla@fla-pc ~]$ cat /etc/X11/xorg.conf.d/10-optimus-manager.conf
Section "Files"
	ModulePath "/usr/lib/nvidia"
	ModulePath "/usr/lib32/nvidia"
	ModulePath "/usr/lib32/nvidia/xorg/modules"
	ModulePath "/usr/lib32/xorg/modules"
	ModulePath "/usr/lib64/nvidia/xorg/modules"
	ModulePath "/usr/lib64/nvidia/xorg"
	ModulePath "/usr/lib64/xorg/modules"
EndSection

Section "ServerLayout"
	Identifier "layout"
	Screen 0 "nvidia"
	Inactive "intel"
EndSection

Section "Device"
	Identifier "nvidia"
	Driver "nvidia"
	BusID "PCI:1:0:0"
	Option "Coolbits" "28"
EndSection

Section "Screen"
	Identifier "nvidia"
	Device "nvidia"
	Option "AllowEmptyInitialConfiguration"
EndSection

Section "Device"
	Identifier "intel"
	Driver "modesetting"
	BusID "PCI:0:2:0"
EndSection

Section "Screen"
	Identifier "intel"
	Device "intel"
EndSection

[fla@fla-pc ~]$ ls -laR /etc/modprobe.d/
/etc/modprobe.d/:
total 12
drwxr-xr-x   2 root root 4096 Feb 12 22:20 .
drwxr-xr-x 100 root root 4096 Feb 13 17:37 ..
[fla@fla-pc ~]$ ls -laR /etc/modules-load.d/
/etc/modules-load.d/:
total 16
drwxr-xr-x   2 root root 4096 Feb 12 22:20 .
drwxr-xr-x 100 root root 4096 Feb 13 17:37 ..
-rw-r--r--   1 root root   34 Nov 20 01:54 modules.conf
[fla@fla-pc ~]$ ls -laR /etc/optimus-manager/
/etc/optimus-manager/:
total 28
drwxr-xr-x   2 root root 4096 Feb 13 01:56 .
drwxr-xr-x 100 root root 4096 Feb 13 17:37 ..
-rw-r--r--   1 root root  305 Nov 15 15:04 xorg-intel.conf
-rw-r--r--   1 root root  298 Nov 15 15:04 xorg-nvidia.conf
-rwxr-xr-x   1 root root  127 Nov 15 15:04 xsetup-intel.sh
-rwxr-xr-x   1 root root  195 Nov 15 15:04 xsetup-nvidia.sh
[fla@fla-pc ~]$ cat /etc/optimus-manager/xorg-intel.conf
# You can use this file to add Xorg options which are not covered in the configuration file.
#
# Everything you put here will go to the "Device" section corresponding
# to the Intel GPU in the Xorg configuration.
# Lines starting with # are ignored.
#
# Example :
#
# Option "Backlight" "intel_backlight"
[fla@fla-pc ~]$ cat /etc/optimus-manager/xorg-nvidia.conf
# You can use this file to add Xorg options which are not covered in the configuration file.
#
# Everything you put here will go to the "Device" section corresponding
# to the Nvidia GPU in the Xorg configuration.
# Lines starting with # are ignored.
#
# Example :
#
# Option "ConnectToAcpid" "0" 
[fla@fla-pc ~]$ 

[fla@fla-pc ~]$ ls -laR /usr/lib/modprobe.d/
/usr/lib/modprobe.d/:
total 172
drwxr-xr-x   2 root root   4096 Feb 13 01:56 .
drwxr-xr-x 234 root root 143360 Feb 13 06:18 ..
-rw-r--r--   1 root root    128 Dec 22 18:08 bluetooth-usb.conf
-rw-r--r--   1 root root    101 Oct 28 22:18 nvdimm-security.conf
-rw-r--r--   1 root root    102 Nov 15 15:04 optimus-manager.conf
-rw-r--r--   1 root root    765 Jan 23 01:46 systemd.conf
-rw-r--r--   1 root root    369 Aug 11  2018 uvesafb.conf
[fla@fla-pc ~]$ cat /usr/lib/modprobe.d/optimus-manager.conf
blacklist nouveau
blacklist nvidia_drm
blacklist nvidia_uvm
blacklist nvidia_modeset
blacklist nvidia
[fla@fla-pc ~]$ 
1 Like

I don't know, I haven't ever tried it, cuz for me "nouveau" is a French for a "nightmare": it causes lockups and metric tonnes of errors if not killed beforehand for the glory of the emperor!

1 Like

I also have:

 michaldybczak  alienware-PC  ~  cat /usr/lib/modprobe.d/optimus-manager.conf
blacklist nouveau
blacklist nvidia_drm
blacklist nvidia_uvm
blacklist nvidia_modeset
blacklist nvidia

and nouveau as a switching method works fine for me.

As to prime-offloading, it isn't possible on nvidia-390xx driver and will never be possible, unless somehow nvidia decides to port it back, but I doubt it. It isn't even possible with 430xx series.
At the moment prime-offloading is available on 435xxx series and above (so 440xxx and future ones).

There is a gnome extension that does the same as optimus-manager-qt. Use it instead (I don't remember the name but it should be easy findable), because -qt version won't appear on the gnome's panel as I understand it. I can't tell for sure because I'm not running gnome.

1 Like

I came back to KDE and even using bbswitch on Intel mode power button is blue :innocent:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by