Trying to change efi boot order with efibootmgr: GRUB falls into rescue mode!

Hello everyone, I've been dealing with this issue for days but cannot find any solution.
I have a dual boot system on my HP Omen 15-AX000NL laptop with Windows and Manjaro. I'm trying to make manjaro (or actually the GRUB menu) the default boot option so that the computer automatically shows the grub menu on boot without me needing to touch anything. Instead at the moment it automatically boots into windows. Here's what I did (unsuccessfully):

  • Change efi file boot order in BIOS: nothing happens, the order is just ignored
  • efibootmgr -o XXXX,YYYY,... where XXXX is the manjaro code and YYYY the windows one (as seen from the output of efibootmgr -v): boot order is changed but on reboot GRUB falls into rescue mode and shows the recovery console. The error is "no such device:" and then the UUID of my actual Manjaro partition (so it's like it doesn't find the Manjaro partition, but it actually is there and the UUID is correct, I checked with blkid). On the second line of the error it says "unknown filesystem" (and here's where it gets even more confusing: how can you say unknown filesystem if you just said you can't find the partition?). And then there's just the grub> line waiting for commands.
  • grub-install and then again efibootmgr -o nothing changes, same as before, grub falls into rescue mode
  • Manually copying the grubx64.efi file in place of bootx64.efi or bootmgfw.efi: same "grub rescue" problem

If I reboot and select the manjaro boot file manually, it boots fine. If I reboot again and do nothing I now have the grub rescue console showing up unless I boot into Windows and reboot it again in recovery mode (by holding shift while rebooting), so that it changes the efi boot order again, making Windows default again.


efibootmgr -v
findmnt /boot/efi
sudo parted -l

o After doing "efibootmgr -o XXXX,YYYY,…", is manjaro showing at the top of the bootorder?
o And when you reboot (and still having problem), is manjaro still showing at the top of the bootorder? (maybe completely gone from the bootorder?)
o Have you more than one disk? A "parted -l" will be useful

One other issue that may be causing this, if you wait, say for 20 seconds, before pressing 'enter' for your selected menuentry, does the problem disappear?

Hello and thank you for your attention
Here's the output of efibootmgr -v

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0004,3004,0000,2001,2002,2004
Boot0000* manjaro HD(1,GPT,a959959d-5dda-4679-b26f-3121a83ae82c,0x800,0x82000)/File(\EFI\manjaro\grubx64.efi)
Boot0004* Windows Boot Manager HD(1,GPT,a959959d-5dda-4679-b26f-3121a83ae82c,0x800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...Z................
Boot2001* EFI USB Device RC
Boot3004* Internal Hard Disk or Solid State Disk RC

Here's findmnt /boot/efi

/boot/efi /dev/sda1 vfat rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mi

sudo parted -l

Model: ATA SanDisk SD8SNAT- (scsi)
Disk /dev/sda: 128GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 274MB 273MB fat32 EFI system partition boot, esp
2 274MB 290MB 16.8MB Microsoft reserved partition msftres
3 290MB 127GB 127GB ntfs Basic data partition msftdata
4 127GB 128GB 1028MB ntfs Basic data partition hidden, diag

Model: ATA HGST HTS721010A9 (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 859GB 859GB ntfs Basic data partition msftdata
2 859GB 985GB 126GB ext4
4 985GB 1000GB 15.1GB ntfs Basic data partition hidden, msftdata

  • After doing “efibootmgr -o XXXX,YYYY,…”, Manjaro is showing at the top
  • When I reboot sometimes it isn't actually at the top anymore, sometimes it is
  • I have more than one disk (as you can see from parted): one M.2 SSD where windows is installed. One 1TB HDD where there are three partitions: the first is for windows data storage (I use that under manjaro too), the second is the manjaro partition and the third is the windows RECOVERY

I can't wait for GRUB to load the system because I actually get the GRUB rescue console and nothing else. It's not me doing something to open the rescue console, it shows up automatically and that's all I can get :frowning:

Edit: this is the error I get from GRUB btw

Boot up Manjaro, at terminal

sudo grub-install
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi

If problem of efibootmgr still persist, see HP website if bootorder can only be done through the bios setup (F2).

As to your (screen shot) error, check if the said uuid, dc2xxxxxxxxxxaa0 is the swap partition.
If it is, check fstab and /etc/default/grub if the uuid in "resume=xxxxxxxxxxxxxx" correspond with your swap uuid and update-grub. If it other partition (not swap), see your /etc/fstab is correct.

Good luck.

I tried ALL of what you said and I'm still getting the same error
The UUID is correct for the manjaro partition. I don't have any swap partition.
The BIOS has an option to set the boot order: i tried that and it failed, it was just ignored

Hi, it's late here, But there are some quick searches on your HP where people cannot change the default bootorder.
Please go through these links (I need to sleep now) and hope you see something that may help.

link 1
link 2
link 3
link 4
link 5

I read somewhere in one of these links something like "... affects the current boot, and subsequent boots revert to the default boot" (but now I cannot find it, sorry).

As to your grub error where the "no such device" is the manjaro partition, that's not good (swap is understandable and easily resolved). Try to fsck the partition first (unmounted).

Good luck and good night.

[edit] - please check you have set up 'secure boot' to be disabled.

Thank you very much dude. After days of tinkering, I finally figured it out...
Turns out setting the right boot order from the BIOS setup is actually possibile, but there's like a hidden sub-menu I had to look for. In fact, if you go to the page where you can choose the boot order, you just have an option for "OS boot loader" that you can put on the top but you can't choose which boot loader you want first. Then, I figured out that if you press enter while highlighting said option, you get a sub-menu that allows you to choose the right OS to boot first.
But then if you just very Esc and F10 to save, it won't be saved! You need to press F10 to close and save that sub-menu and then F10 again to exit the setup and save! I feel stupid for not understanding this the first time, but it is very unintuitive!
Thank you for your time, I'm sorry if this turned out being such a stupid thing :frowning:

You're much welcome, dude. :laughing:
Glad you finally found the way through the bios setup.
If others have the same problem in their HP systems, would be good if you can step in with helping them.
As this is not intuitive, perhaps a step by step screen shots would be helpful for them.

You can put them here so that in future you can refer them to this page.
Cheers, take care.

Alright, excuse me for my delay but I've had a pretty bad weekend

So, for everyone trying to change the EFI startup order on their HP OMEN AX000NL laptop (and laptops that have a similar BIOS setup utility), you need to go to your BIOS setup (by quickly pressing F10 on startup), then you want to go into System Configuration (by using your left/right arrow keys) and select Boot Options (by using your up/down arrow keys)


Then press enter to enter this Menu and scroll Down (using your up/down arrow keys) until you reach OS Boot Manager. Now, using your F5/F6 keys, make sure this option is placed on top of the others. But it is not over: see there's a little arrow on the left side of this particular option? That means it has a sub-menu you need to access to by pressing the ENTER key. Now you'll see a list of all of the available EFI bootable OSes. Here comes the tricky part: you nee to use your F5/F6 keys again to make sure Manjaro is on the top of this list. Then press F10 to close this sub-menu and save the changes, then press F10 again to exit the BIOS setup utility and save the changes.



This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by