Trying to get a dual GPU laptop to work right - GLX-related errors

My goal: run video games on the laptop using NVidia's GPU. Intel GPU doesn't matter, can be disabled/left unused if possible.

This is where I'm currently at: glxinfo and optirun glxinfo return "Error: couldn't find RGB GLX visual or fbconfig", while glxgears and optirun glxgears return "Error: couldn't get an RGB, Double-buffered visual". Also, when trying to launch an OpenGL game (eg. Minecraft), I'm getting the "Could not init GLX" error, regardless of whether I'm using optirun or not. Similar errors in Xorg.0.log

What have I done?:

  • installed kernel 4.16
  • ran sudo mhwd -a pci nonfree 0300 in order to install proprietary drivers
  • followed the "Using nvidia" steps on Arch Wiki: https://wiki.archlinux.org/index.php/NVIDIA_Optimus#Using_nvidia (placing these "Section" lines in /etc/X11/xorg.conf.d/90-mhwd.conf didn't help)
  • attempted to reinstall libgl with sudo pacman -S libgl

but no dice.

Xorg.0.log: https://pastebin.com/pjP4S14q

What have I done wrong?
Oh, I forgot to mention, it's a GTX 960M.

mhwd -li
please.
(note - most likely you have doubled down by adding those extra lines to mhwd - it sets it up for you)
Oh, and also always a good place to start:
inxi -Fxzc0

(EE) Screen 1 deleted because of no matching config section.
(II) UnloadModule: "nvidia"
(II) UnloadSubModule: "wfb"
(II) UnloadSubModule: "fb"

And then

(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

You need a "matching config section." for nvidia . You said you edited xorg.conf file.
What exactly, which file?
Post it here please.
Can your system (which is?? give us inxi -SGxxz) disable intel GPU from BIOS? Do it if it is possible, as you say you don't need it.
Else you should use modesetting as described in the wiki you gave.

I dont think so. I think they should be using bumblebee, should not have done what the wiki outlines instead of what mhwd provided, and then should add to /etc/X11/mhwd.d/intel.conf :

Section "OutputClass"
    Identifier "intel"
    ModulePath "/usr/lib/xorg/modules/extensions"
EndSection

Or thereabouts, but more info would be helpful.

1 Like

You said you edited xorg.conf file.
What exactly, which file?

I have edited it exactly as the Arch Wiki describes, while remembering to replace the Bus ID of course. However, I didn't make changes into the xorg.conf file, instead I did changes in xorg.conf.d/90-mhwd.conf.

While I'm not here, a person with a nickname of 'psvarek' will provide you with more info of that laptop :slight_smile:

Here you have what I’ve got from mhwd -li :

[arek@arek-pc ~]$ mhwd -li

> Installed PCI configs:

NAME                                VERSION             FREEDRIVER    TYPE

video-linux                         2018.05.04		true          PCI
video-hybrid-intel-nvidia-bumblebee 2018.05.04		false         PCI

Warning: No installed USB configs!

And here is what I got from inxi -Fxzc0 :

[arek@arek-pc ~]$ inxi -Fxzc0
System:
Host: arek-pc Kernel: 4.16.7-1-MANJARO x86_64 bits: 64 compiler: gcc
v: 7.3.1 Desktop: N/A Distro: Manjaro Linux 17.1.10 Hakoila
Machine:
Type: Laptop System: Micro-Star product: PE60 6QE v: REV:1.0 serial: N/A
Mobo: Micro-Star model: MS-16J5 v: REV:0.A serial: N/A
UEFI: American Megatrends v: E16J5IMS.111 date: 03/24/2016
Battery:
ID-1: BAT1 charge: 38.6 Wh condition: 40.6/43.2 Wh (94%) model: MSI BIF0_9
status: Unknown
CPU:
Topology: Quad Core model: Intel Core i7-6700HQ bits: 64 type: MT MCP
arch: Skylake-S rev: 3 L2 cache: 6144 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 41488
Speed: 800 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 800 2: 800
3: 800 4: 800 5: 801 6: 800 7: 800 8: 800
Graphics:
Card-1: Intel HD Graphics 530 driver: i915 v: kernel bus ID: 00:02.0
Card-2: NVIDIA GM107M [GeForce GTX 960M] driver: nvidia v: 396.24
bus ID: 01:00.0
Display: x11 server: N/A driver: intel,nvidia unloaded: modesetting
resolution:
OpenGL: renderer: N/A v: N/A direct render: N/A
Audio:
Card-1: Intel Sunrise Point-H HD Audio driver: snd_hda_intel v: kernel
bus ID: 00:1f.3
Sound Server: ALSA v: k4.16.7-1-MANJARO
Network:
Card-1: Intel Wireless 3165 driver: iwlwifi v: kernel bus ID: 02:00.0
IF: wlp2s0 state: up mac:
Card-2: Qualcomm Atheros AR8161 Gigabit Ethernet driver: alx v: kernel
port: d000 bus ID: 03:00.0
IF: enp3s0 state: down mac:
Drives:
HDD Total Size: 931.51 GiB used: 7.62 GiB (0.8%)
ID-1: /dev/sda model: WDC_WD10JPVX-22J size: 931.51 GiB
Partition:
ID-1: / size: 47.81 GiB used: 7.59 GiB (15.9%) fs: ext4 dev: /dev/sda7
Sensors:
System Temperatures: cpu: 57.5 C mobo: 27.8 C
Fan Speeds (RPM): N/A
Info:
Processes: 217 Uptime: 21m Memory: 7.71 GiB used: 1.37 GiB (17.8%)
Init: systemd Compilers: gcc: 7.3.1 clang: 6.0.0 Shell: bash v: 4.4.19
inxi: 3.0.07

Here you have content of this ( /etc/X11/xorg.conf.d/90-mhwd.conf ) file.

And I was looking in BIOS options and there wasn't any that could allow me to disable intel GPU.

There is a very detailed and complete Tutorial for this issue.
Please read it carefully and follow it. If your issue is not solved report here for any more assistance.

Edit: please use code blocks for your provided outputs. Be kind and apply that in your posts.

We have rolled back our changes and followed the guide, now desktop never appears and instead the monitor keeps blinking repeatedly (as if it was changing resolutions over and over) while showing black screen. Sometimes the login screen appears for a split second before disappearing again.
We'll try to get the Xorg.0.log file by booting from USB and we'll post it here.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by