Trying to install Manjaro in Lenovo ideapad S145 with Windows [Solved]

Hi everybody,

I'm connected to the wifi. The machine specification from Lenovo:

  • Processor: Intel Celeron 4205U Dual Core Processor
  • Memory:4GB DDR4 2133 MHz RAM
  • Internal storage: 128GB SATA Solid State Drive
  • Graphics: Integrated Intel UHD Graphics 610
  • Optical Drive: None
  • Audio: 2 x 1.5W speakers with Dolby Audio
  • Battery life: Up to 6 Hours
  • Wireless: 802.11AC Wi-Fi and Bluetooth 4.1 Combo

From F2 I can get open the BIO with this information at:

Lenovo setup utility.

information>configuration>security>boot and click,

Boot Mode [UEFI] -- This line is very clear --
Fast Boot [Enabled]
USB Boot Enabled]
PXE Boot to Lan [Enabled]
IPV4 PXE first EFI [Enabled]

Window Boot manager (SAMSUNG M27LN128HAHQ-000 L2)

I was trying to 'turn off' Boot Mode and Fast Boot but I don't see how, I can get it, means there is not a clear option to me of how to do it in order to be able to boot the USB with Manjaro, windows comes back always.

Thanks for any help.

99% of lenovos skip to the boot menu if you press F12 when the logo is shown. (basically when it says "Press enter for custom boot" (or something similar) press F12 instead.

From F12

Boot Manager window opened …

Boot Option Menu

Windows Boot Manager (SAMSUNG …) --this line is very clear too --

then there are two arrows (up and down) Enter to select an Option.

I did it but nothing is happening, nothing move or change {I click at the space too to see if but …}

Go into Setup and make sure that the boot option for USB is enabled. You might have to google that to make sure where the option is for your model.

Boot option for USB is enable.

Sorry I didn't mention it before, I will fix it now ...

If I were able to move the option 'USB Boot' on top, means at the first place of this list in Lenovo setup … may be … bingo! but I don see how.

Maybe this help: i found at the page 'Security':

Secure Boot [Disable]
Secure Boot Status -Enable
Plataform Mode -User Mode
Secure Boot Mode -Standard

etc. etc

At Lenovo setup, in information:

Bios Version ASCN38WW
EC ASEC38WW
MTM 81MV00FFUS

Make sure "Secure boot" is disabled.

I don't think I understand, what the page at the BIO says is: [Disable] What do you means by to make sure that it is disable?. --Do you means the option 'status'?

Thanks

Well, yes, this output: Secure Boot Status -Enable seems to indicate it is still enabled.
No clue how your BIOS looks like, but usually you can navigate through the options with the arrow keys and then change individual settings with ENTER or + or so, etc.
Maybe you can take a photo of the screen...

Ok, it is disable now but window still coming back ...

-- yes, it is like you said I can navigate and change things like that, no I don't know how to take a photo.

@moson I found now something very interesting, if I connect the USB and with F12 go to the option BOOT MANAGER than this time i'm able to move the arrows up down … a new option appear at the page now:

EFI USB device -- Is it safe ... can I press enter an check if the USB boot …?

Well, yes, try it. That's the stick I guess.

Welcome to Manjaro Linux!!

But there is a problem: do not recognize the red (no access to internet).

Whatever "the red" means?! You should probably make a new thread for that.

sorry, means the network

You may have to "blacklist ideapad_laptop module" to get your wifi working.

Search those terms on the forum for instructions.

I can't get into the search at the forum (?).

Any way i found this at Lenovo forum:

https://forums.lenovo.com/t5/Lenovo-Yoga-Series-Notebooks/Wifi-is-hardware-disabled/td-p/1307405

This is what i got from Manjaro/Lenovo at the Terminal, coping by hand here:

[manjaro@manjaro ~]$ rfkill list
0:  ideapad_wlan:  Wireless LAN
Soft blocked: no
Hard blocked: no
1:  ideapad bluetooth: Bluetooth
soft blocked: yes
Hard blocked: no
2:  hci0: Bluetooth
soft blocked: yes
hard blocked: no
[manjaro@manjaro...$

And this is from another forum:

https://ubuntuforums.org/archive/index.php/t-2232757.html

I’m not sure if i can do what he recommended, this is what i got after ... coping by hand:

$ lsmod | greap idea
ideapad_laptop  24576 0
sparse_keymap  16384 1 ideapad_laptop
rfkill                   28672 5 bluetooh,ideapad_laptop
wmi                    36864 3 intel_wmi_thunderbolt,wmi_bmof, ideapad_laptop
i8072                  32768 1 ideapad_laptop
Manjaro@manj  $

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by