Trying to install Manjaro on external hdd with Legacy Hw (no UEFI) - Nvidia GTX 970

Hi guys, I'm new to Manjaro but pretty advanced in Linux Knowledge. I'm trying to install Manjaro on an external hdd, but it doesn't boot. The USB Installer was made in Rufus 3.8, and I noticed that it makes 3 partitisions on the USB, that Windows 10 detects as not formatted, EFI partition and not formatted; but the installer works. I tried to install Manjaro manually, by partitioning by myself and assigning the boot flags, and tried to install it via the erase disk option with the linuxswap with hibernation. The bootloader location is installed on the External HDD, but it doesn't boot when I select it from the Boot Menu.

I'm on a Legacy System, so no UEFI.

Thanks in advance!

:+1: Welcome to Manjaro! :+1:

As you're proficient with Linux, just asking for the info we need to help you further:

inxi --full --verbosity=7 --filter
sudo parted --list

:wink: :innocent:

1 Like

Your key was created just fine, it should have 3 partitions on it for UEFI. As for your boot problem you created a UEFI live key in Rufus when you should of created a MBR live key in Rufus since your bios is legacy / MBR. Since it looks like you are giving Manjaro the entire drive once you have your key created correctly once you get to the partitioning section of the install just choose that drive and let Manjaro setup the partitions, Hope that helps.

1 Like

You can of skip the encryption part - the guide is primarily targeted removal devices - how to install with hybrid boot.

  1. partition is a ISO9660 with a Linux filesystem - Windows cannot read other filesystems
  2. partition is EFI loader
  3. partittion is not really a partition - but the remaining space.

Rufus doesn't make change anything when I select the Manjaro ISO file and the default options seems OK for my system, since it locks down in MBR partition scheme and as target system BIOS or UEFI. Other solutions?

rufus

EDIT1:
I searched online, and the Wiki of Manjaro says that I have to select DD Image Mode when Rufus asks me what Image Mode I should use, but Rufus doesn't show me this option with the Manjaro ISO. I tried other Linux ISOs and all of them gives me the option between ISO and DD.

EDIT2:
Now I'm trying Win32 Disk Imager

Try Balena Etcher instead: That's our new standard here.
(also: multi-platform so even people having fruity-flavoured hardware can use it)

:innocent:

1 Like

Ok, I’ll try. I was starting another one time the Manjaro setup

@Fabby is right I should of suggested Etcher, forget that it seems the latest Rufus has issues dealing with Manjaro cause it won't give the DD option. Now that said once you do get your key made and you attempt to boot from it please make sure you do not select the UEFI version to try to boot into. Like in my case once I reboot and open the boot menu or use the bios settings i would select UEFI Kingston Data Traveler not the Kingston Data Traveler cause my motherboard is UEFI not MBR. In your case Kingston Data Traveler would be selected and not the UEFI Kingston Data Traveler.

Ok, just finished to installation process with this configuration and it still doesn’t boot. Ubuntu work fine on this machine, why not Manjaro?

image

I used Balena Etcher, the USB was created successfully, but the installation is still a problem. I thought this solution:
Install Ubuntu and its Bootloader that works fine on my machine, replace Ubuntu with Manjaro

Did you select the drive and then let the installer decide the partitions to create?

Check my post just before your last screenshot.

I checked and the only info that my BIOS is showing is the name of the USB drive, no signs of UEFI

Ubuntu/Debian/Fedora/OpenSuse supports Secure Boot while Manajro doesn't. Did you disable Secure Boot?
Also try making the very first partition of the disk the root ('/') partition with "boot" flag in case of Legacy+MBR installation. And make sure GRUB is installed in that disk. (sdi not sdi1).

2 Likes

I tried automatic and manual installation, but the results are the same

that's pretty much what I figured being legacy only. The board is legacy so I don't believe you have secure boot, but it's been so long since I dealt with legacy I can't swear to that.

Please read this again:

We're still missing valuable info so we are taking shots in the dark now (ipotesi azzardata).

Please? (Per piacere!)

:unicorn: :unicorn: :unicorn:
:rainbow: :rainbow: :rainbow:
:innocent: :stuck_out_tongue_winking_eye: :crazy_face:

1 Like

If the installation process finishes but then fails to boot, you could boot using usb then try os-prober.

Ok, so I have to write them in the Terminal from the USB right?

2 Likes

Forum kindly sponsored by