Trying to install Manjaro on external hdd with Legacy Hw (no UEFI) - Nvidia GTX 970

Great. Good luck.

1 Like

Old Nvidia cards are not exactly the best hardware to run a rolling release distro on. I'd stick with Ubuntu LTS or its derivatives.

I mean it can be fixed, but I'm not the expert on this particular type of hardware. I will add a tag and update your topic. Maybe an expert will show up.

Try also forum search:

Edit: But somehow it resolved without any fixing.

I turned off the machine and now I’m stuck at this. I can type whatever I want. This appena when entering in command-like mode by pressed F12


Just asking. Have you unplugged the external hdd before this boot?
Your topic title says Manjaro is on external HDD. Confirm it is external and removable.

Yes it is removable, but I didn’t remove it before or after turning off the machine

okay, noted. I'm staying out for now. The rest seems quite involved. Don't need me.

Oh... before you unplug that removable and boot without it,
Suggest you do again the 'grub-install' command with a "--removable" in the command.
ps: Since it is msdos/bios-legacy, choose that " /dev/sdx" carefully, but I think you know that.
Just a reminder then.


Thanks for the advice, since as soon as the SATA cable comes, I will insert into the case


I'm running a 750 Ti and other than a recent issue with the 5.6 RC1 and Rc2 kernels it's worked like a champ.

  • Boot the USB again, but don't install!

  • Go to a terminal by pressing Ctrl+Alt+T and execute:

    sudo mkdir /media/viksn0w
    sudo mount /dev/sdh2 /media/viksn0w
    sudo nano /media/viksn0w/boot/grub/grub.cfg

Ignore the warning not to change this file on the second line and search (Ctrl+W) for quiet and splash and remove all the occurrences without disturbing any other text.

  • Save Ctrl+X YEnter
    (or maybe S Enterin Italian)
  • sudo shutdown --halt now
  • Remove USB stick
  • Reboot

Take another picture.

(This will not solve your issue: it will just allow us to see where in the boot process the machine gets stuck.)

P.S. Food on stove so my responses will be intermittent...


It doesn’t boot in text mode even with the live usb stick!

Ok I boot the usb live and opened the terminal but when exciting the first command it says cannot create folder no such file or directory

sudo mkdir /mnt/viksn0w
sudo mount /dev/sdh2 /mnt/viksn0w
sudo nano /mnt/viksn0w/boot/grub/grub.cfg

It says no such file

What's the output of the mount command?

My apologies: I've never had to do this on Manjaro before...

Don’t worry, if the installation is going over like this, I will switch to Ubuntu. It’s not your fault. Btw the output is nothing, just display a new line for input and nothing else

I just switched from Ubuntu to Manjaro because Ubuntu is going down the drain...
OK, follow this one and stop at 6 and ping me.

I tried to boot into windows 10 and I realized that Manjaro installed grub also on that drive

That confirms one of my suspicions: You seem to have a grub issue and we need better coordination to get everything back up...

(the other being nVidia driver)

so chroot into the current environment and provide:

sudo lsblk
sudo gdisk -l /dev/sda

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by