Tutorial: How to enable system-wide color emoji support

1. Install noto-fonts-emoji

How to do it using the terminal? Click to expand.

sudo pacman -S noto-fonts-emoji

2. Create /etc/fonts/local.conf with the following content:

How to do it using the terminal? Click to expand.
  • Copy the following file.
  • sudo cat > /etc/fonts/local.conf
  • Paste it using Ctrl+Shift+V
  • Ctrl+D
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>

 <alias>
   <family>sans-serif</family>
   <prefer>
     <family>Noto Sans</family>
     <family>Noto Color Emoji</family>
     <family>Noto Emoji</family>
     <family>DejaVu Sans</family>
   </prefer> 
 </alias>

 <alias>
   <family>serif</family>
   <prefer>
     <family>Noto Serif</family>
     <family>Noto Color Emoji</family>
     <family>Noto Emoji</family>
     <family>DejaVu Serif</family>
   </prefer>
 </alias>

 <alias>
  <family>monospace</family>
  <prefer>
    <family>Noto Mono</family>
    <family>Noto Color Emoji</family>
    <family>Noto Emoji</family>
   </prefer>
 </alias>

</fontconfig>

This will change your default fonts to Noto, you can customize it if you want.

3. Change display font in the settings

Go to your settings or configuration tool and change the font to "Sans Serif". This will use the configuration we've just created so apps can show emoji.

12 Likes

I moved this to tutorials since, well, that's what it is. :wink:

1 Like

Just would like to add something here:

  1. You can set such change for current user only by putting the config in ~/.config/fontconfig/fonts.conf. This does not require root privileges.
  2. This works only under gtk apps. Support for color emoji got shipped with GTK+ 3.92 (and the corresponding gnome 3.26). For Qt/KDE apps we have another emoji framework for this.
  3. Google changed the design of emoji from "blob-like" to more rounded design.

Twemoji, the SUPERIOR emoji set, also works if you install ttf-twemoji (NOT ttf-twemoji-color, which doesn't work) and change the font from

"Noto Color Emoji"/"Noto Emoji"

to

"Twemoji"

in /etc/fonts/local.conf:
twemoji

2 Likes

Forum kindly sponsored by