Tutorial: How to magically fix most computers that will not boot after a manjaro update!

Hello fellow Manjaro peoples!

Recently I have seen a lot of panicking because update XX/XX/XX broke their system, and now they get something like Error: Cannot access tty. You have been dropped to an emergency shell.Or Job control turned off: You are on your own. Good luck!

There is nothing to worry about, and you should be up in about 15-20 minutes!

Here is how.

Step 1. Find, or prepare a Manjaro bootable medium (USB, DVD (etc.))

Step 2. Go into your BIOS, and set your computer to boot from the medium.

Step 3. Boot into the live environment. Exactly how you did when you installed Manjaro.

Step 4. Launch a terminal or Konsole (for KDE users)

Step 5. For non BTRFS users: Type manjaro-chroot -a

Step 5. For BTRFS users: Read the steps at the bottom of this tutorial, then proceed to step 6

Step 6. Type Sudo pacman -Syyuu Into the terminal

Step 7. When that finishes, type sudo update-grub

Step 8. Upon completion of that, type exit

Step 9. Reboot you computer

Step 10. Your installation is saved!

———Step 5 for those who use BTRFS———

Step 5a. Launch gparted, or KDE partition manager, and identify which drives you use for you partitions (You may only have one)

Step 5b. Find the drive identifier. It will look start with /dev /dev/sd(x), /dev/nvme0 Or /dev/Mmcblk0 are examples.

Step 5b. Mount you root partition with sudo mount /dev/(indentifier) /mnt(ex.)Mount /dev/sda1 /mnt

Step 5c. Mount all other partitions at their subsequent mount points but instead of /mnt/mountpoint, you will have to use /mnt/@/“mountpoint” so for an example home partition, you would use mount /dev/sda2 /mnt/@/home

Step 5d. Type manjaro-chroot /mnt

—Continue on to step 6.—

:warning:Notice: If you are using an encrypted volume (Luks) partition for the root in your Manjaro system, DO NOT use this tutorial as I have not included how to chroot into this configuration. I may in the future, but not now.

Well, I hope this helps someone. Be sure to leave comments with any questions or issues. :slight_smile: Peace out!:v:

Manjaro doesn't load after GRUB
Broke my Manjaro installation... again
Kernel issues, not boot device
Manjaro not booting up after update. Shows failed to load kernel modules as the only error
Manjaro don't start
System froze, now it won't boot
Latest update broke my system
Kernel Panic Boot error: switch_root failed to execute /sbin/init: exec format error
Kernel Panic Boot error: switch_root failed to execute /sbin/init: exec format error
Dropped into emergency shell without keyboard access due to a failed hibernation
Latest update broke my system: Can't get into TTY
System won't boot after update Error hibernation device
Due to incorrect shutdown manjaro can't boot
Manjaro doesn't boot after update
mount: /usr/lib/libmount.so.1:version `MOUNT_23.4` not found
Stuck at boot screen after update
Infamous 19/2 update broke my system, what to do?
Can't boot after last upgrade
I seem to have broken my system
System crash, cannot reboot
How to install Manjaro on a 32 bit efi / 64 bit cpu system
manjaro gnome ed qualcosa è andato storto
Mhwd-chroot - I must be doing something wrong?
Can't boot after dist update
Gnome black screen after installing Nvidia Proprietary drivers + Prime
Why do I have to update python, ms fonts, kernel, etc just to install oracle xe?
Is it possible to install the open source drivers for an AMD GPU from live environment?
sh: can’t access tty: job control turned off
I broke my Manjaro
Boot problem
[Stable Update] 2019-04-28 - Gcc, Systemd, Kernels, Virtualbox, Qt5, Deepin
Manjaro deepin update is causing black screen on my laptop
Black screen since installing driver though manjaro-settings-manager
Manjaro broken after update
Manjaro deepin update is causing black screen on my laptop
GLIBC not found kernel panic
Can’t login libread so 7 error
After update not starting
Problems installing Manjaro on an SSD that previously had a different distro
Broken Manjaro after removing gtk3-classic
I updated kernel to Manjaro wouldn't start
No grub, WIN starts right away without option of choosing Manjaro
Manjaro won’t boot anymore
Manjaro won’t boot anymore
Kernel Panic, System not booting
[Closed] Kernel Panic -> manjaro-chroot -a -> Exec format error
Laptop Freezes at Login Screen, Manjaro, Keyboard and mouse also doesn't work
failed to load kernel modules and unable to boot
Crash during update
boot problem2
Screens are blinking
Issues after power outage
Manjaro won't boot after installing slack-desktop
[SOLVED]Interrupted update, system would not boot
Manjaro not working properly after update [solved!]
[SOLVED] Borked 4.20 kernel?
Manjaro goes black screen on boot up
System will not boot to desktop. Hibernation device not found
[SOLVED] Boot fails after recent update w/ libidn2 not found error
Not able to start Manjaro linux
problem w/ latest update on KDE

You clearly did say drive, so my question is hopefully silly, but just to double-check my understanding...

I assume your warning does not apply, & hence your tutorial does apply, for Manjaroos with a LUKS-encrypted /home partition but straight standard vanilla ext4 / partition?

How to check if it is a BTRFS user?

Open gparted, and look for the partition you use as /. If it says "BTRFS," then you are using a btrfs system.

Thank you for this tutorial.

I do not know how to deal with encrypted drives at this time, so your answer would be no... I may update this to support encrypted drives in the future. I clarified the notice.

Oh, ta. OK, i shall create a LUKS-/home ext4-/ VM then try out your tute on it & discover if i break it or not. Live & learn, also... muhahahaha.

Will do it tomorrow & reply then. Tonight, now, tis cuppa, puddin' & NF time.

1 Like

Oh no :anguished:

I think reasonable disclaimers are needed. This will not magically fix any computer. It will probably fix situations related to interruption of a system update that would have resulted in a working system.

It probably won't fix many other problems, some user-created, some not, where that same error message is printed. For instance, it won't fix a situation where a user is explicitly holding packages that create a non-working system (I've done this).

And there are at least 2 other tutorials just like this. If you've improved upon these older tutorials in some way, you should say so to differentiate this tutorial from those others (such as choice of using -Syyuu switch).


I feel like mine is easier to follow... It can't hurt to have more than one, can it? Some people will agree. Others won't. That's why we give them choice about what to use. Linux is all about user choice. Isn't it?

No it can't hurt too much I suppose, but you already added the btrfs commands as a comment to one of the other tutorials, so I don't see what this tutorial really adds to the forum. I agree this tutorial is easier to follow because it uses manjaro-chroot at the start whereas the other tutorials use mhwd-chroot or the constituent commands and someone has to read further down to find out manjaro-chroot can do those steps automatically. But those other tutorials are more comprehensive as a result.

Maybe I'm making too big a deal of this. And I don't want to discourage your efforts. You actually helped me understand the chroot topic better because I ended up reading 3 chroot tutorials carefully now :smile: . But this tutorial in the bigger picture seems unnecessary at best. At worst, it dilutes information and discussion. Because users have already commented on other tutorials, they're unlikely to comment again on this new tutorial.

I understand your points; they are objectively fine. That said, personally i do really like @SlayerProof32's tute -- at least for a numpty like me, it floats my boat.


Sorry, i still have not had time for this, but haven't forgotten. Maybe next weekend i'll get the chance [i _really do_ want to know the outcome].

Well, i have now tested it in my manjaro-kde-18.0.4-rc-testing-x86_64.iso VM, setup as:

[kdemeoz@manjaroKDEtestingVM ~]$ lsblk
NAME                                          MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda                                             8:0    0    22G  0 disk  
├─sda1                                          8:1    0   550M  0 part  /boot/efi
├─sda2                                          8:2    0    18G  0 part  /
└─sda3                                          8:3    0   3.5G  0 part  
  └─luks-21a90b78-6c1c-4b78-8014-9387e7414523 254:0    0   3.5G  0 crypt /home
sr0                                            11:0    1  1024M  0 rom   
zram0                                         253:0    0 199.3M  0 disk  [SWAP]
zram1                                         253:1    0 199.3M  0 disk  [SWAP]
[kdemeoz@manjaroKDEtestingVM ~]$ 

...& exactly as i'd imagined beforehand, your tute remains perfectly fine IMO for that lsblk arrangement... IF the user's objective is simply to unbork a borked system after an interrupted or bad system update. I don't see any surprise there, given it's only the /home that's encrypted, not the entire drive. Obviously for other Manjaroos with full drive encryption, additional/different steps are needed... way above my head.

I continue to really like your tute, & thank you for it.

So my guide works for systems with an encrypted /home only. Not ones with encrypted/ and /home?

It works fine, based on my own tests, for systems with:

  1. No encryption at all.
  2. Encryption limited only to /home partition.

I have not tested for:
3. Full-disk LVM LUKS [as i have never used it & have no interest in it].
4. LUKS-/ & LUKS-/home partitions [as i have never used it & have no interest in it].

I intuit though that your tute, as currently written, likely cannot work for #3 & #4, given by definition there can't be access to the / partition before it is somehow decrypted & mounted from within the chroot environment, which as i intimated, is way above my head [aka, damned if i know how to do that!]. :grinning:

1 Like

I recently did an update & decided to reboot, after that the screen res was off? so I tried my older kernel & it just goes to a black screen after grub? So I tried this fix & still nothing on both kernels? I'm running LXDE 18 for almost 2 yrs until now.

It's not really fair or proper IMO to hijack a Tutorial thread into a personal troubleshooting one. Why not instead begin your own thread for that, & then when you describe the problem & supply your specs, you can link to here when you indicate you have tried this?


So sorry

Forum kindly sponsored by