Twas a rough old night, last night.

Yeah, nah. She’ll be right. :crazy_face:


Whack o' the diddle dee oh then, bring on tomorrow!

1 Like

I'm temporarily trolling my own thread here.

In FF/FF-Dev one of my AOs is VTZilla, whilst in my chromium-based browsers it's VirusTotal. In recent weeks [/months?] these seem to have significantly decreased in efficacy; i keep trying to test links that fail to be tested, resulting in [FF]:

The page you navigated to does not exist

The page you were looking for is out of reach.

...& in [Chromium]:

Item not found
Are you looking for advanced malware searching capabilities?

Those two useless results above arose from the Asia server link on that page.

Once these kinds of failures were rare, but lately they seem commonplace for me.

It's your no end to the surprises tower. Consider yourself lucky it isn't delivering spine tingling shocks instead of a simple 404 error.

Well, hello from Z97HD3.10c... & from my second boot Fedora 30.

Tis the worster.

She ain't, not yet, but i'm nonetheless really grateful to you, @Sinister & @tbg for successfully getting me this far already. I'm so enthused now with Q-Flashing my Tower, that soon i shall go & upgrade my toaster, my microwave, the dishwasher, & the budgie [but i'm not touching the deepin. Try the fish, i'm here til Thurs] :crazy_face:

Just like that referenced post [SOLVED] Grub rescue after updating BIOS, since the post-BIOS-update [successful] reboot/s, i end up in the grub rescue screen [shudder]. Unlike said post however, nothing i have tried succeeds in getting me back into Manjaro, ie, including choosing it from within the BIOS boot list. Each attempt results in an angry screen of error messages [which vary, depending on which option i tried]. Otoh, getting into my secondary distro still succeeds, hence i'm using F30 atm.

I assume, given the above, that my necessary course of action now needs to be to LiveUSB boot into my Manjaro ISO, & therein do the usual chroot business, within which i can then run the famous @gohlip commands per [SOLVED] Grub rescue after updating BIOS ?

Am valiantly fighting off the rising sensation of nausea & panic in my belly atm. :crazy_face:

1 Like

Try this [Simple First Start] and if after you boot in, do the 2 [UEFI - additional commands]. You will be okay.

ps: there's no need to chroot or even boot up to liveOS.


And... at grub rescue prompt, you can still boot into installed OS manjaro. But I think above is far easier. Just in case, here's how....

grub rescue> ls
grub rescue> set prefix=(hdx,y)/boot/grub
grub rescue> set root=(hdx,y)
grub rescue> insmod normal
grub rescue> normal

note: the first command 'ls' is for you to determine your installed OS is (hdx,y); then continue using the right (hdx,y).

The last command should boot into manjaro OS, If it don't, it should get to the normal grub prompt (grub> ) not grub rescue prompt (grub rescue> ). If so continue...

grub> configfile /boot/grub/grub.cfg

and you will get to the grub menu. Boot into OS.
If not, see the link above and use the [More Complicated Setup] to boot into it. but I think in your case, you don't need to do that.

In all cases, do the 2 UEFI commands after you boot into manjaro installed OS.

Oh, after fixing all, and just for my info, at grub prompt (press 'c') what's output of
grub> echo $cmdpath

I suspect path shows efi/boot/bootx64.efi not /efi/manjaro/grubx64.efi
I just want to confirm that is your case.
Again, reiterate you don't have to worry about this. Just for my info. Thanks.

ps: I've not got into grub rescue for years (at least 7 years).
But I think that should work. :crossed_fingers:

1 Like

Thank you... but OMZ!! :exploding_head:

Am making a coffee. to then re-read all your procedure/s. My head is spinning.

It occurs to me that this BIOS update has definitely achieved its hoped-for goal... there's sure no way in hell now that the lovely grub rescue screen is gonna annoy me with any of those pesky random freezes -- success! :crazy_face:


I'm still in F30 atm, still with coffee, still reading, still trying to understand. For the interests of clarity & hopefully no musunderstandings, fyi:

[kdemeoz@Fedora30-Tower ~]$ lsblk
NAME                                          MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda                                             8:0    0 232.9G  0 disk  
├─sda1                                          8:1    0   156M  0 part  
├─sda2                                          8:2    0    60G  0 part  
├─sda3                                          8:3    0   102G  0 part  
│ └─luks-7106d77d-ce05-4059-87fc-9f6de535b652 253:2    0   102G  0 crypt /run/media/kdemeoz/b539574d-c9d8-4f5c-8bfd-ea7e6ad81517
├─sda4                                          8:4    0     2G  0 part  
└─sda5                                          8:5    0    60G  0 part  
  └─veracrypt7                                253:1    0    60G  0 dm    /media/veracrypt7
sdb                                             8:16   0   1.8T  0 disk  
├─sdb1                                          8:17   0    35G  0 part  /
├─sdb2                                          8:18   0    40G  0 part  /SeagateSpare
├─sdb3                                          8:19   0   1.7T  0 part  /Seagate
└─sdb4                                          8:20   0    35G  0 part  
  └─luks-f78ef307-e584-49da-bf4b-152077dd85dc 253:0    0    35G  0 crypt /home
sr0                                            11:0    1  1024M  0 rom   
[kdemeoz@Fedora30-Tower ~]$ 

sda1 = my Manjaro /boot/efi partition as best i recall.
sda2 = my Manjaro / partition.
sda3 = my Manjaro /home LUKS partition.

Please, i can't follow this part without ambiguity... there seems to be multiple "Step 4" 's or 4. there. For my certainty, pls could you hereafter paste the explicit additional commands you want me to do, so i then can't possibly use the wrong ones.

This is the part i understand so far:

1. boot up livecd in the right mode, uefi or bios-legacy
2. Do not boot up to live OS, but press ‘c’ at the menu and we’ll get to the grub prompt (grub>).
3. Do:
        grub> search.file /etc/manjaro-release  root
        grub> configfile /boot/grub/grub.cfg
4. When booted, do:
        sudo grub-install /dev/sda
        sudo update-grub

Aha, maybe these?

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

First, a caveat. I do not use encryption nor luks.
It is far more difficult to boot into these as the UUID's are not the raw UUID's nor the simple device mapping. Later on, I'll recommend all using luks and encryption to have a backup boot config file in cases for these.

But to answer the 2 additional uefi commands, the first command is pretty straightforward.

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi

The second... in the case of /boot/efi $esp in sda1 is

sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

In the link I wrote..

Note the second command above is for $esp in sda1.
Change accordingly if it is not. This command " findmnt /boot/efi " will confirm the $esp partition.
So if $esp is sdb3 or if $esp is /dev/nvme0n1p2 , the respective commands are

sudo efibootmgr -c -d /dev/sdb -p 3 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"
sudo efibootmgr -c -d /dev/nvme0n1 -p 2 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

Hope this is clear. Check with command

findmnt /boot/efi

That will display the /boot/efi partition mapping (again in luks and encryption, that may differ).

The main thing is to be able to boot into installed Manjaro OS.

Oh... here's how to set up a backup grub.

But always include a current working grub (that is in the separate section) in the case for encryption and luks system.

Again I stress I do not use luks and encryption. But good luck.
There's one link somewhere where we made progress but the OP did not finish the 'experiment. I think Test F should work out. I'll supply the link later here after I searched for it.



Many thanks! Have Lappy next to Tower so i can follow these steps, so am now about to reboot Tower using LiveUSB & press c etc.

Who me, petrified? Nah... um, yeah. :upside_down_face:

1 Like

Hello again, from back inside Manjaro... MY Manjaro, not the LiveUSB one.

Dear @gohlip, your grub & booting [etc] wizardry is astoundingly fabulously wondrous!

The story so far...

  1. boot up livecd in the right mode, uefi or bios-legacy
  2. Do not boot up to live OS, but press ‘c’ at the menu and we’ll get to the grub prompt (grub>).
  3. Do:
    grub> search.file /etc/manjaro-release root
    grub> configfile /boot/grub/grub.cfg
  4. When booted, do as per the following codebox:
[kdemeoz@GA-Z97-HD3-Tower ~]$ sudo grub-install /dev/sda
[sudo] password for kdemeoz: 
Installing for x86_64-efi platform.
Installation finished. No error reported.

[kdemeoz@GA-Z97-HD3-Tower ~]$ sudo update-grub
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.1-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.1-x86_64.img
Found initrd fallback image: /boot/initramfs-5.1-x86_64-fallback.img
Found linux image: /boot/vmlinuz-4.19-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.19-x86_64.img
Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img
Found linux image: /boot/vmlinuz-4.14-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
grub-probe: error: cannot find a GRUB drive for /dev/sdc1.  Check your
Found Fedora 30 (Workstation Edition) on /dev/sdb1
Found memtest86+ image: /boot/memtest86+/memtest.bin

[kdemeoz@GA-Z97-HD3-Tower ~]$ sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
[sudo] password for kdemeoz: 
[kdemeoz@GA-Z97-HD3-Tower ~]$ 

[kdemeoz@GA-Z97-HD3-Tower ~]$ findmnt /boot/efi
/boot/efi /dev/sda1 vfat   rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro

[kdemeoz@GA-Z97-HD3-Tower ~]$ sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"
efibootmgr: ** Warning ** : Boot0000 has same label manjaro
BootCurrent: 0007
Timeout: 1 seconds
BootOrder: 0002,0000,0001,0007,0003,0005,0006,0008
Boot0000* manjaro
Boot0001* UEFI OS
Boot0005* Samsung SSD 850 EVO 250GB
Boot0006* ST2000DM001-1ER164
Boot0007* UEFI: Generic Flash Disk 8.07
Boot0008* Generic Flash Disk 8.07
Boot0002* manjaro
[kdemeoz@GA-Z97-HD3-Tower ~]$ 

Unless there's another step/s i have neglected, i am just about to do the final(?) reboot. I'll wait 10' or so in case there's still anyone around, & who sees some new ghastly stuff-up i've made in any of the above code.

Looks good. Reboot away.

but... uhm... good luck? :joy:


Tis all hunky-dory, tickety-boo, ripper, grouse, & very noice... tis so good to be home again. Really there's no place like home, Toto.

Had to take a minor detour back into my BIOS Setup after that last reboot, coz in doing the flashing, one of the old settings lost was my BIOS boot lock, so i needed to reapply that. Thence, with the next boot, the lock was back, the perfect Manjaro grub menu [offering me the various Manjaro & Fedora kernels] was back, & it all works ... yabber dabber doooooo.

Here's hoping that i lost my poultrygoose somewhere back in the chicanes of the last few hours.

To all you lubbly lubbly helpful Manjaroos -- thank you so much!

My new major problem is how to mark this thread Solved, because several of you are owed the rights to that.


Glad you got it back up and running, @gohlip is truely the master of grub issues.

It’s not solved yet, needs at least a week, maybe two, of stable running before you could possibly claim it a fix.

1 Like

I wouldn't take the exorcist off speed dial just yet. :smile:


Always good to hear and you're welcome.

哪里哪里. (where where) :smile:


Yes, i'm nutty, i was sooooo blooody relieved to survive-with-help this BIOS-update process with its "fun" aftermath, that in my subsequent mindless gushing i forgot the OP of this thread, & unwisely wrote my preceding post as if the thread had been about only how to flash a new BIOS. Probably at this point i need a Tia Maria.

Yes totally agree, & indeed the fact i was so silly as to express momentary optimism, truly condemns me to an impending new round of PG'ing for sure.

If that does occur [aaaarrrggghhhh], the next step will need to be to stop avoiding those RAM tests. Geez it'd be nice just to use this box & never have to worry about that damn PG,

Ahh, look at it this way you'll never be bored as long as you own that tower. Besides look at all the stuff you've learned because of it. Hmmm ... maybe it's not so evil after all.

1 Like

Forum kindly sponsored by