UEFI: Manjaro is missing

Well it has Windows 10 on it (it's a new machine and I still need it), but this has to be a problem with the implementation in the bios. I say this because I just installed rEFInd to see what would happen.

Like Manjaro's grub, Manjaro's rEFInd doesn't show up as an option in the bios either. So my modus operandi now to investigate matters is to boot into my manjaro-i3 install disk, select "Detect EFI bootloaders," and see what shows up. Not surpringly at this point, I see all of the entries I put in before - my "fake" Red Hat Enterprise" manjaro efi, my standard Manjaro EFI, and now I see my rEFInd EFI as well.

I can, incidentally, choose rEFInd and am presented with their boot manager, and it's working without a hitch.

I also assume it will pick up 'manjaro' (grub efi file) and boot that as well.
From the install menu, this or that should also work.

If you really want to, we can work out a bootable usb stick or sd card where it will have a boot menu and boot whatever things in your hard drive. But it's a lot of work.

I got it working.

I think this all boils down to manjaro not being part of my bios' whitelist of supported operating systems. So taking a hint from that earlier post of mine, where I named the manjaro entry "red hat enterprise linux," I decided to try the same, this time naming it "ubuntu":

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Ubuntu --recheck --debug

So guess what, I now have an entry for ubuntu grub, which is actually the manjaro grub installer. I've successfully tried it 4-5 times now, booting into all OS's without a hitch.

I completely understand the need for security at the most basic level, but this "whitelist" may be a bit of overkill if it can't be disabled physically when entering the bios. Talk about going against the principle of 'free software', or am I being preachy??

1 Like

Good. Do please tell us what computer this is so we all can avoid touching it with a 10 m pole.
And where do you get this whitelist ? What command will show this?
How does that compare with .. ?

ps: it may still be a 'space' issue as reusing the same bootentry name like 'ubuntu' will not take up additional space in your bios memory. But you did clear up the other bootentries, right/
efibootmgr -b xxxx -B

It worked here.

I'm not convinced myself now that I've had a few hours of sleep. I have only seen one mention of this so-called whitelist of OS's in the following blog:

I'm going to go back to check out the efibootmgr -v output to see what's going on. Perhaps I never updated the order of the efi list, and the bios can only handle so many choices. Stay tuned.

As an FYI it's a yoga 720. Got it for a steal from a guy here in Phoenix who bought a bunch from his company. Incidentally the i3 install is doing what it took me 3 full days to figure out with Mint's i3 install. Lid/sleep, sound and brightness buttons all work out of the box, as does compton and conky. Nice.

Ok everything is working and looking as expected. I'm sure some of what I did was a bit reckless but as there was nothing (yet) of import on this computer, and I had a Windows recovery USB stick at the ready, I really didn't care too much.

gohlip - a HUGE thanks for all of your assistance. You've been invaluable in helping me out here!

I still don't know what the cause of my problems were but it may have been the limit on the number of EFI bootloaders my bios allows as you and others suggested, some problems in naming conventions, or a host of other things.

Ultimately I had quite a few directories in /boot/efi/EFI due to my many attempts to get things going. Using efibootmgr -b (entrynumber) -B I first deleted what I thought was an unneeded entry, followed by physically removing the directory itself from /boot/efi/EFI.

I had two manjaro EFI directories. One was named Manjaro, the other "manjaro" (quotes included)! I planned on removing both of them and re-running grub-install, but instead removed the Manjaro directory and renamed the "manjaro" directory to manjaro. This seemed to do the trick.

My remaining ubuntu grub was actually just another instance of manjaro - I must have deleted Mint's grub by accident at some point.

At this point, my bios now only shows two choices for bootloader - Windows and manjaro. That's good indeed.

One thing I noticed was that, with all of these options, the bios seemed to re-order the bootloaders, despite running efibootmgr -o 0002,0001,0005 etc. So it's possible that all the work we did last night was somehow preempted by the bios. Again this may be due to the sheer number of entries. At one point I had:
1xmanjaro
2x fake manjaros
1xLinux Mint
1x Windows
1x Windows recovery
1x rEFInd

I think the next question is what happens when I update the kernel ;-D

Again, appreciate the help all. Hope my steps and missteps help someone out.

Good & happy to hear you've got it working and you're welcome.
In some Lenovo's, it is important to do this after the grub-install command

Cheers, take care.

Ok so now it's not working. I'm too tired to put all details so I'll summarize.
Attached cd drive to use gparted/debian cd. deleted Mint partition and grew Manjaro partition. No errors or problems.

Unplugged drive from USB and rebooted. Manjaro's grub went missing again!

After numerous attempts at messing with efibootmgr, reordering efi load order, doing grub-install etc., I still don't have it. I think what's happening is that, when I plug in the SATA drive to the USB and enter the bios (so that I may boot from it), the bios does it's own rewriting of the possible boot entries, erasing all my work. So it's a bit of an endless loop there as far as I can tell. Will be playing some more. Stay tuned.

Just booted in. Executed the following:

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=ubuntu --recheck --debug

And voila, I have a grub back! Doesn't this mean my bios is ignoring certain entries, and accepting others?

Wait a minute....
Is your hard drive an external usb drive?

Then you will need to put a '--removable' in your grub-install command.

Otherwise when you pull it out it will be lost.
Also even with the '--removable' included, you may need to go to boot set up (F12) to select it after you have pulled it off and plugged it in.

Ah... that explains it. An external sata drive. Geez. All this time. :stuck_out_tongue_closed_eyes:

-- removable that's " - and - together, no space". 2 '-'.

1 Like

No no no. CD drive is external. I have to use it when I lose my bootloader so that I can boot from the live CD.

WHen I can no longer get to grub, what I do is boot from the live cd. WHen I get to the Manjaro CD boot screen I select "Detect EFI Devices," which does a wonderful job (compared to my bios!) of finding a kernel on hd (0,1) /boot/manjaro from which to boot.

The moment I select it, and start loading from the hard drive (I usually see soemething like version 237) I yank the CD drive from the USB port in hopes of it not being seen by manjaro. However, it doesn't make a difference, my efibootmgr -v output is monstrous, including multiple entries for the USB CD driv.

I'm not messing with you - I do the grub-install command and name it manjaro and it doesn't stick with my bios. I name it ubuntu and it's there for life. I posted to the lenovo forums to see if they can lend any insight into what's going on.

I suppose the next experiment is to plug that drive back in to see what happens to my ubuntu grub. I'm a bit frightened to do so.

Well, ok. Got it.

There's a few on Lenovo here and having boot problems of some kind.
Cheers.

@Crimguy/gohlip:
I don't know if this would help or fix the issue Crim is having but I contacted Lenovo tech support via online chat. The tech was only partially helpful. She would only tell me how to access the BIOS via the Novo button but would not go into details on how to disable secure boot. She said that it was outside of their realm of their support and she didn't want to get into trouble. So next I tried a bit of Google-Fu and Youtube-Tai Chi. I found a youtube video for setting up dual boot Win 10/Fedora on a Yoga 910 laptop. The narrator in the video says that the system is very finnicky. The info in the video might prove helpful.

Setting up Dual Boot on the Yoga 910 with Fedora and Windows
URL = https://www.youtube.com/watch?v=X2duO89XT_Q

You might have to do a full system restore and start from the beginning so that nothing present interferes. However, that is totally up to your discretion. If you do decide to go with the full system restore method, I suggest that you take pics of your BIOS/EFI setttings at their defaults and post them an online pic. site such as imgur.com.

Chat transcript:

Janie: Hi, welcome to Lenovo Chat Services, I'm Janie. I'll be your Lenovo technician today.
Janie: I am sorry that you had to contact us today. Before we proceed, may I please have your shipping address and if you have an alternate phone number
for documentation purposes???
Ghoul Tek: Hello janie
Ghoul Tek: I would rather not give those out
Ghoul Tek: I'm trying to help a friend who is in another state.
Ghoul Tek: I'm in New Jersey, US
Ghoul Tek: He is in Arizon
Ghoul Tek: His parent's got him a Yoga 720 laptop
Ghoul Tek: He is trying to install Manjaro Linux on it, but after the install completes the OS is not available for him to boot
Ghoul Tek: I suspect that secure boot is preventing him from booting up the Linux install
Ghoul Tek: How do we disable secure boot in the BIOS?
Janie: I am sorry. Third party operating system is beyond our scope of support.
Ghoul Tek: I understand that
Ghoul Tek: that is why I'm looking to find out how to disable secure boot in the BIOS
Ghoul Tek: I believe once that is turned off he will be able to boot the Linux partition
Ghoul Tek: so the issue isn't a 3rd party OS problem its the secure boot feature in the BIOS
Ghoul Tek: Janie are still there?
Janie: I understand. The answer to you question can be found on the BIOS.
Janie: Do you know how to get to the BIOS?
Ghoul Tek: No. Is there a document with instructions on how to disable secure boot in the BIOS?
Janie: I can give you the steps to get to BIOS.
Ghoul Tek: Awesome... thank you
Janie: May I please have the serial number of your machine?
Ghoul Tek: I don't have the laptop with me
Janie: Oh
Ghoul Tek: and he didn't send that too me in his email message
Janie: Here are the steps to get to BIOS.
Janie: 1. Turn off the laptop completely.
Janie: 2. Look for a pinhole that looks like an inverted arrow or horseshoe. It is beside the power button or audio jack. Sometimes beside the dc in jack/port. Insert a paperclip on the pin hole once you find it. Machine will turn on and you will see Novo Butoon Menu. Select BIOS Setup.
Janie: That is the step to get to BIOS.
Janie: Is there anything else I may help you with?
Ghoul Tek: Ok once in BIOS how do I disable the secure boot?
Janie: We do not support that.
Janie: You can navigate the BIOS.
Ghoul Tek: is the secure boot accessible via a menu in the BIOS?
Janie: We do not support changing settings on the BIOS to install 2rd party OS. You can navigate the menu on the BIOS.
Ghoul Tek: Ok I understand you dont support it but I just need to know how to get to the secure boot to turn it off.
Ghoul Tek: I'm just trying to help him complete one of his engineering projects for school
Janie: I understand. The answer is on the BIOS itself.
Ghoul Tek: ok thank you Janie
Janie: We do not want to get blamed if the 3rd party Linux did not work.

As stated in the other thread the part of the reason the OEMs limit their systems is to limit their support responsibilities to Windows.

Well that’s certainly hilarious. Disabling secure boot was definitely the easy part :slight_smile:

Its not just disabling the secure boot that may be necessary. Take a look at the video. Pay attention to the part where he is changing the driver/mode in EFI from the Intel thing to AHCI. You might have to so similar. That mode could be what trips up the install and boot process.

Yeah Lenovo ships the drive in RAID mode despite there being only one drive. Makes sense to nobody.
Everyone with a Lenovo needs to, at the outset:
Change to AHCI
Turn off secure boot
Turn off quick boot
The rest is outlined above. My problems were firmly in getting my bios to recognize manjaro’s grub installation. I knew it was there and functional - I could get it to go via rEFInd and the Manjaro live cd could detect it.

But despite its presence the bios (is that even what we call it these days?) refused to acknowledge its presence. At least not consistently.

Yes, I heard you before and I understand what you say.
Trouble is, I think it's the Lenovo uefi firmware (which I think you agree with) that's causing all this grief and I suggested earlier the following...

I don't have Lenovo, but go to bios-setup (yes, uefi bios is also called bios) F2, look into anything
o Security menu "trusted"
o Startup sequence "+/-"
o “Lock Boot Order” disable

As said, first remove some bootentries "efibootmgr -b xxxx -B"
and lastly using the ugly hack, rename your manjaro efi file to the windows bootmgfw.efi and at that windows directory (you should copy out that windows file and put it safely somewhere else first).

Whatever, good luck and let us know what you did to fix it.
Cheers.

ps: I did not give up on you. I just don't know how to help further.

Did the AHCI change have any effect? I was hoping that since the Yoga 910 and 720 are similar in design that the video would provide answers or solutions; especially since the guy in the video was successful at setting up dual boot without having to resort to all of the extra EFI hacks. Gohlip seems to be rather knowledgeable in regard to manipulating /boot/efi goodies. Also, I believe my SATA mode in BIOS is set to AHCI and I know distros have worked with AHCI before. You could also try contacting the guy in the video. I suspect there are only a handful of steps to put your BIOS into the correct state for it to work smoothly with your Manjaro GRUB.

I have no idea if it made any difference. I got the Yoga about 10 days ago. First thing I did was read up on installing linux, and I had AHCI going before anything else. As for my bios there are very few options on this thing. I think we manipulated just about every one.

But hey - it's working now. Part of my obsessive-compulsive perfectionist side can't stand the fact that grub resides in a directory called "ubuntu" inside the /boot/efi/EFI directory.

Forum kindly sponsored by