UEFI: Manjaro is missing

I suppose the next experiment is to plug that drive back in to see what happens to my ubuntu grub. I'm a bit frightened to do so.

Well, ok. Got it.

There's a few on Lenovo here and having boot problems of some kind.

I don't know if this would help or fix the issue Crim is having but I contacted Lenovo tech support via online chat. The tech was only partially helpful. She would only tell me how to access the BIOS via the Novo button but would not go into details on how to disable secure boot. She said that it was outside of their realm of their support and she didn't want to get into trouble. So next I tried a bit of Google-Fu and Youtube-Tai Chi. I found a youtube video for setting up dual boot Win 10/Fedora on a Yoga 910 laptop. The narrator in the video says that the system is very finnicky. The info in the video might prove helpful.

Setting up Dual Boot on the Yoga 910 with Fedora and Windows
URL = https://www.youtube.com/watch?v=X2duO89XT_Q

You might have to do a full system restore and start from the beginning so that nothing present interferes. However, that is totally up to your discretion. If you do decide to go with the full system restore method, I suggest that you take pics of your BIOS/EFI setttings at their defaults and post them an online pic. site such as imgur.com.

Chat transcript:

Janie: Hi, welcome to Lenovo Chat Services, I'm Janie. I'll be your Lenovo technician today.
Janie: I am sorry that you had to contact us today. Before we proceed, may I please have your shipping address and if you have an alternate phone number
for documentation purposes???
Ghoul Tek: Hello janie
Ghoul Tek: I would rather not give those out
Ghoul Tek: I'm trying to help a friend who is in another state.
Ghoul Tek: I'm in New Jersey, US
Ghoul Tek: He is in Arizon
Ghoul Tek: His parent's got him a Yoga 720 laptop
Ghoul Tek: He is trying to install Manjaro Linux on it, but after the install completes the OS is not available for him to boot
Ghoul Tek: I suspect that secure boot is preventing him from booting up the Linux install
Ghoul Tek: How do we disable secure boot in the BIOS?
Janie: I am sorry. Third party operating system is beyond our scope of support.
Ghoul Tek: I understand that
Ghoul Tek: that is why I'm looking to find out how to disable secure boot in the BIOS
Ghoul Tek: I believe once that is turned off he will be able to boot the Linux partition
Ghoul Tek: so the issue isn't a 3rd party OS problem its the secure boot feature in the BIOS
Ghoul Tek: Janie are still there?
Janie: I understand. The answer to you question can be found on the BIOS.
Janie: Do you know how to get to the BIOS?
Ghoul Tek: No. Is there a document with instructions on how to disable secure boot in the BIOS?
Janie: I can give you the steps to get to BIOS.
Ghoul Tek: Awesome... thank you
Janie: May I please have the serial number of your machine?
Ghoul Tek: I don't have the laptop with me
Janie: Oh
Ghoul Tek: and he didn't send that too me in his email message
Janie: Here are the steps to get to BIOS.
Janie: 1. Turn off the laptop completely.
Janie: 2. Look for a pinhole that looks like an inverted arrow or horseshoe. It is beside the power button or audio jack. Sometimes beside the dc in jack/port. Insert a paperclip on the pin hole once you find it. Machine will turn on and you will see Novo Butoon Menu. Select BIOS Setup.
Janie: That is the step to get to BIOS.
Janie: Is there anything else I may help you with?
Ghoul Tek: Ok once in BIOS how do I disable the secure boot?
Janie: We do not support that.
Janie: You can navigate the BIOS.
Ghoul Tek: is the secure boot accessible via a menu in the BIOS?
Janie: We do not support changing settings on the BIOS to install 2rd party OS. You can navigate the menu on the BIOS.
Ghoul Tek: Ok I understand you dont support it but I just need to know how to get to the secure boot to turn it off.
Ghoul Tek: I'm just trying to help him complete one of his engineering projects for school
Janie: I understand. The answer is on the BIOS itself.
Ghoul Tek: ok thank you Janie
Janie: We do not want to get blamed if the 3rd party Linux did not work.

As stated in the other thread the part of the reason the OEMs limit their systems is to limit their support responsibilities to Windows.

Well that’s certainly hilarious. Disabling secure boot was definitely the easy part :slight_smile:

Its not just disabling the secure boot that may be necessary. Take a look at the video. Pay attention to the part where he is changing the driver/mode in EFI from the Intel thing to AHCI. You might have to so similar. That mode could be what trips up the install and boot process.

Yeah Lenovo ships the drive in RAID mode despite there being only one drive. Makes sense to nobody.
Everyone with a Lenovo needs to, at the outset:
Change to AHCI
Turn off secure boot
Turn off quick boot
The rest is outlined above. My problems were firmly in getting my bios to recognize manjaro’s grub installation. I knew it was there and functional - I could get it to go via rEFInd and the Manjaro live cd could detect it.

But despite its presence the bios (is that even what we call it these days?) refused to acknowledge its presence. At least not consistently.

Yes, I heard you before and I understand what you say.
Trouble is, I think it's the Lenovo uefi firmware (which I think you agree with) that's causing all this grief and I suggested earlier the following...

I don't have Lenovo, but go to bios-setup (yes, uefi bios is also called bios) F2, look into anything
o Security menu "trusted"
o Startup sequence "+/-"
o “Lock Boot Order” disable

As said, first remove some bootentries "efibootmgr -b xxxx -B"
and lastly using the ugly hack, rename your manjaro efi file to the windows bootmgfw.efi and at that windows directory (you should copy out that windows file and put it safely somewhere else first).

Whatever, good luck and let us know what you did to fix it.

ps: I did not give up on you. I just don't know how to help further.

Did the AHCI change have any effect? I was hoping that since the Yoga 910 and 720 are similar in design that the video would provide answers or solutions; especially since the guy in the video was successful at setting up dual boot without having to resort to all of the extra EFI hacks. Gohlip seems to be rather knowledgeable in regard to manipulating /boot/efi goodies. Also, I believe my SATA mode in BIOS is set to AHCI and I know distros have worked with AHCI before. You could also try contacting the guy in the video. I suspect there are only a handful of steps to put your BIOS into the correct state for it to work smoothly with your Manjaro GRUB.

I have no idea if it made any difference. I got the Yoga about 10 days ago. First thing I did was read up on installing linux, and I had AHCI going before anything else. As for my bios there are very few options on this thing. I think we manipulated just about every one.

But hey - it's working now. Part of my obsessive-compulsive perfectionist side can't stand the fact that grub resides in a directory called "ubuntu" inside the /boot/efi/EFI directory.

And it had Ubuntu OS in it already installed? Or did you install Ubuntu?

No. That'd be nice if they had linux options but it came with Windows 10, which is what I needed it for. I'm a criminal attorney and a lot of the recordings I get from the police/jails/victim stores come in proprietary formats, with their own .exe files to play them. Unplayable without Windows, and they're such crap applications that the loss of computing power in a VM makes them occasionally unplayable at a reasonable clip.

So when I got the Yoga, first thing I did was try a manjaro install, following all the tips about secure boot, fast boot, changing the HD to AHCI etc.

After install the manjaro bootloader didn't show up. Only after multiple attempts, both with Calamares and architect (which is fantastic) did I try another distro (Linux Mint), which worked.

After all of our gyrations outlined above, the only thing I can conclude is that the BIOS, for whatever reason, does not consistently want to show a bootloader other than specified ones. Windows works obviously, as does anything named ubuntu (which is what LM's bootloader is named). Manjaro or manjaro do not seem to work.

I've updated the kernel since I got it going, run update-grub, and all that, and all is well. I'm actually extremely satisfied with the distro now that it's going.

If I were to advise someone who was trying to install manjaro on a yoga 720, Id advise them to:

  1. change HD type to AHCI from RAID.
  2. Change BIOS to legacy mode, select Boot from UEFI First.
  3. Disable Secure Boot
  4. Disable Fast Boot
  5. Resize partition using Windows partition utility (saves you from having to run chkdsk afterwards.
  6. Insert Live CD
  7. Reboot - hitting F12, and select the CD drive as the boot option. This should get things going from the live CD

Taken from your advice gohlip:
7) Hit “c” when the Manjjaro Live CD starts up, and ensure that it's going in EFI mode.
grub> echo $grub_platform
8) grub> search -f /boot/intel-ucode.img --set=root
grub> configfile /boot/grub/grub.cfg

  • Just to be sure it's starting properly.
  1. Install as normal.
  2. Reboot and enter BIOS. If manjaro isn't present, start from the Manjaro Live CD again.
  3. Go to "Detect EFI Devices". There should be a manjaro at hd(0,1) or the like and select it.
  4. From there, it should boot from the newly-installed manjaro.
  5. Open terminal and enter:
    sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=ubuntu --recheck --debug
  6. sudo update-grub
  7. Reboot, entering the bios. Select ubuntu as the startup entry.

Hopefully I dont' have to test this any time soon.


Thanks for the answer and particularly for helping others if they encountered the same problem.
Cheers and take care.

1 Like


Yes. Select Ubuntu. Feels weird doing it even now.

Hi Crimguy,

I have just created an account to say a huge thank you. I was struggling for three days all day to make my dual boot work, tried everything. I had the same issue like you. My BIOS just simply does not list the Manjaro UEFI option but it worked with other Linux distros like Mint. I could only boot into Manjaro if my USB was inserted and from the install menu I could see the manjaro efi. But without USB I got straight to Windows and I had only one entry, the windows in my efi list. I renamed the manjaro grub to Ubuntu like you did and now it is working. I have a laptop - MSI CX QD and looks like it does not like the Manjaro grub either. Thanks again for sharing this!

1 Like

In this post, there is a user with a solution for MSI.

The ‘gaming’ models need to have these settings in bios settings (F2)
Turn off secure boot
Set boot to UEFI (DO NOT USE CSM)
Set TPM to 2.0 with 1.x compatibility

Is your bios setup differentl?

Thanks for you reply. I could make it work now by renaming the manjaro directory to ubuntu. My bios is different, it is just a basic entry level laptop, nothing fancy. It is working now perfect. I am still very new and trying things. One thing I noticed, it happened three times so far that both my headphone and laptop speaker started to give a repeating noise. Noise like when you disconnect a cable from a speaker and it was looping around. Reboot resolved the issue. Fingers crossed it was only temporary.

1 Like

Happy it worked for you. It was mostly plagiarizing @gohlip and others.

1 Like

I've been living in a nightmare trying to get my Yoga 720 to work properly with grub after installing manjaro and rebooting. I followed your steps and it works perfectly. Thank you.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by