UEFI not showing Manjaro after an install

I installed Manjaro Linux from a live CD and can't figure out how to get it to show up as a boot option in UEFI. I'm stuck. I've tried searching and can't figure out how to fix this issue.

I can boot into Grub from the live CD. Windows 10 shows up as an option. All of that seems fine. Just that an option to load Grub doesn't show up in the UEFI boatloader.

If it makes a difference, I installed Manjaro on a newly purchased mSata drive. I have windows installed on a different SSD.

My partitions on the drive look like this in gparted and would appreciate it if you could help me with commands based on this:

/dev/sdc1 -fat32 /boot/efi - flagged as boot, esp
/dev/sdc2 -ext4 /
/dev/sdc3 -swap

I can attach screenshots of everything step by step if it would help. I'm a newb to linux and to Manjaro, so my terminal skills are lacking. Would greatly appreciate if you guys would point me in the right direction.

Read the first post here.

1 Like

I believe your post in that thread is the one that I tried a couple of days ago and failed. I'm going to try it again tomorrow night and let you know if I get stuck again. There was a point in it where I was unsure of what to do exactly if my memory serves.

....... together with the required information listed in that link.
And state computer make and model ...... as stated in the same link.

Thanks. I'll keep you posted.

If it helps ahead of time, the computer is a dell 17r se with an i5-3230m. Figured I'd go ahead and tell you that in case there were any issues with that particular model.

I added an inxi command in the info links of the Tutorial, so you/we don't need to remember/state it all the times :relaxed:

inxi SMxxx

Hey thanks,........ but but but.... :smile:
It does not give info like Lenovo, HP, Acer, Asus,.....
Does that do it for you?
I don't have all these, just

System:    Host: Nov Kernel: 4.19.0-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.0 
           Desktop: KDE Plasma 5.13.4 tk: Qt 5.11.1 wm: kwin_x11 dm: sddm Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Intel model: DH67BL v: AAG10189-203 serial: <root required> 
           UEFI: Intel v: BLH6710H.86A.0076.2010.1115.1959 date: 11/15/2010 

Maybe it gives something on Laptops? :roll_eyes:
At least it does the best for a technical objective view :stuck_out_tongue_closed_eyes:
Anyway, this info is nice for this troubleshooting..

Don't think so, petsam.
As it is, I have a feeling some people (who don't know well enough) may think it is already too invasive to ask for so much. As you know all that we ask for is required to fix or understand where the issue lies.

But I'll leave it to you if you want to keep this "inxi SMxxx" there.
I prefer to leave that out.
What do you think?

ps: the OP hasn't replied yet.
I'm taking my sleep now.
Please handle it if he respond.
Thanks again. Cheers.

I'm not sure what the exact info you need is, but here goes nothin:

Dell 17 r se - i5 3230m
KDE Plasma: 5.13.4
KDE FW version: 5.48.0
qt version: 5.11.1
Kernel: 4.14.65-1-1-MANJARO

a couple of questions

Step 5: I ran grub> configfile /boot/grub/grub.cfg

I selected the correct Manjaro boot file (to my knowledge) and it booted me back to the main menu on the live CD. Is that what you mean by original grub? From there, I went to the detect bootloaders portion and booted into my manjaro install. Maybe this part is incorrect on my end?

I also have may have "multiple manjaros" as i'm unsure what this means.

Step 6.....you say

sudo grub-install /dev/sda

So which partition would that be for me? I have a 300mb efi boot,esp partition on sdc1 and a a 50gb sdc2 partition that is ext4 and unflagged.

Alright, so it worked. I now have it booting into Grub by default. Thank you guys!

I do have one last question. I now have two options for Manjaro when the original bootloader pops up. Don't know why. Don't really care as long as it isn't a problem down the line.

Is that a big deal?

And one observation. I tried your guide last week and realised where I got stuck before. I got stuck because I thought the terminal was frozen when typing in my password. Turns out, terminal just doesn't let you know when you type anything in as a password. I expected to see something like ***** as I typed. Nope. Just blank lol. This through me for a loop and I gave up last time. This time I was like what the heck and just hit enter to see what happened. Well wouldn you look at that...terminal was just yanking my chain. I felt stupid. Legitimately.

Thanks again for all the help!

Hi @AgentS I've removed that "inxi -SMxxx" line.
PM me if you think it should be there.

I think it is the most edited post on this forum.:stuck_out_tongue_closed_eyes:
But for good intentions, I suppose. :slightly_smiling_face:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by