UEFI not working after Manjaro installation (but booting works fine)

  1. You've replied so fast that I know you haven't even tried:

    https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/boot-to-uefi-mode-or-legacy-bios-mode

    :stuck_out_tongue_winking_eye:

  2. I didn't set up your system nor did you provide any file system structure for all of your ESPs, so I can only provide general guidelines. You know what you did, so up to you to choose the solution...

    :innocent:

1 Like

@Fabby, I have actually tried this before (from your link):

Power (Power button icon) > hold Shift while selecting Restart . Select Troubleshoot > Advanced options > UEFI Firmware settings .

However, when I'm in the UEFI Firmware Settings, there is just 1 button "Restart". If I press that button I get to the black screen with underscore just like when I press F2 during any other boot.

That looks like an UEFI NVRAM issue, but I've never seen this on a system with a battery in such good condition.

Anyway, this is a hardware problem (not a Manjaro nor a Windows problem) so I can offer only 3 additional solutions (going from bad to worse):

  1. Reset the NVRAM:
    • Execute efibootmgr --verbose and copy-paste the output to a file on a USB!
    • Remove the battery
    • Hold the power button for 1 minute
    • Reinsert battery
    • Try again the Shift+Windows restart into EFI settings
    • If that works, Manjaro will still be installed, but removed from the NVRAM, so execute efibootmgr --verbose again and add the missing Manjaro boot entry with efibootmgr --create and the data you saved to a file
  2. Reset the system to default:
    • Back up all your data
    • Shift+Windows restart into Reset your PC
  3. Return the machine to Acer and have them restore the system if still under warranty.

And from this point forward (after solving above), start making crash proof backups...

:sob:

@Fabby, I have not tried any of your suggestions yet, but...

I deleted the EFI on the Kingston SHDD with https://www.easeus.com/partition-master/delete-efi-system-partition.html and this did not change anything (still black screen with white underscore instead of UEFI after pressing F2). So, this really was not the issue.

Then, I got UEFI to work again. With the method that I mentioned earlier. I think before, I did not do it correctly. When I was on the black screen with the white underscore, I pressed the power button for approx. 20 seconds straight. (Before I had pressed it several times or not long enough, which did not work). I think it was during the first restart directly after this, when I pressed F2 and got into UEFI. I again disabled secure boot and activated the boot manager with F12.

After that things went far from smooth. The first Windows boot failed (with a blue screen saying that windows encountered some issues and needs to restart). After restart, I got into the blue Windows trouble shooting menu. From there, I first tried a simple restart. This did not work, I again got into this trouble shooting menu. Next, I activated the safe mode (https://www.howtogeek.com/164876/how-to-use-safe-mode-to-fix-your-windows-pc-and-when-you-should/). And this helped getting back to windows as usual (like mentioned in my first posts of this thread here).

At this point, I can boot into Windows and I can access UEFI again. However, the problem is that I cannot boot into Manjaro anymore. I can select it from the boot manager (after pressing F12). But when it starts booting, I get the following error:

IMG_20200426_004826

I'm not quite sure where to go from here. Did I make major mistakes in life? :face_with_raised_eyebrow:

Currently, in my UEFI settings I have SATA Mode: RST Premium with Optane. Before installing Manjaro, I had to set it to SATA MODE: AHCT (because otherwise my SSD(s) did not show up as option for installing Manjaro; only the SHDD was showing). That's a wild guess but maybe the SATA MODE explains why Manjaro can't start anymore now? (And possibly even why UEFI was not working before?)

You have a completely different problem now and one that is outside of my area of expertise. The only advice remaining is to:

  • Create a Windows repair USB (look on M$ site how)
  • Completely nuke your Manjaro install and any redundant ESPs
  • Repair Windows if needed with aforementioned repair USB
  • Redo the Manjaro install and use the existing ESP: one is enough! :innocent:

and finally I wish you good luck (as you'll need it with an Acer)

:innocent: :bed: :zzz:

1 Like

can you boot on ISO USB manjaro ( not your disk )
open a terminal and browser on this topic

manjaro-chroot -a ( type 1 if only only line )
cat /etc/fstab
lsblk -fs  ( check UUID )
nano /etc/fstab ( correct UUID  and save )
nano /etc/default/grub ( correct UUID and save)
update-grub
exit ( quit chroot )

@stephane, I am getting errors for the first command:

[manjaro@manjaro ~]$ manjaro-chroot -a
==> ERROR: You can't mount 0!
[manjaro@manjaro ~]$ manjaro-chroot -a 1
==> ERROR: You can't mount 0!

is there any lines appears after manjaro-chroot -a ( enter)
list of linux appears
if none appears there is a big problem

inxi -Fxxxza
parted -l

@stephane there was no more output after manjaro-chroot -a.

[manjaro@manjaro ~]$ inxi -Fxxxza
System:
  Host: manjaro Kernel: 5.4.23-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us 
  tz=UTC driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 
  misobasedir=manjaro misolabel=MANJARO_KDE_1902 quiet 
  systemd.show_status=1 apparmor=1 security=apparmor 
  Desktop: KDE Plasma 5.17.5 tk: Qt 5.14.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Acer product: Predator PH315-52 v: V1.02 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: CFL model: Covini_CFS v: V1.02 serial: <filter> UEFI: Insyde 
  v: 1.02 date: 04/15/2019 
Battery:
  ID-1: BAT0 charge: 17.0 Wh condition: 56.6/56.6 Wh (100%) 
  volts: 13.8/15.4 model: SMP KT00407009 AP18E7M type: Li-ion 
  serial: <filter> status: Discharging 
CPU:
  Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: CA L2 cache: 12.0 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 62431 
  Speed: 891 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 900 2: 900 
  3: 901 4: 900 5: 900 6: 900 7: 900 8: 900 9: 900 10: 901 11: 900 
  12: 901 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, 
  SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: Acer Incorporated ALI 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] 
  vendor: Acer Incorporated ALI driver: nouveau v: kernel bus ID: 01:00.0 
  chip ID: 10de:2191 
  Display: x11 server: X.Org 1.20.7 driver: intel,modesetting,nouveau 
  alternate: fbdev,nv,vesa compositor: kwin_x11 
  resolution: 1920x1080~144Hz 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) 
  v: 4.6 Mesa 19.3.4 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
  Device-2: NVIDIA TU116 High Definition Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 chip ID: 10de:1aeb 
  Sound Server: ALSA v: k5.4.23-1-MANJARO 
Network:
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] 
  vendor: Bigfoot Networks driver: iwlwifi v: kernel port: 5000 
  bus ID: 00:14.3 chip ID: 8086:a370 
  IF: wlp0s20f3 state: up mac: <filter> 
  Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: alx v: kernel port: 3000 
  bus ID: 06:00.0 chip ID: 1969:e0b1 
  IF: enp6s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 960.87 GiB used: 165.9 MiB (0.0%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000LX015-1U7172 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: SDM1 
  scheme: GPT 
  ID-2: /dev/sdb type: USB vendor: Intenso model: Ultra Line 
  size: 14.91 GiB block size: physical: 512 B logical: 512 B 
  serial: <filter> rev: 8.00 scheme: MBR 
  ID-3: /dev/sdc type: USB vendor: Philips model: USB Flash Drive 
  size: 14.44 GiB block size: physical: 512 B logical: 512 B 
  serial: <filter> rev: PMAP scheme: MBR 
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: 5060 bus ID: 00:17.0 chip ID: 8086.282a rev: 10 
Partition:
  ID-1: / raw size: N/A size: 23.41 GiB used: 165.9 MiB (0.7%) 
  fs: overlay source: ERR-102 
Sensors:
  System Temperatures: cpu: 62.0 C mobo: N/A gpu: nouveau temp: 27 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 293 Uptime: 1h 20m Memory: 31.22 GiB used: 1.46 GiB (4.7%) 
  Init: systemd v: 242 Compilers: gcc: 9.2.1 Shell: bash v: 5.0.16 
  running in: konsole inxi: 3.0.37 

parted -l does not give any output whatsoever.

try

sudo parted -l

Sure, this worked :slight_smile:

[manjaro@manjaro ~]$ sudo parted -l
Model: ATA ST1000LX015-1U71 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      17.4kB  1066kB  1049kB               LDM metadata partition
 2      1066kB  134MB   133MB                Microsoft reserved partition  msftres
 3      134MB   1000GB  1000GB               LDM data partition


Model: Intenso Ultra Line (scsi)
Disk /dev/sdb: 16.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  16.0GB  16.0GB  primary  ntfs


Model: Philips USB Flash Drive (scsi)
Disk /dev/sdc: 15.5GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      3044MB  3048MB  4194kB  primary               esp

Philips is my Manjaro Boot USB, Intenso is a storage USB, ATA ST1000LX015-1U71 is the storage SHDD. It seems like my 2 SSDs don't show.

shutdown and check cables

At this point, I cannot start the laptop anymore. This happened while I was in Manjaro booted from USB: currently, the laptop switched off while I was doing something else. From there on, I could not boot anymore. When I press the power button, the screen just stays black (in the sense that the laptop stays turned off).

I have tried removing the battery and pressing the power button for 1 Minute. But after that, I still cannot switch on the laptop again.


Edit: It worked again now (after plugging in the cable). Possibly, the battery was just empty and that's why it did not start before. I'm not quite sure.

@stephane importantly, both SSD's do show when I boot into Windows. So the cables work just fine.


@Fabby, @stephane Following up on SATA MODE in UEFI. This really seems to be the issue here.

I just set SATA MODE: AHCI and now I can boot into Manjaro (without getting the error ERROR: resume: hibernation device... anymore, from the photo that I posted previously). But I cannot boot into Windows any more: I am only getting a blue screen with a sad smiley :( saying that something went wrong and Windows needs to restart. This is essentially the situation that I had after the fresh Manjaro installation.

If now get Windows back to work (with the blue trouble shoot menu, where I activate safe mode activated the safe mode https://www.howtogeek.com/164876/how-to-use-safe-mode-to-fix-your-windows-pc-and-when-you-should/ and restart in the with UEFI System settings section), this causes the sata mode in UEFI to get set back to SATA MODE: RST Premium with Optane. Then, I can boot into Windows without issues but I cannot boot into Manjaro because the SSD is not found (Note that SATA MODE: AHCI was required for the SSDs to show up as option for the Manjaro installation. Without AHCI, I only saw the SHDD as option for the Manjaro installation. )


Long story short: I have to choose SATA MODE: RST Premium with Optane for Windows or SATA MODE: AHCI for Manjaro. I can't actually dual boot smoothly: don't think it's easy to change sata modes in order to jump between operating systems. Switching SATA mode always results in various issues (UEFI resets etc.) that I need to always address first before I am able to use the other operating system.

Interestingly, dual booting was possible without issues when I had Manjaro instaled on my SHDD. Because I did not need to change to SATA MODE: AHCI in order to install Manjaro in the SHDD. The SHDD always shows up as option for the Manjaro installation regardless of the sata mode (unlike the SDDs which required AHCI as sata mode).

Please have a look at the following thread for a similar issue:

:warning: If you choose to implement the solution suggested at this thread, do it at your own risk. That is don't shoot the messenger!

create 2 profiles for boot in UEFI
one for windows , other for linux

linux boot only on AHCI and do not support optane
@philm @oberon @jonathon

it should be added on any doc for boot about theses options

I think that when I was running Manjaro from my SHDD, I did not need AHCI. Dual boot worked fine (for both Windows and Manjaro), so I think I was using RST Premium with Optane.

In addition, to my previous post I need to say that I can actually boot into both, Windows and Manjaro now. The boot process just gets more complicated and prone to errors.

If I want to boot into Windows:

  • Press power to start machine, and then F2
  • Set SATA Mode: RST Premium with Optane and then F10 to save
  • Again press power and F12 to select Windows for booting

If I want to boot into Manjaro:

  • Press power to start machine, and then F2
  • Set SATA Mode: AHCI and then F10 to save
  • Again press power and F12 to select Manjaro for booting

This all works fine (until I forget to select the correct SATA Mode before booting). In particular if I start Windows with AHCI, I might get issues because Windows may try to restart, and reset UEFI to defaults etc.


@stefane Would you explain how to create 2 UEFI profiles?

check if you can save settings from your bios

I don't have any options to save my settings as profiles in UEFI. It's only F10 to save and exit.

I guess, even if I was able to save settings as profiles in UEFI, I'd still need to select the correct profiles in UEFI before booting into Windows or Manjaro? In this case, this would not make things any less complicated: going into UEFI and changing sata mode would be as much effort as going into UEFI and changing profile.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by