UI of some apps broken after changing kernel

Hey people,
I had issues with fresh Manjaro KDE not seeing usb headphones, so I changed kernel to 5.5 from 5.4. However after doing so some apps (qbittorrent, virtualbox) got some UI problems. Then I reverted kernel to 5.4 again, but the issue still persists. I tried completely reinstalling both Qbittorrent and Virtual box to no avail. I reckon it has something to do with KDE, but I have no idea how to fix it, besides reinstalling whole OS.
Any help would be greatly appreciated
dedui

:+1: Welcome to Manjaro! :+1:

Please read this:


and post some more information so we can see what's really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies...

:innocent:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you're using, which CPU/GPU you have, ...

1 Like

Sorry for not reading it beforehand and not following guidelines.

System:
  Kernel: 5.4.24-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=17b55bc4-7dff-456d-ab80-fe4543b0c2f2 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.18.3 tk: Qt 5.14.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME X470-PRO v: Rev X.0x 
  serial: <filter> UEFI [Legacy]: American Megatrends v: 4602 
  date: 03/07/2019 
CPU:
  Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP 
  arch: Zen+ family: 17 (23) model-id: 8 stepping: 2 microcode: 800820D 
  L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 127801 
  Speed: 1895 MHz min/max: 2200/4000 MHz boost: disabled 
  Core speeds (MHz): 1: 2264 2: 1965 3: 2164 4: 2132 5: 1774 6: 1774 
  7: 3589 8: 1774 9: 2165 10: 2022 11: 1774 12: 1774 13: 3992 14: 1774 
  15: 3046 16: 1897 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, 
  STIBP: disabled, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA TU106 [GeForce RTX 2070 Rev. A] vendor: Micro-Star MSI 
  driver: nvidia v: 440.64 bus ID: 0a:00.0 chip ID: 10de:1f07 
  Display: x11 server: X.Org 1.20.7 driver: nvidia compositor: kwin_x11 
  resolution: 1360x768~60Hz 
  OpenGL: renderer: GeForce RTX 2070/PCIe/SSE2 v: 4.6.0 NVIDIA 440.64 
  direct render: Yes 
Audio:
  Device-1: NVIDIA TU106 High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 0a:00.1 chip ID: 10de:10f9 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 0c:00.3 chip ID: 1022:1457 
  Device-3: Kingston HyperX Cloud Revolver S type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 3-1:2 
  chip ID: 0951:16ad serial: <filter> 
  Sound Server: ALSA v: k5.4.24-1-MANJARO 
Network:
  Device-1: Realtek RTL8812AE 802.11ac PCIe Wireless Network Adapter 
  vendor: ASUSTeK driver: rtl8821ae v: kernel port: d000 bus ID: 05:00.0 
  chip ID: 10ec:8812 
  IF: wlp5s0 state: down mac: <filter> 
  Device-2: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb 
  v: 5.6.0-k port: c000 bus ID: 08:00.0 chip ID: 8086:1539 
  IF: enp8s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 4.55 TiB used: 15.86 GiB (0.3%) 
  ID-1: /dev/sda vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 023 scheme: MBR 
  ID-2: /dev/sdb vendor: Seagate model: ST4000DM006-2G5107 size: 3.64 TiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: DN04 scheme: GPT 
Partition:
  ID-1: / raw size: 194.81 GiB size: 190.75 GiB (97.92%) 
  used: 15.86 GiB (8.3%) fs: ext4 dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 39.0 C mobo: N/A gpu: nvidia temp: 43 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:
  Processes: 317 Uptime: 6m Memory: 15.63 GiB used: 5.41 GiB (34.6%) 
  Init: systemd v: 244 Compilers: gcc: 9.2.1 Shell: bash v: 5.0.16 
  running in: konsole inxi: 3.0.37
  1. Please read this again as the way you posted it is quite unreadable and the </> way isn't.

  2. You've got an AMD Ryzen 7 2700X, so 5.5 or 5.6 are indeed the way to go, not 5.4.

  3. nVidia 440.64 is also correct, but which driver are you using exactly? The output to:

    mhwd --listinstalled
    

    would be appreciated (in pre-formatted text, please, pretty please with :unicorn: and :rainbow: )

Thank you a lot for your time,

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
    video-nvidia-440xx            2019.10.25               false            PCI


Warning: No installed USB configs!

I think I found the culprit - my second monitor. I'm running 2560x1440 as primary and 1360x768 as secondary monitor. Once I launched OS with second monitor turned off the UI worked correctly, but as soon as I plugged it in - it broke again.

Does that mean your issue is solved? If yes, please mark the answer that solved your question as "Solution" like this:
Solution
so that your question gets removed from the "unsolved" queue and if anyone else has the same question as you and they come looking for a solution, they'll find it as well!

If not, leave another message.

:innocent:

Yeah, at least I know the root of the problem. Now to find how to use second monitor without breaking whole UI. I'll try to find a solution first, post it here and then close the thread as solved, in case someone stumbles into same issue. Thanks for your time

Did you try kernel 5.5 and 5.6? Has that made a difference? If not, I'm unable to help you any further as I'm not an expert on AMD drivers.

I am on kernel 5.5 right now and I managed to fix it. My global scale was set to 125% as stuff on primary monitor is a bit too small at 100%, but now that I changed it back to 100% both QBittorrent and VirtualBox display correctly

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by