Unable to access BIOS after installing Manjaro XFCE 18.1.5


I'm unable to access BIOS ever since I installed Manjaro. My laptop works normally, but if I press F2 during boot up the start up process freezes on Acer logo and Im unable to enter BIOS. I have tried to reboot with "systemctl reboot --firmware-setup". Same issue I can only see the Acer logo and the PC does not boot, or enter BIOS. Please help.

systemctl reboot --firmware-setup

or something like it - so if this is not working I think your firmware has a bug

Create a bootable USB using WoeUSB and Hirens BootCD then download and flash your systems firmware with the latest version.

Thank you for responding. I have tried this already. Same issue. I can only see Acer logo

Could you try to hold down the F2-key when the computer is booting?

  1. turn it off.
  2. hold down F2 and keep it that way.
  3. Turn on

This is what I did. I only see then Acer logo and the system won't start, nor will BIOS. I have done this and waited for over 5 min but all I see is Acer logo.

can you please what specific model you have? thanks

Try to boot without any hard drive inside or with a different hard drive.
Tell us model of laptop.


Acer Aspire A515-54 Series

Acer Laptop BIOS Key Input

Each computer manufacturer uses a customized BIOS program for the computers they produce. As a result, the function key used to load the BIOS will differ depending on the brand of your computer. On an Acer Laptop, the BIOS key is traditionally "F2," though some older models may require you to press "F12" or the "Delete" key. Commonly, during start-up a message will briefly appear noting the key you need to press. When your computer powers on, tap the "F2" or other noted key repeatedly when the green Acer logo appears on the screen to enter the BIOS.

you may be close. found this for the 53 vs 54. 3rd post.

1 Like

Wow guys thanks for fast response. I tried to boot with ESC + F2 but I get the same issue.

Thanks for response. I will download BIOS update form here and try my best to update it. https://www.acer.com/ac/en/US/content/support-product/7972?b=1

Your laptop probably has UEFI instead of BIOS. I have no experience with UEFI, so bowing out of the discussion, sorry.

Oh wait.
Have you tried
'Fn'+ 'F2' when powering on?
Try it if that helps.

rather a comp is uefi, mbr, or both makes no difference on how you get into the bios. manufacture tend to keep the same method for all 3. now that said there use to be a way of powering down and removing the power cord on towers that when reconnected and powered back on would force the tower into the bios. i do not know if laptops have something simular, but might be worth googling.

Thanks for reply. I have tried it. Same issue

So I have created a bootable USB thanks too your tutorial. But I don't know how to use it. All I found on internet hints to BIOS witch I don't have access too. Please help

Just to ask the obvious, have you tried to hammer the relevant button while booting? I have to do that on one of the older machines.

A very last resort could be to flush the bios manually. On tower systems that can be done by pins or by removing the battery, I've never had the need to do it on a laptop so I'm not sure how you'd do it there. And I would not advice it if you are unfamiliar with bios.

Thanks for help guys

now that you have the live environment i believe that you ban boot to the bios from within it. i know i saw the option in my actual install, but don't remember where.

Forum kindly sponsored by