Unable to access my secondary internal ssd on my laptop

hi guys, totally new to linux and manjaro and any help would be welcome. after installing manjaro, i realised i could not access my secondary drive, the create folder option is greyed out and i cannot transfer files into it. i can see it but cannot perform tasks on it. im not sure what to do next and i would appreciate any help . thankyou.

Have you fully updated the system? Sometimes when I have issues with a fresh install they vanish once I fully update.

Other than that I cannot help sorry. I am new too.

Hello,

depending on what DE you are using, Gnome, XFCE or KDE you should have partition management software installed. You can then use this to see what partitions are on what drives. Depending on how well versed you are in using software to create partitions, You should see what I have posted below. Linux does not have a drive c, d, e as in windows, but will have /sda, /sdb, /sdc usually the /sdc drive is a USB drive or some external device.

If you look closely at the drives, You should be able to tell them apart by the amount of drive space. The 1TB drive in the screenshot below is my external drive, The 111 is my main drive and the 160 drive is my secondary drive. once you have that information you should be able to give yourself permissions to access the drive. It could be that the drive is not mounted. You need to mount the drive also.

Here is a link to a video that will show you how to mount a drive in Linux
https://www.youtube.com/watch?v=8lLHRd6UnSs

Here is a Linux to help you understand how to give yourself permissions on a secondary drive.

Can you open a terminal window and share the results of two commands?

The first is lsblk and the second is cat /etc/fstab

If you could run those one at a time and paste the results here it would help us figure out what is going on.

It sounds to me like the device is either mounted read only or with only root permissions.

1 Like

Your issue is most likely tied to

  • NTFS partition
  • Windows cache exit due to fastboot enabled in windows.

The only cure is to reboot into windows or a windows recovery environment and try fixing it with windows tools.

Another approach would be to salvage what ever you need from the drive to a partition on another drive preferrably external and then zap the partiion and create a new ext4 or ntfs whatever you prefer.

@dini-manjaro

could you post the output of

sudo fdisk -l /dev/sda

You don't have the correct permissions set for that drive.

Easiest fix for a beginner? Open your file manager, right click on the SSD drive to open it, right-click and change read-write permissions to yourself. This will work, with minor variations, in most Linux file managers. Then re-boot.

It it shows as corrupted, then @linux-aarhus's first fix works great. :smiley:

respect

1 Like

1 Like

Is your secondary internal ssd by any chance NTFS filesystem?
Try running this and copy the output (By pressing CTRL+SHIFT+C ) and paste it here

lsblk -no FSTYPE /dev/sda1

the output is ext4

1 Like

1 Like

In this case your issue is permissions.

@c00ter already desribed the ^^^ The easy way ^^^ - one thing forgotten though is that you first have to open the file manager as root - also using right-click.

Another way where you also is learning about your Linux comes here:

Make a permanent mountpoint.

Create a folder for the purpose (you can change all references to sda1 if you want another name).

sudo mkdir -p /media/sda1

Mount the partition

sudo mount /dev/sda1 /media/sda1

Set owner

Recursive change owner on the folder structure

sudo chown -R mangala:mangala /media

Now see if this solved the permission problem.

As @dalto pointed to down the thread I have removed the suggestion to change permissions as it was a bad idea.

Mount partition permanent

To mount it permanently on boot modify your /etc/fstab to include the partition on boot.

su -
echo "UUID=$(lsblk -no UUID /dev/sda1) /media/sda1 ext4 defaults,noatime 0 0" >> /etc/fstab
mount -a
2 Likes

Isn't this going to set every file in /media as executable?

If you really want to do this I think sudo chmod u+rw,go+r -R /media would be a lot safer

1 Like

Is this okay to set the group and other read-only? Why not allow them to write it (766) ?

From a security perspective I would not recommend giving 'other' write access to an entire partition. group would probably be fine in the above circumstances.

I really don't think we are talking security here.

Under other circumstances you might be right - but we are talking a single user system here where the user cannot change his own data.

Lets not confuse a newbie with security stuff he does not have a chance of understanding.

Hard setting an entire partition to 0755 is going to set the executable bit on every file. Why would you ever want that? It is also going to destroy any special permissions any of those files may have had. It isn't about security, it is just general good practice.

My comment about security was in reference to giving 'other' write to an entire partition. While I don't think a newbie needs to understand why you shouldn't do it . I think it important to understand that you shouldn't do it unless there is a good reason to. other isn't just other users who are logged in it is every process running on the system.

EDIT: I think things were edited while I was responding and my comments seem strangely out of context now.

1 Like

That is my bad. I think you are absolute right - my thinking of permissions in general and changing those would - as you point out - be a bad idea.

Also changing the owner:group will effectively retain permissions but move the permissions to another container - the user - so it should not be needed to change permissions.

Thank you for pointing it to me - we can't have anyone doing something foolish caused by bad advise.

Again - Thank You :thumbsup: :100:

1 Like

wooohoooo...that did the trick, thankyou so much for your help. now i need to study and understand what exactly i typed into the terminal, interesting..

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by