Unable to boot installed Manjaro

Hello there. Sorry for my bad English. I'm new at Linux. I have Jumper ezbook 3 pro and trying to install manjaro-gnome-17.1.11-stable-x86_64 on ssd 240 GB. UEFI, secure boot disabled. No dual boot, only Manjaro (i've formated disk with Win 10 anyway). I've installed it (at least, i think so) but i can't to boot it.
Disk partition GPT - 512 MB to /boot/efi with esp flag (fat32), 40 GB to / with flag root (ext4), other to /home (ext4)

After reboot i saw this
manjaro grub menu -> Detect EFI bootloaders -> No EFI files detected.

I google it and found this

I tried to use this guide, but it doesn't help.

grub> echo $grub_platform
grub> search.file /etc/manjaro-release
error : no such device: /etc/manjaro-release.
grub> search.file /intel-ucode.img root
error : no such device: /intel-ucode.img.

~$ sudo grub-install /dev/sda
Installing for x86_64-efi platform.
grub-install: error: cannot find EFI directory.

What can i do?

Hi, if it is uefi you must create a partition to store the boot bios and mount that partition inside /boot and then install grub, maybe this help https://www.thomas-krenn.com/en/wiki/Installing_Operating_Systems_on_UEFI_Systems

I don't undestand. I created a partition and mount it in /boot/efi. Do you mean i need an another partition for /boot or do not mount it in /boot/efi and mount in /boot or what?

for i can see you try install grub in /dev/sda not in dev/sda1, and in the partition table need a partition for efi-system

Creating an EFI partition

If you are manually partitioning your disk in the Ubuntu installer, you need to make sure you have an EFI partition set up.

  1. If your disk already contains an EFI partition (eg if your computer had Windows8 preinstalled), it can be used for Ubuntu too. Do not format it. It is strongly recommended to have only 1 EFI partition per disk.

  2. An EFI partition can be created via a recent version of GParted (the Gparted version included in the 12.04 disk is OK), and must have the following attributes:

  3. Mount point: /boot/efi (remark: no need to set this mount point when using the manual partitioning, the Ubuntu installer will detect it automatically)

  4. Size: minimum 100Mib. 200MiB recommended.

  5. Type: FAT32

  6. Other: needs a "boot" flag.

i mean that a partition for / than can contain grub and other partition for efi-system or use a table partition mbr

This is correct, but it is possible that you should have left the original (vendor) esp partition and use that.
It seems you have not installed Manjaro (some error on installer maybe?)
I suggest you try again the installation with a different ISO and use Etcher or dd to write to USB.

If it fails (and since you don't need WinOS) you could make your drive MBR (legacy) partition scheme and change it in your UEFI/BIOS settings. Then you may install any Linux OS in legacy (non-UEFI) mode.

for i can see you try install grub in /dev/sda not in dev/sda1

I have same error when trying to install in /dev/sda1, /dev/sda2/, /dev/sda3

DO NOT do that.
In normal UEFI systems you should not specify ANY target. Just grub-install
Even in MBR systems you should normally install on the drive, not partition, unless you know what you are doing.

I've tried it just to find out what will happen. May be it will work.
May be i should have left original esp but it was in my EMMC and i tried to install Manjaro in SSD. But my Win 10 has some problems with formatting SSD - so i couldn't clone system on SSD and just formate it. Ok then. I'll ask vendor to send me original esp.

You might try again to install with another ISO image.
It is possible that there is/was a calamares bug. There are a bunch of different issues with installation on several PC/laptop models and also changes in Calamares versions.

Another system? Like Win 10? Will it create new esp that i need?

You have a emmc disk.
You need to set your $esp to the $esp partition in the emmc device. Not " I created a partition and mount it in /boot/efi."

An emmc partition is like "/dev/mmcblk1boot0" not /dev/sdxy.
Even then, some emmc laptops specifications (like uefi firmware) are not 'tuned' for dual-booting. You may have to try bios-legacy boots if you have a problem with uefi.

Also can it run well in livecd boot? Is the celeron and other specs good enough?
Try out in live OS first before you attempt installation.

I just tried to make esp on SSD. I didn't want it on EMMC.

Also can it run well in livecd boot? Is the celeron and other specs good enough?

It runs great. At least for my tasks.

Try out in live OS first before you attempt installation.

I've already tried Ubuntu and Manjaro in virtual machine.

So i made this



And got this



It's at least not empty anymore. Looks like i shouldn't try this on SSD.

So it works now with Manjaro $esp in emmc and not in ssd?
You're welcome.

I didn't say it works. I said - these 2 strings have appeared. If i try use them i get grub rescue black screen

Is your (manjaro) $esp now in emmc device?
Or still in ssd?

ps: It's going to be a long night.

~$ echo $esp


It was empty as in SSD, as in EMMC.

Nope. Not this command.
Need command below

sudo parted -l

Oh my.



Can you print, not screen shot?

Forum kindly sponsored by